Les prémices

Créer un nouveau tableur

Créer une nouvelle feuille de calcul :

  1. Ouvrir Documents et accéder à la section ou au dossier dans lequel la feuille de calcul doit être créée.

  2. Cliquer sur Nouveau et sélectionner Feuille de calcul.

    Astuce

    Alternativement, depuis le dossier Tous, cliquer sur Nouveau et sélectionner Feuille de calcul, puis sélectionner dans quel Dossier la feuille de calcul doit être créée.

  3. Cliquer sur Tableur vierge ou, pour créer un nouveau tableur à partir d’un modèle existant, sélectionner le modèle approprié.

  4. Cliquez sur Créer.

  5. Cliquer sur Feuille de calcul sans titre en haut de l’écran pour modifier le nom de la feuille de calcul.

Astuce

Il est également possible de créer une nouvelle feuille de calcul en :

Dans ces cas, la nouvelle feuille de calcul est enregistrée dans Documents dans le dossier personnel Mon lecteur.

Modèles

Les modèles de feuille de calcul permettent de créer rapidement des feuilles de calcul sans partir de zéro. Par exemple, vous pourriez créer un modèle pour un rapport budgétaire mensuel ou un rapport de commission de ventes trimestriel.

Note

Les modèles sont accessibles à tous les utilisateurs sur la base de données.

Créer un modèle

Tout tableur peut être enregistré comme modèle.

Pour créer un modèle :

  1. Ouvrir la feuille de calcul pertinente ou créer une nouvelle.

  2. Dans la barre de menus, cliquer sur Fichier ‣ Enregistrer comme modèle. Modifier le Nom du modèle par défaut si nécessaire et cliquer sur Confirmer.

Important

Une fois qu’une feuille de calcul est enregistrée comme modèle, toute modification ultérieure de la feuille de calcul ouverte est enregistrée uniquement dans cette feuille de calcul. Pour apporter des modifications au modèle, il faut modifier le modèle.

Il est également possible de créer un modèle en copiant un modèle existant et en le modifiant.

Utiliser les modèles

Pour créer une nouvelle feuille de calcul à partir d’un modèle, ouvrir l’application Documents et cliquer sur Nouveau ‣ Feuille de calcul. Sélectionner le modèle approprié et cliquer sur Créer.

Alternativement, aller dans Documents ‣ Configuration ‣ Modèles de feuille de calcul, puis sur la ligne du modèle approprié, cliquer sur Nouvelle feuille de calcul.

Note

Par défaut, la nouvelle feuille de calcul hérite du nom du modèle, affiché en haut de l’écran. Pour renommer la feuille de calcul, cliquer sur le nom et le modifier.

Gérer et modifier les modèles

Gérez les modèles en allant aux Documents ‣ Configuration ‣ Modèles de feuille de calcul. Supprimez le filtre Mes modèles pour afficher tous les modèles dans la base de données.

Diverses actions sont possibles :

  • Copier un modèle existant en cliquant sur Faire une copie à droite de l’écran. Le nouveau modèle apparaît en bas de la liste. Cliquer sur le Nom pour le modifier.

  • Modifier un modèle existant (y compris celui que vous venez de copier) en cliquant sur Modifier, puis effectuer les changements requis. Les modifications sont automatiquement enregistrées.

  • Supprimer un modèle en cochant la case à côté de celui-ci, en cliquant sur Actions, puis sur Supprimer.

Téléverser des fichiers

Les fichiers au format .xlsx ou .csv peuvent être téléversés dans Documents et ouverts avec Odoo Spreadsheet. Pour ce faire :

  1. Ouvrir Documents et accéder à la section ou au dossier où la feuille de calcul doit être enregistrée.

  2. Cliquer sur Nouveau et sélectionner Téléverser.

  3. Sélectionner le fichier .xlsx ou .csv concerné et cliquer sur Ouvrir.

  4. Cliquer sur le fichier téléversé.

  5. Par défaut, le fichier d’origine est supprimé lorsqu’il est ouvert avec Odoo Spreadsheet. Pour conserver le fichier d’origine dans le même dossier dans Documents, désactiver Envoyer le fichier source à la corbeille.

  6. Cliquer sur Ouvrir avec Odoo Spreadsheet.

Le fichier peut maintenant être entièrement modifié dans Odoo Spreadsheet.

Actions de base sur les feuilles

Les utilisateurs disposant des droits d”Éditeur sur la feuille de calcul ont plusieurs options pour gérer les feuilles depuis la barre inférieure :

  • (plus) : ajoute une nouvelle feuille à droite de la feuille active.

  • Cliquer sur la (flèche vers le bas) sur l’onglet d’une feuille ou faire un clic droit sur l’onglet pour ouvrir un menu contenant les options suivantes :

    • Supprimer : supprime la feuille, après demande de confirmation.

    • Masquer la feuille : masque la feuille de la barre inférieure et la rend inaccessible aux utilisateurs disposant uniquement des droits de Lecteur.

    • Dupliquer : crée une copie de la feuille à côté de la feuille d’origine.

    • Renommer : rend le nom de la feuille directement modifiable dans son onglet.

      Astuce

      Sinon, double-cliquer sur l’onglet de la feuille pour modifier directement son nom.

    • Changer la couleur de l’onglet : sélectionner une couleur existante ou personnalisée pour ajouter une barre de couleur au bas de l’onglet de la feuille. Les couleurs d’onglets apparaissent sous forme de points à côté du nom de la feuille lors de l’utilisation de l’icône (menu) pour afficher la liste de toutes les feuilles de la feuille de calcul.

    • Déplacer la feuille vers la droite ou Déplacer la feuille vers la gauche : déplace la feuille d’une position vers la droite ou vers la gauche.

      Astuce

      Sinon, cliquer et faire glisser l’onglet d’une feuille vers la position souhaitée.

Masquer les feuilles

Les utilisateurs disposant des droits Éditeur sur la feuille de calcul peuvent masquer une ou plusieurs feuilles en cliquant sur l’icône (curseur vers le bas) sur l’onglet d’une feuille ou en faisant un clic droit sur l’onglet, puis en cliquant sur Masquer la feuille. Cela peut être utile pour les feuilles qui ne sont pas prêtes à être partagées avec d’autres personnes, ou pour les feuilles utilisées pour des calculs par d’autres feuilles.

La feuille est alors supprimée de la barre inférieure, mais reste incluse, avec son nom grisé, dans la liste de toutes les feuilles accessibles via l’icône (menu) icon.

Utilisateurs avec :

  • les seuls droits Lecteur sur la feuille de calcul ne permettent pas d’ouvrir une feuille masquée.

  • Éditeur peuvent ouvrir une feuille masquée via l’icône (menu) ; cela rétablit l’onglet de la feuille sur la barre inférieure.

Gérer les feuilles de calcul

Les utilisateurs disposant des droits Éditeur sur une feuille de calcul spécifique ont plusieurs options pour gérer la feuille de calcul via le menu Fichier :

  • Faire une copie : crée un duplicata de la feuille de calcul actuelle avec les mêmes paramètres régionaux (ou locale).

  • Partager : permet de configurer les droits d’accès à la feuille de calcul et de la Partager avec des utilisateurs spécifiques ou de copier un lien partageable. Pour une feuille de calcul contenant des données Odoo dynamiques qui doit être partagée avec un utilisateur qui ne dispose pas des droits d’accès appropriés aux données, il est possible de Figer et partager la feuille de calcul.

    Voir également

    Accès et partage

  • Télécharger : télécharge la feuille de calcul au format .xlsx.

    Important

    Lors du téléchargement d’une feuille de calcul au format .xlsx, toute formule de feuille de calcul qui récupère des données Odoo depuis la base de données, par exemple via une liste insérée ou via d’autres fonctions spécifiques à Odoo, est convertie en valeurs qu’elle aurait retournées au moment du téléchargement de la feuille de calcul.

    Astuce

    Les utilisateurs disposant des droits Lecteur peuvent également télécharger une feuille de calcul au format .xlsx.

  • Imprimer : imprime une copie de la feuille de calcul sur une imprimante connectée.

  • Enregistrer comme modèle : permet d’utiliser la feuille de calcul actuelle comme modèle pour de futures feuilles de calcul.

  • Mettre à la corbeille : déplace la feuille de calcul vers le dossier corbeille de l’application Documents

    Astuce

    Les éléments dans le dossier corbeille sont définitivement supprimés après 30 jours.

  • Ajouter au tableau de bord : convertit la feuille de calcul actuelle en tableau de bord Odoo.

  • Voir l’historique des versions : fournit un accès en lecture seule aux versions précédentes de la feuille de calcul actuelle, qui peuvent être nommées et restaurées si nécessaire.

  • Paramètres : permet de voir et de modifier la locale de la feuille de calcul actuelle.

Historique des versions

Odoo Spreadsheet enregistre automatiquement les versions des feuilles de calcul au fur et à mesure des modifications, permettant aux utilisateurs disposant des droits Éditeur de parcourir et de restaurer les versions précédentes.

Pour accéder à l’historique des versions d’une feuille de calcul, cliquez sur Fichier ‣ Voir l’historique des versions depuis la barre de menu. Les versions enregistrées apparaissent dans un panneau à droite de la feuille de calcul. Le nom de l’utilisateur ayant effectué la modification est affiché, ainsi que la date et l’heure de la modification.

Les actions suivantes sont possibles :

  • Consulter une version antérieure en format lecture seule en cliquant sur la version concernée.

  • Restaurer une version antérieure en cliquant sur (ellipse verticale) puis Restaurer cette version.

  • Copier une version antérieure en cliquant sur (ellipse verticale) puis Faire une copie. Une copie de la version s’ouvre en tant que nouvelle feuille de calcul.

  • Créer des versions nommées en cliquant sur la date et l’heure de la version concernée et en saisissant le nom souhaité. La date et l’heure de la version sont alors affichées sous le nouveau nom.

Astuce

Lors de la consultation d’une version antérieure en lecture seule d’une feuille de calcul, les actions suivantes restent possibles :

  • Rechercher dans la feuille de calcul en cliquant sur Édition ‣ Rechercher et remplacer ou en utilisant le raccourci Ctrl + H.

  • Copier une cellule individuelle ou une zone sélectionnée en cliquant sur Édition ‣ Copier ou en utilisant le raccourci Ctrl + C.

Paramètres régionaux

Pour garantir que les données sont affichées de manière cohérente pour tous les utilisateurs, les paramètres régionaux (ou locale) d’une feuille de calcul sont gérés au niveau de la feuille de calcul. Cette locale affecte les paramètres et formats suivants :

  • séparateurs de milliers et de décimales

  • formats de date et d’heure

  • premier jour de la semaine

Par défaut, une nouvelle feuille de calcul hérite des paramètres régionaux de l’utilisateur qui l’a créée. Par exemple, toute feuille de calcul créée par un utilisateur dont la langue est définie sur Français (BE) / Français (BE) suivra les conventions du français belge.

La locale d’une feuille de calcul peut être consultée et modifiée à tout moment par un utilisateur disposant des droits Éditeur. Pour consulter la locale d’une feuille de calcul, cliquez sur Fichier ‣ Paramètres depuis la barre de menu. Le panneau Paramètres de la feuille de calcul s’ouvre à droite de la feuille de calcul. Pour modifier la locale, sélectionnez la locale appropriée dans le menu déroulant.

Astuce

Lorsque vous ouvrez une feuille de calcul dont la locale diffère de celle de votre profil utilisateur, une icône bleue (globe) apparaît en haut à droite de la feuille de calcul. Survoler l’icône révèle un message d’avertissement qui indique la locale de la feuille de calcul et met en évidence les formats qui diffèrent.

Avertissement concernant la différence entre la locale de l'utilisateur et celle de la feuille de calcul

Si aucune icône globe n’est affichée, cela signifie que les paramètres régionaux de la feuille de calcul sont identiques à ceux de votre profil utilisateur.

Convertir une feuille de calcul en tableau de bord

Un utilisateur avec les droits d’accès appropriés peut convertir un tableur Odoo en tableau de bord accessible via Tableaux de bord Odoo. Pour ce faire :

  1. Cliquer sur Fichier ‣ Ajouter au tableau de bord dans la barre de menu.

  2. Saisir le Nom du tableau de bord.

  3. Sélectionner la Section du tableau de bord pertinente dans la liste déroulante ou, pour créer une nouvelle section de tableau de bord, saisir le nom de la nouvelle section, puis cliquer sur Créer.

  4. Si nécessaire, modifier les Groupes d’accès pour déterminer quels groupes d’utilisateurs peuvent accéder au tableau de bord.

  5. Cliquez sur Créer.

Astuce

  • Par défaut, le premier onglet du tableur sert d’interface pour le tableau de bord.

  • Il est également possible de convertir un tableur en tableau de bord depuis les paramètres de configuration du tableau de bord, en ajoutant directement le tableur à une section de tableau de bord existante ou nouvelle.

  • Une fois qu’un tableur a été converti en tableau de bord, il est supprimé de Documents Odoo. Toute modification ultérieure doit être effectuée via Tableaux de bord Odoo.

Caractéristiques et limites des feuilles

Important

Le nombre de colonnes et de lignes par feuille peut affecter les performances du tableur. Toutefois, le facteur principal est souvent la nature des formules utilisées et des plages qu’elles doivent analyser. En particulier, les formules créant un comportement quadratique, où des formules copiées sur de nombreuses lignes analysent chacune une plage étendue, peuvent gravement affecter les performances avec de grands ensembles de données.

Une nouvelle feuille dans un tableur Odoo contient par défaut 26 colonnes (c’est-à-dire les colonnes A à Z) et 100 lignes. Des colonnes et des lignes supplémentaires peuvent être ajoutées selon les besoins, en gardant à l’esprit les points suivants :

  • Colonnes : bien qu’il n’existe aucune limite technique au nombre de colonnes pouvant être affichées dans une feuille, les formules d’Odoo Spreadsheet ne prennent en charge que les références de colonnes à 3 lettres, ce qui signifie qu’une formule faisant référence, par exemple, à la colonne AAAA, générera une erreur.

    La limite pratique du nombre de colonnes par feuille est donc de 18 278 colonnes (c’est-à-dire jusqu’à la colonne ZZZ).

  • Lignes : il n’existe pas de limite fixe au nombre de lignes qu’une feuille peut contenir.

    Astuce

    Pour ajouter rapidement un maximum de 10 000 lignes en bas de la feuille en une seule fois, faire défiler jusqu’en bas de la feuille, saisir le nombre de lignes souhaité, puis cliquer sur Ajouter.

  • Cellules et caractères par cellule : il n’existe pas de limite fixe au nombre de cellules qu’une feuille peut contenir, ni au nombre de caractères dans une cellule.