เริ่มเลย

สร้างสปรีดชีตใหม่

วิธีสร้างสปรีดชีตใหม่:

  1. เปิด Odoo เอกสารและไปที่ส่วนหรือโฟลเดอร์ที่ต้องการสร้างสปรีดชีต

  2. คลิก ใหม่ และเลือก สปรีดชีต

    Tip

    อีกวิธีหนึ่งจาก โฟลเดอร์ ทั้งหมด ให้คลิก ใหม่ และเลือก สปรีดชีต จากนั้นเลือก โฟลเดอร์ ที่ต้องการสร้างสปรีดชีต

  3. คลิก Blank spreadsheet หรือเพื่อสร้างสปรดชีตใหม่โดยใช้ เทมเพลต ที่มีอยู่ ให้เลือกเทมเพลตที่เกี่ยวข้อง

  4. คลิก สร้าง

  5. คลิกที่ Untitled spreadsheet ด้านบนของหน้าจอเพื่อแก้ไขชื่อของสปรีดชีต

Tip

นอกจากนี้ยังสามารถสร้างสปรีดชีตใหม่ได้โดย:

ในกรณีเหล่านี้ สปรีดชีตใหม่จะถูกบันทึกใน Odoo เอกสารในโฟลเดอร์ส่วนตัว ไดรฟ์ของฉัน

เทมเพลต

เทมเพลตสเปรดชีตช่วยให้คุณสร้างสเปรดชีตได้อย่างรวดเร็วโดยไม่ต้องเริ่มต้นจากศูนย์ ตัวอย่างเช่น คุณสามารถสร้างเทมเพลตสำหรับรายงานงบประมาณรายเดือนหรือรายงานค่าคอมมิชชั่นการขายรายไตรมาส

Note

เทมเพลตพร้อมใช้งานสำหรับผู้ใช้ทุกคนในฐานข้อมูล

สร้างเทมเพลต

สปรดชีตใดๆ ก็ตามสามารถบันทึกเป็นเทมเพลตได้

วิธีสร้างเทมเพลต:

  1. เปิดสปรดชีตที่เกี่ยวข้องหรือ สร้างใหม่

  2. จากแถบเมนู คลิก File ‣ Save as template แก้ไข Template Name เริ่มต้นหากจำเป็น แล้วคลิก Confirm

Important

เมื่อสปรดชีตถูกบันทึกเป็นเทมเพลตแล้ว การเปลี่ยนแปลงใดๆ ต่อสปรดชีตที่เปิดอยู่จะถูกบันทึกเฉพาะในสปรดชีตนั้นเท่านั้น หากต้องการเปลี่ยนแปลงเทมเพลต คุณต้อง แก้ไขเทมเพลต

คุณยังสามารถสร้างเทมเพลตได้โดย ทำสำเนาของเทมเพลตที่มีอยู่และแก้ไข

ใช้เทมเพลต

หากต้องการสร้างสเปรดชีตใหม่โดยใช้เทมเพลต ให้เปิดแอปเอกสารและคลิก ใหม่ ‣ สเปรดชีต เลือกเทมเพลตที่เกี่ยวข้องและคลิก สร้าง

หรือไปที่ เอกสาร ‣ การกำหนดค่า ‣ เทมเพลตสเปรดชีต จากนั้นที่บรรทัดของเทมเพลตที่เกี่ยวข้อง คลิก สเปรดชีตใหม่

Note

ตามค่าเริ่มต้น สเปรดชีตใหม่จะสืบทอดชื่อของเทมเพลต ซึ่งแสดงที่ด้านบนของหน้าจอ หากต้องการเปลี่ยนชื่อสเปรดชีต ให้คลิกที่ชื่อและแก้ไข

จัดการและแก้ไขเทมเพลต

จัดการเทมเพลตโดยไปที่ เอกสาร ‣ การกำหนดค่า ‣ เทมเพลตสเปรดชีต ลบ เทมเพลตของฉัน ตัวกรอง เพื่อดูเทมเพลตทั้งหมดในฐานข้อมูล

สามารถดำเนินการต่างๆ ได้:

  • คัดลอกเทมเพลตที่มีอยู่โดยคลิก ทำสำเนา ที่ด้านขวาของหน้าจอ เทมเพลตใหม่จะปรากฏที่ด้านล่างของรายการ คลิก ชื่อ เพื่อแก้ไข

  • แก้ไขเทมเพลตที่มีอยู่ (รวมถึงเทมเพลตที่คุณเพิ่งคัดลอก) โดยคลิก แก้ไข จากนั้นทำการเปลี่ยนแปลงที่ต้องการ การเปลี่ยนแปลงจะถูกบันทึกโดยอัตโนมัติ

  • ลบเทมเพลตโดยทำเครื่องหมายในช่องถัดจากเทมเพลต คลิก การดำเนินการ จากนั้น ลบ

อัปโหลดไฟล์

ไฟล์ในรูปแบบ .xlsx หรือ .csv สามารถอัปโหลดเข้าสู่ Odoo เอกสารและเปิดด้วย Odoo Spreadsheet ได้ โดยทำดังนี้:

  1. เปิด Odoo เอกสารและไปที่ส่วนหรือโฟลเดอร์ที่ต้องการบันทึกสปรีดชีต

  2. คลิก ใหม่ และเลือก อัปโหลด

  3. เลือกไฟล์ .xlsx หรือ .csv ที่ต้องการและคลิก เปิด

  4. คลิกที่ไฟล์ที่อัปโหลด

  5. ตามค่าเริ่มต้น ไฟล์ต้นฉบับจะถูกลบเมื่อเปิดด้วย Odoo Spreadsheet หากต้องการเก็บไฟล์ต้นฉบับไว้ในโฟลเดอร์เดียวกันใน Odoo เอกสาร ให้ปิดการใช้งาน ส่งไฟล์ต้นฉบับไปยังถังขยะ

  6. คลิก เปิดด้วย Odoo Spreadsheet

ตอนนี้ไฟล์สามารถแก้ไखได้อย่างสมบูรณ์ใน Odoo Spreadsheet

การดำเนินการพื้นฐานกับแผ่นงาน

Users with Editor rights to the spreadsheet have various options for managing the sheets of a spreadsheet from the bottom bar:

  • (บวก): เพิ่มแผ่นงานใหม่ทางด้านขวาของแผ่นงานที่ใช้งานอยู่

  • คลิก (แคเร็ตลง) บนแท็บของแผ่นงาน หรือคลิกขวาที่แท็บเพื่อเปิดเมนูที่มีตัวเลือกต่อไปนี้:

    • ลบ: ลบแผ่นงานหลังจากได้รับการยืนยัน

    • ซ่อนแผ่นงาน: ซ่อนแผ่นงาน จากแถบด้านล่างและทำให้ผู้ใช้ที่มีสิทธิ์เพียง ผู้ดู ไม่สามารถเข้าถึงได้

    • ทำซ้ำ: สร้างสำเนาของแผ่นงานข้างๆ แผ่นงานต้นฉบับ

    • เปลี่ยนชื่อ: ทำให้สามารถแก้ไขชื่อแผ่นงานได้โดยตรงในแท็บของแผ่นงาน

      Tip

      หรือดับเบิลคลิกที่แท็บของแผ่นงานเพื่อแก้ไขชื่อแผ่นงานโดยตรง

    • เปลี่ยนสีแท็บ: เลือกสีที่มีอยู่หรือสีกำหนดเองเพื่อเพิ่มแถบสีที่ด้านล่างของแท็บแผ่นงาน สีของแท็บจะปรากฏเป็นจุดข้างชื่อแผ่นงานเมื่อใช้ไอคอน (เมนู) เพื่อดูรายชื่อแผ่นงานทั้งหมดในสเปรดชีต

    • ย้ายแผ่นงานไปทางขวา หรือ ย้ายแผ่นงานไปทางซ้าย: ย้ายแผ่นงานไปทางขวาหรือซ้ายหนึ่งตำแหน่ง

      Tip

      หรือคลิกและลากแท็บของแผ่นงานไปยังตำแหน่งที่ต้องการ

ซ่อนชีต

ผู้ใช้ที่มีสิทธิ์ ผู้แก้ไข ในสเปรดชีตสามารถซ่อนหนึ่งชีตหรือมากกว่านั้นได้โดยการคลิก (แคร์เตร์ลง) บนแท็บของชีต หรือคลิกขวาที่แท็บ จากนั้นให้คลิก ซ่อนชีต ซึ่งอาจมีประโยชน์สำหรับชีตที่ยังไม่พร้อมจะแชร์กับผู้อื่น หรือชีตที่ใช้สำหรับการคำนวณโดยชีตอื่นๆ

จากนั้นชีตนั้นจะถูกลบออกจากแถบด้านล่าง แต่ยังคงถูกรวมอยู่ในรายการชีตทั้งหมดที่สามารถเข้าถึงได้ผ่านไอคอน (เมนู) โดยชื่อของชีตจะเป็นสีเทา

ผู้ใช้ที่มี:

  • สิทธิ์ ผู้ดู ในสเปรดชีตเท่านั้นไม่สามารถเปิดชีตที่ถูกซ่อนได้

  • ผู้แก้ไข สิทธิ์ดังกล่าวสามารถเปิดชีตที่ซ่อนอยู่ได้ผ่านไอคอน (เมนู) ซึ่งการดำเนินการนี้จะกู้คืนแท็บของชีตบนแถบด้านล่าง

จัดการสปรีดชีต

ผู้ใช้ที่มีสิทธิ์:guilabel:Editor`สำหรับสปรีดชีตเฉพาะจะมีตัวเลือกต่างๆ ในการจัดการสปรีดชีตผ่านเมนู:guilabel:`File:

  • สร้างสำเนา: สร้างสำเนาของสเปรดชีตปัจจุบันด้วย:ref:`การตั้งค่าภูมิภาค <spreadsheet/get-started/manage-spreadsheets-locale>`เดียวกัน (หรือโลแคล)

  • แชร์: ช่วยให้คุณกำหนดค่าสิทธิ์การเข้าถึงสเปรดชีตและ:guilabel:`แชร์`กับผู้ใช้เฉพาะหรือคัดลอกลิงก์ที่แชร์ได้ สำหรับสเปรดชีตที่มีข้อมูล Odoo แบบไดนามิกที่ต้องการแชร์กับผู้ใช้ที่ไม่มีสิทธิ์การเข้าถึงข้อมูลที่เหมาะสม สามารถ:guilabel:`ตรึงและแชร์`สเปรดชีตได้

  • ดาวน์โหลด: ดาวน์โหลดสเปรดชีตในรูปแบบ .xlsx

    Important

    เมื่อคุณดาวน์โหลดสเปรดชีตในรูปแบบ .xlsx สูตรสเปรดชีตใด ๆ ที่ดึงข้อมูล Odoo จากฐานข้อมูลของคุณ เช่น ผ่าน:doc:รายการที่แทรก <insert>`หรือผ่าน:doc:`ฟังก์ชันเฉพาะของ Odoo <work_with_data/functions> จะถูกแปลงเป็นค่าที่จะส่งกลับมา ณ เวลาที่ดาวน์โหลดสเปรดชีต

    Tip

    ผู้ใช้ที่มีสิทธิ์:guilabel:Viewer`สามารถดาวน์โหลดสปรีดชีตในรูปแบบ `.xlsx ได้เช่นกัน

  • Print: พิมพ์สำเนาของสปรีดชีตบนเครื่องพิมพ์ที่เชื่อมต่อ

  • บันทึกเป็นเทมเพลต: ช่วยให้สเปรดชีตปัจจุบันสามารถใช้เป็น:ref:`เทมเพลต <spreadsheet/get-started/templates>`สำหรับสเปรดชีตในอนาคต

  • ย้ายไปยังถังขยะ: ย้ายสเปรดชีตไปยังโฟลเดอร์ถังขยะของแอป เอกสาร

    Tip

    รายการในโฟลเดอร์ถังขยะจะถูกลบอย่างถาวรหลังจาก 30 วัน

  • เพิ่มไปยังแดชบอร์ด: แปลง

  • ดูประวัติเวอร์ชั่น: ให้:ref:`การเข้าถึงเวอร์ชั่นก่อนหน้า <spreadsheet/get-started/manage-spreadsheets-versioning>`ของสเปรดชีตปัจจุบันแบบอ่านอย่างเดียว ซึ่งสามารถตั้งชื่อและกู้คืนได้หากจำเป็น

  • การตั้งค่า: ช่วยให้คุณดูและเปลี่ยน:ref:`โลแคล <spreadsheet/get-started/manage-spreadsheets-locale>`ของสเปรดชีตปัจจุบัน

ประวัติเวอร์ชั่น

Odoo Spreadsheet จะบันทึกเวอร์ชั่นของสปรีดชีตโดยอัตโนมัติเมื่อมีการเปลี่ยนแปลง ทำให้ผู้ใช้ที่มีสิทธิ์:guilabel:`Editor`สามารถเรียกดูและกู้คืนเวอร์ชั่นก่อนหน้านี้ได้

หากต้องการเข้าถึงประวัติเวอร์ชั่นของสปรีดชีต ให้คลิก:menuselection:File --> :menuselection:`See version history`จากแถบเมนู เวอร์ชั่นที่บันทึกไว้จะปรากฏในแผงด้านขวาของสปรีดชีต ชื่อของผู้ใช้ที่ทำการเปลี่ยนแปลงจะถูกแสดง รวมถึงวันที่และเวลาของการเปลี่ยนแปลง

การดำเนินการต่อไปนี้สามารถทำได้:

  • **ดูเวอร์ชั่นก่อนหน้า**ในรูปแบบอ่านอย่างเดียวโดยคลิกที่เวอร์ชั่นที่เกี่ยวข้อง

  • **กู้คืนเวอร์ชั่นก่อนหน้า**โดยคลิก:icon:fa-ellipsis-v (vertical ellipsis)`จากนั้น:guilabel:`Restore this version

  • **คัดลอกเวอร์ชั่นก่อนหน้า**โดยคลิก:icon:fa-ellipsis-v (vertical ellipsis)`จากนั้น:menuselection:`Make a copy สำเนาของเวอร์ชั่นจะเปิดเป็นสปรีดชีตใหม่

  • **สร้างเวอร์ชั่นที่มีชื่อ**โดยคลิกที่วันที่และเวลาของเวอร์ชั่นที่เกี่ยวข้องและป้อนชื่อที่ต้องการ วันที่และเวลาของเวอร์ชั่นจะแสดงด้านล่างชื่อใหม่

Tip

เมื่อดูเวอร์ชั่นก่อนหน้าแบบอ่านอย่างเดียวของสปรีดชีต การดำเนินการต่อไปนี้ยังคงสามารถทำได้:

  • ค้นหาในสปรีดชีตโดยคลิก:menuselection:Edit --> Find and replace`หรือใช้แป้นพิมพ์ลัด `Ctrl + H

  • คัดลอกเซลล์แต่ละเซลล์หรือพื้นที่ที่เลือกโดยคลิก:menuselection:Edit --> Copy`หรือใช้แป้นพิมพ์ลัด `Ctrl + C

การตั้งค่าภูมิภาค

เพื่อให้แน่ใจว่าข้อมูลแสดงอย่างสม่ำเสมอสำหรับผู้ใช้ทุกคน การตั้งค่าภูมิภาค (หรือ locale) ของสปรีดชีตจะถูกจัดการในระดับสปรีดชีต locale นี้ส่งผลต่อการตั้งค่าและรูปแบบต่อไปนี้:

  • ตัวคั่นหลักพันและทศนิยม

  • รูปแบบวันที่และเวลา

  • วันแรกของสัปดาห์

โดยค่าเริ่มต้น สปรีดชีตใหม่จะสืบทอดการตั้งค่าภูมิภาคของผู้ใช้ที่สร้างมัน ตัวอย่างเช่น สปรีดชีตใดๆ ที่สร้างโดยผู้ใช้ที่มีการตั้งค่าภาษาเป็น:guilabel:`French (BE) / Français (BE)`จะปฏิบัติตามหลักเกณฑ์ภาษาฝรั่งเศสของเบลเยียม

โลแคลของสปรีดชีตสามารถดูและเปลี่ยนแปลงได้ตลอดเวลาโดยผู้ใช้ที่มีสิทธิ์ Editor ในการดูโลแคลของสปรีดชีต ให้คลิก File ‣ Settings จากแถบเมนู แผง Spreadsheet settings จะเปิดขึ้นทางด้านขวาของสปรีดชีต ในการเปลี่ยนโลแคล ให้เลือกโลแคลที่เหมาะสมจากรายการแบบเลื่อนลง

Tip

เมื่อคุณเปิดสปรีดชีตที่มีโลแคลแตกต่างจากโปรไฟล์ผู้ใช้ของคุณ ไอคอน (globe) สีน้ำเงินจะปรากฏที่มุมขวาบนของสปรีดชีต การเลื่อนเมาส์ไปเหนือไอคอนจะแสดงข้อความเตือนที่ระบุโลแคลของสปรีดชีตและเน้นรูปแบบที่แตกต่างกัน

คำเตือนเกี่ยวกับความแตกต่างระหว่างโลแคลของผู้ใช้และสปรีดชีต

หากไม่มีไอคอน (globe) แสดงขึ้น นั่นหมายความว่าโลแคลของสปรีดชีตเหมือนกับโปรไฟล์ผู้ใช้ของคุณ

แปลงสปรีดชีตเป็นแดชบอร์ด

ผู้ใช้ที่มี สิทธิ์การเข้าถึง ที่เหมาะสมสามารถแปลงสปรีดชีต Odoo เป็นแดชบอร์ดที่สามารถเข้าถึงได้ผ่าน แดชบอร์ด Odoo โดยดำเนินการดังนี้:

  1. คลิก ไฟล์ ‣ เพิ่มไปยังแดชบอร์ด จากแถบเมนู

  2. ป้อน ชื่อแดชบอร์ด

  3. เลือก ส่วนของแดชบอร์ด ที่เกี่ยวข้องจากรายการแบบเลื่อนลง หรือหากต้องการสร้างส่วนของแดชบอร์ดใหม่ ให้พิมพ์ชื่อของส่วนใหม่ จากนั้นคลิก สร้าง

  4. หากจำเป็น ให้แก้ไข กลุ่มการเข้าถึง เพื่อกำหนดว่า กลุ่มผู้ใช้ ใดสามารถเข้าถึงแดชบอร์ดได้

  5. คลิก สร้าง

Tip

  • โดยค่าเริ่มต้น แท็บแรกของสปรีดชีตจะทำหน้าที่เป็นส่วนหน้าของแดชบอร์ด

  • นอกจากนี้ยังสามารถแปลงสปรีดชีตเป็นแดชบอร์ดจาก การตั้งค่าการกำหนดค่าแดชบอร์ด ได้โดยการเพิ่มสปรีดชีตไปยังส่วนของแดชบอร์ดที่มีอยู่หรือส่วนใหม่โดยตรง

  • หลังจากแปลงสปรีดชีตเป็นแดชบอร์ดแล้ว สปรีดชีตจะถูกลบออกจากเอกสาร Odoo การแก้ไข ที่ตามมาจะต้องทำผ่านแดชบอร์ด Odoo

ข้อมูลจำเพาะและขีดจำกัดของแผ่นงาน

Important

จำนวนคอลัมน์และแถวต่อแผ่นงานอาจส่งผลต่อประสิทธิภาพของสเปรดชีตได้ อย่างไรก็ตาม ปัจจัยหลักมักเกิดจากลักษณะของสูตรที่ใช้และช่วงข้อมูลที่ต้องสแกน โดยเฉพาะสูตรที่สร้างพฤติกรรมเชิงกำลังสอง (quadratic behavior) ซึ่งสูตรที่คัดลอกลงมาหลายแถวจะสแกนช่วงข้อมูลขนาดใหญ่ในแต่ละแถว อาจส่งผลกระทบอย่างรุนแรงต่อประสิทธิภาพการทำงานในชุดข้อมูลขนาดใหญ่

แผ่นงานใหม่ในสเปรดชีต Odoo จะประกอบด้วย 26 คอลัมน์ (เช่น คอลัมน์ A-Z) และ 100 แถวตามค่าเริ่มต้น คุณสามารถเพิ่มคอลัมน์และแถวเพิ่มเติมได้ตามต้องการ โดยคำนึงถึงข้อควรทราบต่อไปนี้:

  • คอลัมน์: แม้ว่าจะไม่มีข้อจำกัดทางเทคนิคเกี่ยวกับจำนวนคอลัมน์ที่สามารถ*แสดงผล*ในแผ่นงานได้ แต่สูตรใน Odoo Spreadsheet รองรับการอ้างอิงคอลัมน์ที่มีตัวอักษรไม่เกิน 3 ตัวเท่านั้น ซึ่งหมายความว่าสูตรที่อ้างอิง เช่น คอลัมน์ AAAA จะส่งผลให้เกิดข้อผิดพลาด

    ดังนั้น ขีดจำกัดในการใช้งานจริงของจำนวนคอลัมน์ต่อแผ่นงานจึงอยู่ที่ 18,278 คอลัมน์ (เช่น สูงสุดถึงคอลัมน์ ZZZ)

  • แถว: ไม่มีการจำกัดจำนวนแถวตายตัวที่แผ่นงานสามารถมีได้

    Tip

    หากต้องการเพิ่มแถวด้านล่างสุดของแผ่นงานสูงสุด 10,000 แถวในคราวเดียวอย่างรวดเร็ว ให้เลื่อนไปที่ด้านล่างของแผ่นงาน ระบุจำนวนแถวที่ต้องการ จากนั้นคลิก เพิ่ม.

  • เซลล์และจำนวนอักขระต่อเซลล์: ไม่มีการจำกัดจำนวนเซลล์ตายตัวที่แผ่นงานสามารถมีได้ และไม่มีการจำกัดจำนวนอักขระภายในเซลล์เช่นกัน