Rozpocznij

Utwórz nowy arkusz kalkulacyjny

Aby utworzyć nowy arkusz kalkulacyjny:

  1. Otwórz Dokumenty Odoo i przejdź do sekcji lub folderu, w którym należy utworzyć arkusz kalkulacyjny.

  2. Kliknij Nowy i wybierz Arkusz kalkulacyjny.

    Wskazówka

    Alternatywnie, z folderu Wszystkie, kliknij Nowy i wybierz Arkusz kalkulacyjny, a następnie wybierz, w jakim Folderze powinien zostać utworzony arkusz kalkulacyjny.

  3. Kliknij Pusty arkusz kalkulacyjny lub, aby utworzyć nowy arkusz kalkulacyjny przy użyciu istniejącego szablonu, wybierz odpowiedni szablon.

  4. Kliknij Utwórz.

  5. Kliknij na Untitled spreadsheet u góry ekranu, aby edytować nazwę arkusza kalkulacyjnego.

Wskazówka

Możliwe jest również utworzenie nowego arkusza kalkulacyjnego poprzez:

W takich przypadkach nowy arkusz kalkulacyjny jest zapisywany w Dokumentach Odoo w folderze osobistym Mój dysk.

Szablony

Szablony arkuszy kalkulacyjnych pozwalają szybko tworzyć arkusze bez zaczynania od zera. Można na przykład utworzyć szablon miesięcznego raportu budżetowego lub kwartalnego raportu prowizji od sprzedaży.

Informacja

Szablony są dostępne dla wszystkich użytkowników w bazie danych.

Utwórz szablon

Dowolny arkusz kalkulacyjny można zapisać jako szablon.

Aby utworzyć szablon:

  1. Otwórz odpowiedni arkusz kalkulacyjny lub utwórz nowy.

  2. Z paska menu kliknij Plik ‣ Zapisz jako szablon. W razie potrzeby zmodyfikuj domyślną Nazwę szablonu i kliknij Potwierdź.

Ważne

Po zapisaniu arkusza kalkulacyjnego jako szablonu wszelkie kolejne zmiany w otwartym arkuszu są zapisywane tylko w tym arkuszu. Aby wprowadzić zmiany w szablonie, należy edytować szablon.

Możesz również utworzyć szablon tworząc kopię istniejącego szablonu i edytując go.

Użyj szablonów

Aby utworzyć nowy arkusz kalkulacyjny na podstawie szablonu, otwórz aplikację Dokumenty i kliknij Nowy ‣ Arkusz kalkulacyjny. Wybierz odpowiedni szablon i kliknij Utwórz.

Alternatywnie przejdź do Dokumenty ‣ Konfiguracja ‣ Szablony arkuszy kalkulacyjnych, a następnie w wierszu odpowiedniego szablonu kliknij Nowy arkusz kalkulacyjny.

Informacja

Domyślnie nowy arkusz kalkulacyjny dziedziczy nazwę szablonu, która jest wyświetlana u góry ekranu. Aby zmienić nazwę arkusza, kliknij nazwę i edytuj ją.

Zarządzaj i edytuj szablony

Zarządzaj szablonami, przechodząc do Dokumenty ‣ Konfiguracja ‣ Szablony arkuszy kalkulacyjnych. Usuń filtr Moje szablony, aby wyświetlić wszystkie szablony w bazie danych.

Możliwe są różne działania:

  • Skopiuj istniejący szablon, klikając Wykonaj kopię po prawej stronie ekranu. Nowy szablon pojawi się na dole listy. Kliknij Nazwa, aby ją edytować.

  • Edytuj istniejący szablon (w tym właśnie skopiowany), klikając Edytuj, a następnie wprowadzając wymagane zmiany. Modyfikacje są automatycznie zapisywane.

  • Usuń szablon, zaznaczając pole wyboru obok niego, klikając Akcje, a następnie Usuń.

Prześlij pliki

Pliki w formacie .xlsx lub .csv mogą być przesłane do Dokumentów Odoo i otwarte za pomocą Arkusza kalkulacyjnego Odoo. Aby to zrobić:

  1. Otwórz Dokumenty Odoo i przejdź do sekcji lub folderu, w którym arkusz kalkulacyjny powinien zostać zapisany.

  2. Kliknij Nowy i wybierz Prześlij.

  3. Wybierz odpowiedni plik .xlsx lub .csv i kliknij Otwórz.

  4. Kliknij na przesłany plik.

  5. Domyślnie oryginalny plik jest usuwany, gdy zostanie otwarty za pomocą Arkusza kalkulacyjnego Odoo. Aby zachować oryginalny plik w tym samym folderze w Dokumentach Odoo, wyłącz Wyślij plik źródłowy do kosza.

  6. Kliknij Otwórz za pomocą Arkusza kalkulacyjnego Odoo.

Plik może być teraz w pełni edytowany w Arkuszu kalkulacyjnym Odoo.

Zarządzaj arkuszami kalkulacyjnymi

Użytkownicy z prawami Edytora do konkretnego arkusza kalkulacyjnego mają różne opcje zarządzania arkuszem kalkulacyjnym za pomocą menu Plik:

  • Utwórz kopię: tworzy duplikat bieżącego arkusza kalkulacyjnego z tymi samymi ustawieniami regionalnymi (lub lokalizacją).

  • Udostępnij: umożliwia skonfigurowanie praw dostępu do arkusza kalkulacyjnego i Udostępnienie go konkretnym użytkownikom lub skopiowanie linku do udostępniania. W przypadku arkusza kalkulacyjnego zawierającego dynamiczne dane Odoo, który ma być udostępniony użytkownikowi nieposiadającemu odpowiednich praw dostępu do danych, możliwe jest Zamrożenie i udostępnienie arkusza kalkulacyjnego.

  • Pobierz: pobiera arkusz kalkulacyjny w formacie .xlsx.

    Ważne

    Po pobraniu arkusza kalkulacyjnego w formacie .xlsx wszelkie formuły arkusza pobierające dane Odoo z bazy danych, np. za pomocą wstawionej listy lub innych funkcji specyficznych dla Odoo, są konwertowane na wartości, które zostałyby zwrócone w momencie pobrania arkusza kalkulacyjnego.

    Wskazówka

    Użytkownicy z prawami Widza mogą również pobrać arkusz kalkulacyjny w formacie .xlsx.

  • Drukuj: drukuje kopię arkusza kalkulacyjnego na podłączonej drukarce.

  • Zapisz jako szablon: umożliwia wykorzystanie bieżącego arkusza kalkulacyjnego jako szablonu dla przyszłych arkuszy kalkulacyjnych.

  • Przenieś do kosza: przenosi arkusz kalkulacyjny do folderu kosza aplikacji Dokumenty

    Wskazówka

    Elementy w folderze kosza są trwale usuwane po 30 dniach.

  • Dodaj do konsoli: konwertuje bieżący arkusz kalkulacyjny na konsolę Odoo.

  • Zobacz historię wersji: zapewnia dostęp tylko do odczytu do poprzednich wersji bieżącego arkusza kalkulacyjnego, które można nazwać i w razie potrzeby przywrócić.

  • Ustawienia: umożliwia wyświetlenie i zmianę lokalizacji bieżącego arkusza kalkulacyjnego.

Historia wersji

Arkusz kalkulacyjny Odoo automatycznie zapisuje wersje arkuszy kalkulacyjnych w miarę wprowadzania zmian, umożliwiając użytkownikom z prawami Edytora przeglądanie i przywracanie poprzednich wersji.

Aby uzyskać dostęp do historii wersji arkusza kalkulacyjnego, kliknij Plik ‣ Zobacz historię wersji z paska menu. Zapisane wersje pojawiają się w panelu po prawej stronie arkusza kalkulacyjnego. Wyświetlana jest nazwa użytkownika, który dokonał zmiany, a także data i godzina zmiany.

Możliwe są następujące działania:

  • Wyświetl wcześniejszą wersję w formacie tylko do odczytu, klikając na odpowiednią wersję.

  • Przywróć wcześniejszą wersję, klikając (pionowe wielokropek), a następnie Przywróć tę wersję.

  • Skopiuj wcześniejszą wersję, klikając (pionowe wielokropek), a następnie Utwórz kopię. Kopia wersji zostanie otwarta jako nowy arkusz kalkulacyjny.

  • Twórz nazwane wersje, klikając na datę i godzinę odpowiedniej wersji i wprowadzając żądaną nazwę. Data i godzina wersji są następnie wyświetlane poniżej nowej nazwy.

Wskazówka

Podczas przeglądania wcześniejszej wersji arkusza kalkulacyjnego tylko do odczytu nadal możliwe są następujące działania:

  • Przeszukaj arkusz kalkulacyjny, klikając Edycja ‣ Znajdź i zamień lub używając skrótu Ctrl + H.

  • Skopiuj pojedynczą komórkę lub wybrany obszar, klikając Edycja ‣ Kopiuj lub używając skrótu Ctrl + C.

Ustawienia regionalne

Aby zapewnić spójne wyświetlanie danych dla wszystkich użytkowników, ustawienia regionalne (lub ustawienia lokalne) arkusza kalkulacyjnego są zarządzane na poziomie arkusza. Te ustawienia lokalne wpływają na następujące ustawienia i formaty:

  • separatory tysięcy i separatory dziesiętne

  • formaty daty i czasu

  • pierwszy dzień tygodnia

Domyślnie nowy arkusz kalkulacyjny dziedziczy ustawienia regionalne użytkownika, który go utworzył. Na przykład wszystkie arkusze kalkulacyjne utworzone przez użytkownika, którego język jest ustawiony na Francuski (BE) / Français (BE), będą zgodne z belgijskimi konwencjami języka francuskiego.

Ustawienia lokalne arkusza kalkulacyjnego mogą być wyświetlane i zmieniane w dowolnym momencie przez użytkownika z uprawnieniami Edytor. Aby wyświetlić ustawienia lokalne arkusza kalkulacyjnego, kliknij Plik ‣ Ustawienia z paska menu. Panel Ustawienia arkusza kalkulacyjnego otworzy się po prawej stronie arkusza. Aby zmienić ustawienia lokalne, wybierz odpowiednie ustawienia z menu rozwijanego.

Wskazówka

Gdy otwierasz arkusz kalkulacyjny, który ma inne ustawienia lokalne niż Twój profil użytkownika, niebieski (globus) ikona pojawia się w prawym górnym rogu arkusza. Po najechaniu na ikonę pojawia się komunikat ostrzegawczy, który wskazuje ustawienia lokalne arkusza i wyróżnia różniące się formaty.

Ostrzeżenie o różnicy między ustawieniami lokalnymi użytkownika i arkusza kalkulacyjnego

Jeśli nie jest wyświetlana żadna ikona (globus), oznacza to, że ustawienia lokalne arkusza kalkulacyjnego są takie same jak ustawienia Twojego profilu użytkownika.

Konwertuj arkusz kalkulacyjny na konsolę

Użytkownik z odpowiednimi prawami dostępu może przekonwertować arkusz kalkulacyjny Odoo na konsolę, która jest następnie dostępna przez Konsole Odoo. Aby to zrobić:

  1. Kliknij Plik ‣ Dodaj do konsoli z paska menu.

  2. Wprowadź Nazwę konsoli.

  3. Wybierz odpowiednią Sekcję konsoli z listy rozwijanej lub, aby utworzyć nową sekcję konsoli, wpisz nazwę nowej sekcji, a następnie kliknij Utwórz.

  4. Jeśli to konieczne, zmodyfikuj Grupy dostępu, aby określić, które grupy użytkowników mogą uzyskać dostęp do konsoli.

  5. Kliknij Utwórz.

Wskazówka

  • Domyślnie pierwsza zakładka arkusza kalkulacyjnego służy jako interfejs użytkownika konsoli.

  • Możliwe jest również przekonwertowanie arkusza kalkulacyjnego na konsolę z poziomu ustawień konfiguracji konsoli, poprzez bezpośrednie dodanie arkusza kalkulacyjnego do istniejącej lub nowej sekcji konsoli.

  • Po przekonwertowaniu arkusza kalkulacyjnego na konsolę, zostaje on usunięty z aplikacji Dokumenty Odoo. Wszelkie kolejne modyfikacje należy wprowadzać przez Konsole Odoo.

Sheet specifications and limits

Ważne

The number of columns and rows per sheet can affect spreadsheet performance. However, the main factor is often the nature of the formulas used and the ranges they need to scan. In particular, formulas that create quadratic behavior, where formulas copied down many rows each scan a large range, can severely impact performance in large datasets.

A new sheet in an Odoo spreadsheet contains 26 columns (i.e., columns A-Z) and 100 rows by default. Additional columns and rows can be added according to your needs, keeping the following points in mind:

  • Columns: While there is no technical limit on the number of columns that can be displayed in a sheet, formulas in Odoo Spreadsheet only support 3-letter column references, which means that a formula referencing, e.g., column AAAA, will result in an error.

    The practical limit on the number of columns per sheet is therefore 18,278 columns (i.e., up to column ZZZ).

  • Rows: There is no fixed limit on the number of rows a sheet can contain.

    Wskazówka

    To quickly add a maximum of 10,000 rows to the bottom of the sheet in one go, scroll to the bottom of the sheet, enter the desired number of rows, then click Add.

  • Cells and characters per cell: There is no fixed limit on the number of cells a sheet can contain, nor on the number of characters within a cell.