Wstawianie i łączenie z danymi Odoo¶
Kilka elementów z bazy danych Odoo można wstawić do arkusza kalkulacyjnego Odoo, mianowicie:
listy, tj. dane z widoku listy
tabele przestawne, tj. dane z widoku przestawnego
wykresy, tj. dane z widoku wykresu
Za każdym razem, gdy zostaje wstawiona lista, tabela przestawna lub wykres, tworzone jest źródło danych. To źródło danych łączy arkusz kalkulacyjny z bazą danych Odoo, pobierając aktualne informacje za każdym razem, gdy arkusz zostanie otwarty, strona przeglądarki zostanie przeładowana lub dane zostaną ręcznie odświeżone przez kliknięcie z paska menu.
Wstawione listy i wstawione tabele przestawne wykorzystują formuły ze specyficznymi dla Odoo funkcjami list i funkcjami tabel przestawnych do pobierania danych z bazy danych i mogą być dalej przetwarzane w arkuszu kalkulacyjnym. Niektóre elementy wstawionych wykresów można modyfikować, ale nie jest możliwa manipulacja danymi ani wykonywanie obliczeń.
Informacja
Listy, tabele przestawne i wykresy z różnych aplikacji i modeli można wstawić do tego samego arkusza kalkulacyjnego.
Wskazówka
Jeśli zamierzasz używać filtrów globalnych do dynamicznego filtrowania danych Odoo w arkuszu kalkulacyjnym lub konsoli, nie używaj tych samych warunków do utworzenia początkowej listy, tabeli przestawnej lub wykresu w bazie danych.
Możliwe jest również:
dodawanie klikalnych linków do pozycji menu Odoo, do innych arkuszy tego samego arkusza kalkulacyjnego lub do zewnętrznych adresów URL
wstawianie danych finansowych z bazy danych Odoo przy użyciu specyficznych dla Odoo funkcji arkusza kalkulacyjnego
wklejanie danych z innego arkusza kalkulacyjnego Odoo, arkusza Excel lub arkusza Google bezpośrednio do dowolnego arkusza kalkulacyjnego Odoo
Źródła danych¶
Źródła danych, które są tworzone za każdym razem, gdy lista, tabela przestawna lub wykres zostają wstawione do arkusza kalkulacyjnego Odoo, łączą arkusz kalkulacyjny z odpowiednim modelem w bazie danych, utrzymując dane w arkuszu na bieżąco.
Każde źródło danych jest zdefiniowane przez właściwości dostępne w menu Data. Źródła danych są identyfikowane przez odpowiednią ikonę (tabela przestawna), (lista) lub (wykres), po której następuje ich ID i nazwa, np. (#1) Analiza sprzedaży według produktu.
Kliknięcie źródła danych otwiera powiązane właściwości w panelu po prawej stronie arkusza.
Wskazówka
Panel właściwości można również otworzyć, klikając prawym przyciskiem myszy dowolną komórkę wstawionej listy lub tabeli przestawnej, a następnie klikając Zobacz właściwości listy lub Zobacz właściwości tabeli przestawnej, lub klikając ikonę (menu) w prawym górnym rogu wstawionego wykresu, a następnie klikając Edytuj.
Po otwarciu właściwości konkretnego źródła danych pozostają one otwarte nawet podczas przechodzenia między zakładkami arkusza. Aby zamknąć panel właściwości, kliknij ikonę (zamknij) w prawym górnym rogu panelu.
Informacja
Usunięcie wstawionej listy lub tabeli przestawnej lub usunięcie arkusza, do którego zostały wstawione, nie usuwa bazowego źródła danych. Źródło danych wstawionej listy lub tabeli przestawnej można usunąć tylko za pośrednictwem właściwości źródła danych.
Ostrzeżenie w menu Data identyfikuje wszystkie źródła danych, dla których odpowiadająca im lista lub tabela przestawna nie jest już widoczna w arkuszu.
Z drugiej strony usunięcie wstawionego wykresu usuwa również bazowe źródło danych.
Wstaw listę¶
Ważne
Przed wstawieniem listy do arkusza kalkulacyjnego upewnij się, że lista jest dostosowana do Twoich potrzeb. Zastanów się, które pola powinny być widoczne oraz jak rekordy są filtrowane i/lub sortowane. Może to wpłynąć zarówno na czas ładowania, jak i przyjazność arkusza kalkulacyjnego dla użytkownika.
Aby wstawić listę:
Mając otwartą odpowiedni widok listy w bazie danych, kliknij ikonę (Akcje) obok nazwy widoku, a następnie .
Informacja
Aby wstawić tylko konkretne rekordy, zaznacz odpowiednie rekordy, kliknij przycisk Akcje, który pojawi się u góry ekranu na środku, a następnie Wstaw w arkuszu kalkulacyjnym.
W oknie, które się otworzy, edytuj Nazwę listy, jeśli to konieczne.
Nazwa listy jest używana w nazwie arkusza i we właściwościach listy.
W razie potrzeby edytuj liczbę rekordów, tj. wierszy, które mają zostać wstawione.
Domyślnie wyświetlana liczba to liczba rekordów widocznych na pierwszej stronie listy. Na przykład, jeśli lista zawiera 150 rekordów, ale widocznych jest tylko 80, w tym polu zostanie wyświetlone 80.
Informacja
Chociaż dane na liście są aktualizowane dzięki połączeniu z bazą danych, wstawiona lista nie rozszerzy się automatycznie, aby pomieścić nowe rekordy, np. nową kategorię produktu lub nowego sprzedawcę.
Jeśli przewidujesz dodanie nowych rekordów, rozważ dodanie dodatkowych wierszy podczas wstawiania listy. Rekordy/wiersze można również dodać ręcznie po wstawieniu arkusza.
Example
Twoja firma ma obecnie dziesięć kategorii produktów i wstawiasz tę listę w arkuszu kalkulacyjnym. Jeśli zostanie utworzona jedenasta kategoria produktu, a wstawiona lista miała tylko dziesięć wierszy, nowa kategoria zostanie wstawiona w odpowiednim miejscu w arkuszu kalkulacyjnym, usuwając w ten sposób istniejącą kategorię.
Jednym ze sposobów na uniknięcie tego jest dodanie dodatkowych wierszy podczas wstawiania listy.
Kliknij Pusty arkusz lub wybierz, do którego istniejącego arkusza lista powinna zostać wstawiona.
Informacja
Nowe arkusze są zapisywane w aplikacji Odoo Dokumenty w osobistym obszarze roboczym Mój dysk lub, jeśli dla arkuszy włączono centralizację plików, w obszarze roboczym Arkusz kalkulacyjny.
Kliknij Potwierdź.
Lista jest wstawiana do nowego arkusza w arkuszu kalkulacyjnym. Zakładka arkusza na dolnym pasku pokazuje nazwę listy, a następnie ID listy, np. Oferty według sumy (Lista #1). Panel po prawej stronie ekranu pokazuje właściwości listy.
Wskazówka
Aby wyświetlić pojedynczy rekord wstawionej listy, kliknij prawym przyciskiem myszy dowolną komórkę odpowiedniego wiersza, a następnie kliknij Zobacz rekord. Aby wrócić do arkusza kalkulacyjnego, kliknij nazwę arkusza kalkulacyjnego w okruchach nawigacyjnych u góry widoku.
Aby zerwać połączenie między wstawioną listą a bazą danych, zaznacz całą listę, kliknij prawym przyciskiem myszy i wybierz Kopiuj, a następnie kliknij ponownie prawym przyciskiem myszy i wybierz .
Nie modyfikuj ID listy w nazwie arkusza, ponieważ wstawiona lista zachowuje ten ID przez cały czas trwania arkusza kalkulacyjnego. Ten ID listy jest używany w funkcjach arkusza, które pobierają dane z bazy danych.
Funkcje listy¶
Gdy lista jest wstawiana do arkusza kalkulacyjnego, następujące funkcje są używane odpowiednio do pobierania nagłówka i wartości pól:
=ODOO.LIST.HEADER(list_id, field_name)
=ODOO.LIST(list_id, index, field_name)
Argumenty funkcji są następujące:
list_id: identyfikator przypisany podczas wstawiania listy. Pierwsza lista wstawiona do arkusza kalkulacyjnego otrzymuje identyfikator listy1, druga identyfikator listy2itd.index: identyfikuje wiersz, w którym rekord pojawił się na liście przed wstawieniem. Pierwszy wiersz ma indeks1, drugi ma indeks2itd.field_name: nazwa techniczna pola.
Wskazówka
Kliknięcie pojedynczej komórki powoduje wyświetlenie powiązanej formuły, jeśli dotyczy, na pasku formuły. Aby wyświetlić wszystkie formuły arkusza kalkulacyjnego jednocześnie, kliknij na pasku menu. Poniższy przykład pokazuje funkcje używane do pobierania nagłówków i wartości listy.
Lista właściwości¶
Właściwości listy pojawiają się po prawej stronie ekranu, gdy lista zostanie wstawiona. Można uzyskać do nich dostęp w dowolnym momencie za pośrednictwem menu Dane, klikając odpowiednią listę, oznaczoną ikoną (lista), lub klikając prawym przyciskiem myszy gdziekolwiek na liście i wybierając Zobacz właściwości listy.
Wyświetlane są następujące właściwości listy, z których niektóre można edytować:
Lista nr: identyfikator listy. Identyfikatory list są przypisywane sekwencyjnie w miarę wstawiania kolejnych list do arkusza kalkulacyjnego.
Nazwa listy: nazwa listy. W razie potrzeby można ją edytować. Należy pamiętać, że edycja nazwy listy we właściwościach listy nie modyfikuje nazwy listy wyświetlanej w nazwie arkusza i odwrotnie.
Model: model, z którego zostały wyodrębnione dane.
Kolumny: pola modelu, które były widoczne w momencie wstawiania listy.
Domena: reguły używane do określenia, które rekordy są wyświetlane. Kliknij Edytuj domenę, aby dodać lub edytować reguły.
Informacja
Gdy używane są filtry globalne, ta domena jest łączona z wybranymi wartościami filtru globalnego przed załadowaniem danych do arkusza kalkulacyjnego.
Sortowanie: sposób sortowania danych, jeśli ma zastosowanie. Aby dodać regułę sortowania, kliknij Dodaj, wybierz pole, a następnie zdecyduj, czy sortowanie ma być Rosnące, czy Malejące. Usuń regułę sortowania, klikając ikonę (usuń).
Aby zduplikować lub usunąć źródło danych listy, kliknij ikonę (koło zębate), a następnie kliknij Duplikuj lub Usuń według potrzeby.
Zarządzanie wstawioną listą¶
Po wstawieniu listy z bazy danych Odoo do arkusza Odoo możesz:
dodać rekordy, tj. wiersze
dodać pola, tj. kolumny
zduplikować listę, aby utworzyć nowe, identyczne źródło danych
Dodawanie rekordów/wierszy do listy¶
Aby dodać rekordy do listy, użyj jednej z następujących metod:
Zaznacz ostatni wiersz tabeli, a następnie najedź kursorem na niebieski kwadrat, aż pojawi się ikona plusa. Kliknij i przeciągnij w dół, aby dodać żądaną liczbę wierszy. Komórki nowych wierszy są wypełniane odpowiednią formułą w celu pobrania wartości listy. Jeśli w bazie danych znajdują się odpowiednie dane, komórki zostaną wypełnione.
Umieść kursor w lewej górnej komórce arkusza, kliknij z paska menu, a następnie wybierz odpowiednią listę. W wyświetlonym oknie wskaż liczbę rekordów do wstawienia i kliknij Potwierdź. Zaktualizowana lista zostanie wstawiona, zastępując poprzednią listę.
Wskazówka
Powyższe metody można również wykorzystać do dodania dodatkowych pustych wierszy do tabeli arkusza kalkulacyjnego. Może to być przydatne w przypadku list, dla których oczekiwane jest generowanie dodatkowych rekordów w bazie danych, np. nowych kategorii produktów lub nowych handlowców.
Dodawanie pól/kolumn do listy¶
Aby dodać pola/kolumny do listy:
Zaznacz kolumnę na prawo lub na lewo od miejsca, w którym ma zostać wstawiona nowa kolumna.
Kliknij , a następnie lub z paska menu albo kliknij prawym przyciskiem myszy, a następnie Wstaw kolumnę z lewej lub Wstaw kolumnę z prawej według potrzeb.
Skopiuj komórkę nagłówka dowolnej kolumny, wklej ją do komórki nagłówka nowej kolumny i naciśnij klawisz
Enter.Kliknij dwukrotnie nową komórkę nagłówka, a następnie kliknij nazwę pola, która pojawia się w cudzysłowie na końcu formuły; pojawi się lista wszystkich nazw technicznych pól powiązanego modelu.
Wybierz odpowiednią nazwę pola i naciśnij klawisz
Enter. W nagłówku pojawi się etykieta pola.Wskazówka
Aby poznać nazwę techniczną pola, przejdź do odpowiedniego widoku, aktywuj tryb programisty, a następnie sprawdź nazwę pola, najeżdżając kursorem na znak zapytania obok etykiety pola.
Gdy komórka nagłówka jest zaznaczona, kliknij dwukrotnie niebieski kwadrat w prawym dolnym rogu. Komórki kolumny zostaną wypełnione odpowiednią formułą w celu pobrania wartości z listy. Jeśli w bazie danych znajdują się odpowiadające dane, komórki zostaną wypełnione.
Duplikowanie listy¶
Duplikowanie listy za pośrednictwem właściwości listy tworzy dodatkowe źródło danych. Pozwala to na wykonywanie różnych operacji na tych samych danych w obrębie jednego arkusza kalkulacyjnego.
Po otwarciu właściwości listy kliknij ikonę (koło zębate), a następnie Duplikuj.
Nowemu źródłu danych przypisywany jest kolejny dostępny identyfikator listy. Na przykład, jeśli w międzyczasie nie zostały wstawione żadne inne listy, zduplikowanie Listy nr 1 spowoduje utworzenie Listy nr 2.
W przeciwieństwie do wstawiania listy, zduplikowana lista nie jest automatycznie wstawiana do arkusza kalkulacyjnego. Aby ją wstawić, wykonaj następujące kroki:
Dodaj nowy arkusz, klikając ikonę (dodaj arkusz) w lewym dolnym rogu arkusza kalkulacyjnego.
Kliknij z paska menu, a następnie wybierz odpowiednią listę.
Określ liczbę rekordów do wstawienia i kliknij Potwierdź.
W razie potrzeby edytuj Nazwę listy w panelu właściwości.
Zmień nazwę arkusza, klikając prawym przyciskiem myszy na zakładkę arkusza, wybierając Zmień nazwę i wpisując nową nazwę arkusza.
Informacja
Duplikowanie wstawionej listy przez skopiowanie i wklejenie jej lub przez zduplikowanie arkusza, do którego została wstawiona, nie tworzy nowego źródła danych. Wszelkie zmiany wprowadzone we właściwościach listy wpłynęłyby zatem na wszystkie kopie listy.
Usuń listę¶
Aby całkowicie usunąć listę i leżące u jej podstaw źródło danych z arkusza kalkulacyjnego, wykonaj następujące kroki w dowolnej kolejności:
Usuń tabelę arkusza kalkulacyjnego przy użyciu preferowanej metody, np. za pomocą poleceń klawiatury, menu arkusza kalkulacyjnego lub przez usunięcie arkusza. To usuwa wizualną reprezentację danych.
W panelu właściwości odpowiedniej listy kliknij ikonę (koło zębate), a następnie Usuń. Spowoduje to usunięcie źródła danych listy z arkusza kalkulacyjnego.
Wstaw tabelę przestawną¶
Wskazówka
Konwersja wstawionej tabeli przestawnej na dynamiczną tabelę przestawną pozwala na dodawanie, usuwanie i manipulowanie wymiarami (tj. kolumnami i wierszami) oraz miarami. Możliwe jest zatem wstawienie podstawowej tabeli przestawnej z minimalną konfiguracją, przekonwertowanie jej na dynamiczną tabelę przestawną, a następnie udoskonalenie jej bezpośrednio w arkuszu kalkulacyjnym.
Aby wstawić tabelę przestawną:
Gdy odpowiedni widok przestawny jest otwarty w bazie danych, kliknij Wstaw w arkuszu kalkulacyjnym.
W otwartym oknie w razie potrzeby edytuj Nazwę tabeli przestawnej.
Ta nazwa jest używana w nazwie arkusza oraz we właściwościach tabeli przestawnej.
Kliknij Pusty arkusz kalkulacyjny lub wybierz istniejący arkusz kalkulacyjny, do którego ma zostać wstawiona tabela przestawna.
Informacja
Nowe arkusze są zapisywane w aplikacji Odoo Dokumenty w osobistym obszarze roboczym Mój dysk lub, jeśli dla arkuszy włączono centralizację plików, w obszarze roboczym Arkusz kalkulacyjny.
Kliknij Potwierdź.
Tabela przestawna jest wstawiana do nowego arkusza w arkuszu kalkulacyjnym. Zakładka arkusza na dolnym pasku pokazuje nazwę tabeli przestawnej, po której następuje identyfikator tabeli przestawnej, np. Analiza sprzedaży według zespołu sprzedaży (Pivot #1). Panel po prawej stronie ekranu pokazuje właściwości tabeli przestawnej.
Wskazówka
Aby wyświetlić rekordy, do których odnosi się pojedyncza komórka tabeli przestawnej, kliknij prawym przyciskiem myszy na komórkę, a następnie kliknij Zobacz rekord. Aby wrócić do arkusza kalkulacyjnego, kliknij nazwę arkusza kalkulacyjnego w okruchach nawigacyjnych u góry widoku.
Aby zerwać połączenie między wstawioną tabelą przestawną a bazą danych, zaznacz całą tabelę przestawną, kliknij prawym przyciskiem myszy i wybierz Kopiuj, następnie kliknij prawym przyciskiem myszy ponownie i wybierz .
Nie należy modyfikować identyfikatora tabeli przestawnej w nazwie arkusza, ponieważ wstawiona tabela przestawna zachowuje ten identyfikator przez cały okres istnienia arkusza kalkulacyjnego. Ten identyfikator tabeli przestawnej jest używany w funkcjach arkusza kalkulacyjnego, które pobierają dane z bazy danych.
Funkcje tabeli przestawnej¶
Wstawiona tabela przestawna, która nie została przekonwertowana na dynamiczną tabelę przestawną, używa następujących funkcji odpowiednio do pobierania nagłówka i wartości pól:
=PIVOT.HEADER(pivot_id, [domain_field_name, …], [domain_value, …]) =PIVOT.VALUE(pivot_id, measure_name, [domain_field_name, …], [domain_value, …])
Argumenty funkcji są następujące:
pivot_id: identyfikator przypisany podczas wstawiania tabeli przestawnej. Pierwsza tabela przestawna wstawiona do arkusza kalkulacyjnego otrzymuje identyfikator przestawny1, druga identyfikator przestawny2itd.measure_name: nazwa techniczna tego, co jest mierzone, po której następuje typ agregacji, np.product_uom_qty:sum.name:
domain_field_name: nazwa techniczna pola używanego jako wymiar, np.user_id, lub, jeśli wymiarem jest okres czasu, nazwa techniczna pola daty, po której następuje okres czasu, np.date_order:month.domain_value: ID rekordu lub, jeśli wymiarem jest okres czasu, docelowa data lub okres czasu.
Wskazówka
Kliknięcie pojedynczej komórki wyświetla powiązaną formułę, jeśli jest to właściwe, na pasku formuł. Aby wyświetlić wszystkie formuły arkusza kalkulacyjnego jednocześnie, kliknij na pasku menu. Poniższy przykład pokazuje funkcje używane do pobierania nagłówków i wartości statycznej tabeli przestawnej.
Właściwości tabeli przestawnej¶
Właściwości tabeli przestawnej pojawiają się po prawej stronie ekranu po wstawieniu tabeli przestawnej. Można uzyskać do nich dostęp w dowolnym momencie za pośrednictwem menu Dane, klikając odpowiednią tabelę przestawną, poprzedzoną ikoną (tabela przestawna), lub klikając prawym przyciskiem myszy w dowolnym miejscu tabeli przestawnej i klikając Zobacz właściwości tabeli przestawnej.
Wyświetlane są następujące właściwości tabeli przestawnej, z których niektóre można edytować:
Pivot #: identyfikator tabeli przestawnej. Identyfikatory tabel przestawnych są przypisywane sekwencyjnie w miarę wstawiania dodatkowych tabel przestawnych do arkusza kalkulacyjnego.
Nazwa: nazwa tabeli przestawnej. W razie potrzeby edytuj tę nazwę. Należy pamiętać, że edycja nazwy we właściwościach tabeli przestawnej nie modyfikuje nazwy pokazanej w nazwie arkusza i odwrotnie.
Model: model, z którego zostały wyodrębnione dane.
Kolumny i Wiersze: wymiary, których używasz do kategoryzowania lub grupowania danych z modelu.
Miary: co mierzysz lub analizujesz, w oparciu o wybrane wymiary.
Wskazówka
Jeśli spróbujesz wprowadzić zmiany w kolumnach, wierszach lub miarach tabeli przestawnej, która została właśnie wstawiona do arkusza kalkulacyjnego, w prawym górnym rogu ekranu pojawi się błąd.
Aby móc manipulować właściwościami tabeli przestawnej, przekonwertuj statyczną tabelę przestawną na dynamiczną tabelę przestawną.
Domena: reguły używane do określenia, które rekordy są wyświetlane. Kliknij Edytuj domenę, aby dodać lub edytować reguły.
Informacja
Gdy używane są filtry globalne, ta domena jest łączona z wybranymi wartościami filtru globalnego przed załadowaniem danych do arkusza kalkulacyjnego.
Aby zduplikować lub usunąć źródło danych tabeli przestawnej, kliknij ikonę (koło zębate), a następnie Duplikuj lub Usuń.
Zarządzanie wstawioną tabelą przestawną¶
Po wstawieniu tabeli przestawnej z bazy danych Odoo do arkusza kalkulacyjnego Odoo możesz:
przekonwertować ją na dynamiczną tabelę przestawną, aby móc manipulować wymiarami i miarami
zduplikować tabelę przestawną, aby utworzyć nowe, identyczne źródło danych
Duplikowanie tabeli przestawnej¶
Duplikowanie tabeli przestawnej za pomocą właściwości tabeli przestawnej tworzy dodatkowe źródło danych. Pozwala to na wykonywanie różnych manipulacji na tych samych danych w ramach jednego arkusza kalkulacyjnego.
Na przykład możesz zobaczyć te same dane zagregowane według różnych wymiarów lub użyć filtrów globalnych, aby przesunąć datę i utworzyć tabele przestawne porównujące dane z bieżącego okresu z danymi z poprzedniego okresu.
Aby zduplikować tabelę przestawną, wykonaj następujące kroki:
Po otwarciu właściwości tabeli przestawnej kliknij ikonę (koło zębate), a następnie Duplikuj.
Zduplikowana tabela przestawna jest automatycznie wstawiana do nowego arkusza w arkuszu kalkulacyjnym, a właściwości tabeli przestawnej otwierają się w prawym panelu.
W razie potrzeby edytuj Nazwę w panelu właściwości i zakładkę arkusza.
Nowe źródło danych otrzymuje następny dostępny identyfikator tabeli przestawnej. Na przykład, jeśli w międzyczasie nie wstawiono żadnych innych tabel przestawnych, zduplikowanie Pivot #1 skutkuje utworzeniem Pivot #2.
Informacja
Duplikowanie wstawionej tabeli przestawnej przez skopiowanie i wklejenie jej lub przez zduplikowanie arkusza nie tworzy nowego źródła danych. Wszelkie zmiany wprowadzone we właściwościach tabeli przestawnej miałyby zatem wpływ na wszystkie kopie tabeli przestawnej.
Gdy tabela przestawna jest duplikowana, nowa tabela przestawna jest domyślnie dynamiczną tabelą przestawną.
Usuń tabelę przestawną¶
Aby całkowicie usunąć tabelę przestawną i bazowe źródło danych z arkusza kalkulacyjnego, wykonaj następujące kroki w dowolnej kolejności:
Usuń tabelę arkusza kalkulacyjnego przy użyciu preferowanej metody, np. za pomocą poleceń klawiatury, menu arkusza kalkulacyjnego lub przez usunięcie arkusza. To usuwa wizualną reprezentację danych.
Z panelu właściwości odpowiedniej tabeli przestawnej kliknij ikonę (koło zębate), a następnie Usuń. Spowoduje to usunięcie źródła danych tabeli przestawnej.
Wstaw wykres¶
Aby wstawić wykres z bazy danych Odoo do arkusza kalkulacyjnego Odoo:
Po otwarciu odpowiedniego widoku wykresu w bazie danych kliknij Wstaw do arkusza kalkulacyjnego.
W otwierającym się oknie edytuj Nazwę wykresu, jeśli to konieczne.
Kliknij Pusty arkusz kalkulacyjny lub wybierz istniejący arkusz kalkulacyjny, do którego ma zostać wstawiony wykres.
Informacja
Nowe arkusze są zapisywane w aplikacji Odoo Dokumenty w osobistym obszarze roboczym Mój dysk lub, jeśli dla arkuszy włączono centralizację plików, w obszarze roboczym Arkusz kalkulacyjny.
Kliknij Potwierdź.
Wykresy są wstawiane na pierwszym arkuszu arkusza kalkulacyjnego. Panel po prawej stronie ekranu pokazuje właściwości wykresu, gdzie można modyfikować różne aspekty konfiguracji i wyglądu wykresu.
Wskazówka
Kliknięcie punktu danych na wykresie otwiera odpowiedni widok listy w bazie danych. W tym przykładzie kliknięcie Jessica Childs otwiera widok listy wszystkich sprzedaży tego sprzedawcy, które pasują do domeny wykresu.
Wstawianie klikalnych linków¶
Dodawanie linków do powiązanych lub pomocniczych informacji może uczynić raport lub konsolę bardziej przyjaznymi dla użytkownika i skutecznymi.
Możesz wstawić klikalny link z dowolnej komórki arkusza kalkulacyjnego do:
elementu menu Odoo
innego arkusza w tym samym arkuszu kalkulacyjnym
zewnętrznego adresu URL
Informacja
Kliknięcie linku do elementu menu daje taki sam rezultat jak nawigacja przez menu Odoo w aplikacji, np. element menu Sprzedaż/Zamówienia/Oferty odpowiada widokowi domyślnemu podczas nawigacji do .
Możliwe jest również wstawienie klikalnego linku do określonego widoku modelu w arkuszu kalkulacyjnym, zaczynając od samego widoku. Jednak ponieważ ta metoda wstawia każdy nowy link w nowym arkuszu, bardziej efektywne jest tworzenie linków do określonych widoków zaczynając od arkusza kalkulacyjnego.
Możesz wstawić klikalny link z dowolnego wykresu do elementu menu Odoo.
Wstawianie klikalnego linku z komórki¶
Aby wstawić klikalny link z komórki:
Kliknij z paska menu lub kliknij prawym przyciskiem myszy na komórkę, następnie kliknij Wstaw link. Następnie, w zależności od pożądanego rezultatu, wykonaj jedną z następujących czynności:
Kliknij ikonę (menu), następnie Połącz z menu Odoo. Wybierz odpowiedni element menu z listy lub kliknij Wyszukaj więcej, aby wybrać z listy wszystkich elementów menu. Kliknij Potwierdź.
Kliknij ikonę (menu), następnie Połącz arkusz, następnie wybierz odpowiedni arkusz z bieżącego arkusza kalkulacyjnego.
W polu Link wpisz adres URL.
Wprowadź lub edytuj etykietę linku w polu Tekst.
Kliknij Potwierdź.
Wstawianie klikalnego linku z wykresu¶
Aby wstawić klikalny link z wykresu do elementu menu Odoo:
Najedź kursorem na prawy górny róg ramki wykresu, następnie kliknij ikonę (menu), następnie Edytuj. Właściwości wykresu pojawią się po prawej stronie ekranu.
Na dole karty Konfiguracja w panelu właściwości wykresu kliknij pod Link do menu Odoo, a następnie wybierz menu.
Najedź kursorem na prawy górny róg ramki wykresu, aby zobaczyć, że dodana została nowa ikona (link zewnętrzny).
Wstaw dane finansowe¶
Podczas tworzenia raportów i konsol przydatne może być uwzględnienie określonych danych księgowych, takich jak identyfikatory kont, uznania i obciążenia dla konkretnych kont oraz daty rozpoczęcia i zakończenia roku podatkowego.
Funkcje arkusza kalkulacyjnego specyficzne dla Odoo pozwalają na pobranie takich danych księgowych z bazy danych i wstawienie ich do arkusza kalkulacyjnego.