Udostępnianie i współpraca

Odoo Spreadsheet oferuje różne funkcje, które umożliwiają wydajną współpracę w czasie rzeczywistym, zapewniając jednocześnie odpowiedni poziom kontroli i identyfikowalności, w tym:

Dostęp i udostępnianie

Co do zasady prawa dostępu do arkuszy kalkulacyjnych Odoo są obsługiwane jak każdy inny plik w aplikacji Dokumenty. Role i uprawnienia są albo dziedziczone z folderu, w którym zapisany jest arkusz kalkulacyjny, albo kontrolowane na poziomie samego arkusza kalkulacyjnego.

Istnieją jednak istotne różnice do rozważenia między arkuszami kalkulacyjnymi zawierającymi tylko dane statyczne a arkuszami kalkulacyjnymi zawierającymi dynamiczne dane Odoo zarówno pod względem dostępu, jak i widoczności danych.

Wskazówka

  • Dostępem do folderu lub arkusza kalkulacyjnego może zarządzać jego właściciel lub każdy użytkownik z prawami Edytor.

  • Użytkownik z prawami Przeglądający nie może bezpośrednio udostępnić arkusza kalkulacyjnego konkretnemu użytkownikowi, ale może skopiować łącze do arkusza kalkulacyjnego.

  • Każdy użytkownik mający dostęp do arkusza kalkulacyjnego może pobrać go jako plik .xlsx, klikając Plik ‣ Pobierz z paska menu. Jeśli arkusz kalkulacyjny zawierał dane dynamiczne, wartości są zamrażane w momencie pobrania.

Role i uprawnienia

Uprawnienia są zarządzane za pomocą następujących ról:

Rola

Widok

Edytuj

Usuń

Pobierz .xlsx

Udostępnij

Zarządzaj rolami

Używaj komentarzy

Używaj chatter

Właściciel

z konkretnymi osobami lub za pomocą linku

włącznie ze zmianą właściciela

Edytor

z konkretnymi osobami lub za pomocą linku

ale nie można zmienić właściciela

Widz

tylko za pomocą linku

Udostępnij statyczny arkusz kalkulacyjny

Arkusze kalkulacyjne zawierające tylko dane statyczne mogą być udostępniane wewnętrznie lub zewnętrznie przez właściciela arkusza kalkulacyjnego lub dowolnego użytkownika z uprawnieniami Edytor.

W tym celu kliknij Udostępnij w prawym górnym rogu nad arkuszem kalkulacyjnym, a następnie skonfiguruj dostęp odpowiednio.

Udostępnij dynamiczny arkusz kalkulacyjny

Arkusz kalkulacyjny jest uznawany za dynamiczny arkusz kalkulacyjny, jeśli zawiera którykolwiek z następujących elementów:

Udostępnianie wewnętrzne

Arkusze kalkulacyjne zawierające dynamiczne dane Odoo mogą być udostępniane wyłącznie użytkownikom wewnętrznym przez właściciela arkusza lub dowolnego użytkownika z uprawnieniami Edytor.

Jednak posiadanie dostępu do arkusza kalkulacyjnego niekoniecznie oznacza, że użytkownik wewnętrzny widzi wszystkie dane z oryginalnego arkusza. Widoczność dynamicznych danych Odoo zależy od praw dostępu użytkownika wewnętrznego do modelu, z którego dane zostały pobrane, i uwzględnia wszelkie reguły rekordów, które mogą ograniczać dostęp.

Ważne

Uprawnienia do przeglądania danych są brane pod uwagę, gdy użytkownik wewnętrzny otwiera arkusz kalkulacyjny – arkusz jest wypełniany tylko danymi, które użytkownik jest uprawniony widzieć.

Example

Menedżer sprzedaży tworzy arkusz kalkulacyjny zawierający dane sprzedażowe dla wszystkich handlowców w swoim zespole. Użytkownicy z uprawnieniem „Sprzedaż / Użytkownik: Tylko własne dokumenty” widzą tylko dane związane z własnymi sprzedażami.

Aby udostępnić arkusz kalkulacyjny zawierający dynamiczne dane Odoo, kliknij Udostępnij w prawym górnym rogu nad arkuszem, a następnie skonfiguruj dostęp odpowiednio.

Udostępnianie zewnętrzne

Arkusze kalkulacyjne zawierające dynamiczne dane Odoo nie mogą być dostępne dla użytkowników zewnętrznych.

Informacja

Jeśli użytkownik zewnętrzny spróbuje uzyskać dostęp do dynamicznego arkusza za pomocą linku, wyświetlany jest komunikat o błędzie.

Jeśli arkusz kalkulacyjny zawierający dane Odoo musi zostać udostępniony użytkownikowi zewnętrznemu, właściciel arkusza lub użytkownik z uprawnieniami Edytor może utworzyć zamrożoną wersję tylko do odczytu. W tej wersji wszystkie formuły Odoo są konwertowane na ich wartości z momentu utworzenia zamrożonej wersji, a wszelkie linki do menu Odoo są usuwane.

Aby utworzyć zamrożoną wersję arkusza kalkulacyjnego zawierającego dynamiczne dane Odoo, kliknij Plik ‣ Udostępnij ‣ Zamroź i udostępnij w pasku menu, a następnie skonfiguruj dostęp odpowiednio.

Wskazówka

Możliwe jest również pobranie zamrożonej wersji arkusza kalkulacyjnego zawierającego dane Odoo jako pliku .xlsx, klikając Plik ‣ Pobierz w pasku menu. Wartości wszelkich dynamicznych danych są zamrażane w momencie pobrania.

Komentarze i czat

Odoo Spreadsheet oferuje dwa sposoby komunikacji z innymi użytkownikami mającymi dostęp do tego samego arkusza kalkulacyjnego, mianowicie przez użycie:

Używanie komentarzy w arkuszu kalkulacyjnym

Komentarze, które są dodawane do poszczególnych komórek arkusza, są przydatne do omawiania konkretnych elementów arkusza. Inni współpracownicy mogą zostać powiadomieni przez wpisanie @, a następnie ich nazwy.

Ważne

Tylko właściciel arkusza lub użytkownicy z uprawnieniami Edytor mogą używać komentarzy w arkuszu kalkulacyjnym; obie role mogą wykonywać te same działania. Komentarze nie są widoczne dla użytkowników z uprawnieniami Przeglądający.

Dodawanie komentarzy lub reagowanie na nie

Aby dodać komentarz lub na niego zareagować:

  1. Jeśli komentarz jest:

    • pierwszym komentarzem dodawanym do komórki, kliknij komórkę prawym przyciskiem myszy, a następnie kliknij Wstaw komentarz lub kliknij Wstaw ‣ Wstaw komentarz na pasku menu.

    • reakcją na istniejący wątek komentarzy w komórce, kliknij odpowiednią komórkę lub wątek komentarzy, aby otworzyć wątek.

  2. Wpisz komentarz w polu tekstowym.

    Wskazówka

    • Kliknij ikonę , a następnie:

      • Dodaj z Dokumentów, aby dodać plik zapisany w aplikacji Dokumenty

      • Dodaj GIF-y, aby dodać GIF-y (jeśli jest to włączone w Ustawieniach ogólnych)

    • Kliknij (Dodaj emotikony), aby dodać emotikony.

    • Wpisz @, a następnie nazwę użytkownika, aby oznaczyć go w komentarzu.

  3. Kliknij ikonę (Zapisz) lub naciśnij Enter, aby zapisać komentarz.

Kliknij w dowolnym miejscu arkusza kalkulacyjnego, aby zamknąć wątek komentarzy.

Wskazówka

Aby zareagować na pojedynczy komentarz wyłącznie emotikoną, najedź na komentarz, kliknij ikonę (Dodaj reakcję), a następnie wybierz żądaną emotikonę.

Wyświetlanie komentarzy

Gdy komentarz zostanie dodany do komórki, w prawym górnym rogu komórki pojawia się mały żółty trójkąt.

Aby wyświetlić wątek komentarzy w pojedynczej komórce, najedź na komórkę; kliknij komórkę lub wątek komentarzy, aby otworzyć wątek i móc dodać komentarz.

Aby wyświetlić wszystkie komentarze w arkuszu kalkulacyjnym, kliknij Widok ‣ Wszystkie komentarze na pasku menu. Alternatywnie, po otwarciu wątku komentarzy kliknij Otwórz wszystkie komentarze.

Panel Komentarze otwiera się po prawej stronie arkusza kalkulacyjnego. Domyślnie wyświetlane są wątki komentarzy dla Wszystkich arkuszy arkusza kalkulacyjnego, pogrupowane według arkusza. Aby zobaczyć tylko wątki komentarzy dla bieżącego arkusza, wybierz Ten arkusz w polu Filtruj komentarze.

Kliknij wątek komentarzy w panelu Komentarze, aby go otworzyć.

Edytowanie lub usuwanie komentarzy

Informacja

Właściciel arkusza kalkulacyjnego lub użytkownicy z uprawnieniami Edytora mogą edytować lub usuwać dowolny komentarz.

Aby edytować komentarz:

  1. Najedź kursorem na komentarz, a następnie kliknij ikonę (wielokropek).

  2. Kliknij Edytuj.

  3. Wprowadź żądane zmiany, a następnie kliknij Zapisz lub naciśnij Enter. Aby anulować edycję, kliknij Anuluj lub naciśnij Escape.

Wskazówka

Komentarz, który został zmodyfikowany, ma na końcu tekstu dopisek (edytowano).

Aby usunąć komentarz:

  1. Najedź kursorem na komentarz, a następnie kliknij ikonę (wielokropek).

  2. Kliknij Usuń.

  3. Kliknij Potwierdź, aby potwierdzić usunięcie.

Rozwiązywanie wątków komentarzy

Aby rozwiązać wątek komentarzy:

  1. Otwórz panel Komentarze, klikając Widok ‣ Wszystkie komentarze z paska menu. Alternatywnie, gdy wątek komentarzy jest otwarty, kliknij Otwórz wszystkie komentarze.

  2. Kliknij ikonę (wielokropek) dla odpowiedniego wątku komentarzy, a następnie kliknij Rozwiąż ten wątek.

Po rozwiązaniu wątek komentarzy nie jest już dostępny bezpośrednio w arkuszu kalkulacyjnym, ale pozostaje widoczny w panelu Komentarze; rozwiązane wątki są oznaczone ikoną (ptaszek).

Aby ponownie otworzyć rozwiązany wątek komentarzy, w panelu Komentarze kliknij ikonę (wielokropek) dla odpowiedniego wątku komentarzy, a następnie kliknij Otwórz ponownie ten wątek.

Korzystanie z wątku rozmów arkusza kalkulacyjnego

Podczas gdy komentarze do konkretnych komórek arkusza kalkulacyjnego nadają się do dyskusji o konkretnych elementach arkusza, wątek rozmów arkusza kalkulacyjnego pozwala na bardziej ogólną dyskusję.

Aby uzyskać dostęp do wątku rozmów arkusza kalkulacyjnego:

  1. Mając otwartą aplikację Dokumenty, przejdź do folderu lub sekcji, w której zapisano arkusz kalkulacyjny.

  2. Wybierz widok (Lista) w prawym górnym rogu.

  3. Wybierz odpowiedni arkusz kalkulacyjny, a następnie kliknij przycisk (Informacje i tagi) w prawym górnym rogu obok selektora widoku. Alternatywnie, mając wybrany arkusz kalkulacyjny, kliknij przycisk Akcja, a następnie wybierz (Informacje i tagi).

Wątek czatu arkusza kalkulacyjnego otwiera się po prawej stronie ekranu, poniżej panelu szczegółów arkusza kalkulacyjnego.