Să începem

Creează o nouă foaie de calcul

Pentru a crea o nouă foaie de calcul:

  1. Deschideți Odoo Documents și navigați la secțiunea sau dosarul în care ar trebui creată foaia de calcul.

  2. Faceți clic pe Nou și selectați Foaie de calcul.

    Sfat

    Alternativ, din dosarul All, faceți clic pe New și selectați Spreadsheet, apoi selectați în ce Workspace (adică dosar) ar trebui creat tabelul. Dacă centralizarea fișierelor a fost activată pentru tabele, veți avea, de asemenea, opțiunea de a salva noul tabel în dosarul Spreadsheet.

  3. Faceți clic pe Tabel gol sau, pentru a crea un tabel nou utilizând un șablon existent, selectați șablonul relevant.

  4. Faceți clic pe Creați.

  5. Faceți clic pe Foaie de calcul fără titlu în partea de sus a ecranului pentru a edita numele foii de calcul.

Sfat

Este posibil, de asemenea, să creați o nouă foaie de calcul:

În aceste cazuri, noul tabel este salvat în Odoo Documents în dosarul personal My Drive sau, dacă centralizarea fișierelor a fost activată pentru tabele, în dosarul Spreadsheet.

Șabloane

Șabloanele de tabel vă permit să creați rapid tabele fără a porni de la zero. De exemplu, puteți crea un șablon pentru un raport de buget lunar sau pentru un raport trimestrial de comisioane de vânzări.

Notă

Șabloanele sunt disponibile pentru toți utilizatorii din baza de date.

Creați un șablon

Orice tabel poate fi salvat ca șablon.

Pentru a crea un șablon:

  1. Deschideți tabelul relevant sau creați unul nou.

  2. Din bara de meniu, faceți clic pe Fișier ‣ Salvează ca șablon. Modificați Numele șablonului implicit dacă este necesar și faceți clic pe Confirmă.

Important

Odată ce un tabel este salvat ca șablon, orice modificări ulterioare aduse tabelului deschis sunt salvate doar în acel tabel. Pentru a face modificări la șablon, trebuie să editați șablonul.

Puteți crea, de asemenea, un șablon făcând o copie a unui șablon existent și editându-l.

Utilizați șabloane

Pentru a crea un tabel nou folosind un șablon, deschideți aplicația Documents și faceți clic pe Nou ‣ Tabel. Selectați șablonul relevant și faceți clic pe Creează.

Alternativ, accesați Documents ‣ Configurare ‣ Șabloane tabel apoi, pe linia șablonului relevant, faceți clic pe Tabel nou.

Notă

Implicit, noul tabel preia numele șablonului, care este afișat în partea de sus a ecranului. Pentru a redenumi tabelul, faceți clic pe nume și editați-l.

Gestionați și editați șabloanele

Gestionați șabloanele accesând Documente ‣ Configurare ‣ Șabloane de foi de calcul. Eliminați Șabloanele mele filtrul pentru a vedea toate șabloanele din baza de date.

Sunt posibile diverse acțiuni:

  • Copiați un șablon existent făcând clic pe Creează o copie în partea dreaptă a ecranului. Noul șablon va apărea la finalul listei. Faceți clic pe Nume pentru a-l edita.

  • Editați un șablon existent (inclusiv unul pe care tocmai l-ați copiat) făcând clic pe Editează, apoi efectuați modificările necesare. Modificările sunt salvate automat.

  • Ștergeți un șablon bifând caseta de lângă el, făcând clic pe Acțiuni, apoi pe Șterge.

Încarcă fișiere

Tabelele în format .xlsx pot fi încărcate în Odoo Documents și deschise ca tabel Odoo. Pentru a face acest lucru:

  1. Deschideți Odoo Documents și navigați la secțiunea sau dosarul în care ar trebui salvată foaia de calcul.

  2. Faceți clic pe Nou și selectați Încarcă.

  3. Selectați fișierul .xlsx relevant și faceți clic pe Open.

  4. Faceți clic pe fișierul încărcat.

  5. În mod implicit, fișierul original .xlsx este șters atunci când este deschis ca tabel Odoo. Pentru a păstra fișierul original în același dosar în Odoo Spreadsheet, dezactivați Send source file to trash.

  6. Faceți clic pe Open with Odoo Spreadsheet.

Fișierul este acum un tabel Odoo și poate fi editat complet în Odoo Spreadsheet.

Gestionare foi de calcul

Utilizatorii cu drepturi de Editor pentru o foaie de calcul specifică au diverse opțiuni pentru gestionarea foii de calcul prin meniul File:

  • Creează o copie: creează un duplicat al tabelului curent cu aceleași setări regionale (sau locale).

  • Salvează ca șablon: permite ca tabelul curent să fie utilizat ca șablon pentru tabelele viitoare.

  • Download: descarcă tabelul în format .xlsx.

    Important

    Când descărcați un tabel în format .xlsx, orice formule de tabel care preiau date Odoo din baza dvs. de date, de ex., printr-o listă inserată sau prin alte funcții specifice Odoo, sunt convertite în valorile pe care le-ar fi returnat în momentul în care tabelul a fost descărcat.

    Sfat

    Utilizatorii cu drepturi de Viewer pot de asemenea descărca o foaie de calcul în format .xlsx.

  • Vezi istoricul versiunilor: oferă acces doar în citire la versiunile anterioare ale foii de calcul curente, care pot fi denumite și restaurate dacă este necesar.

  • Print: imprimă o copie a foii de calcul pe o imprimantă conectată.

  • Setări: vă permite să vizualizați și să modificați setările regionale ale foii de calcul curente.

  • Adaugă în tablou de bord: convertește foaia de calcul curentă într-un tablou de bord Odoo.

Versiunea istorică

Odoo Spreadsheet salvează automat versiuni ale foilor de calcul pe măsură ce se fac modificări, permițând utilizatorilor cu drepturi de Editor să navigheze și să restaureze versiuni anterioare.

Pentru a accesa istoricul versiunilor unei foi de calcul, faceți clic pe File ‣ See version history din bara de meniu. Versiunile salvate apar într-un panou în partea dreaptă a foii de calcul. Este afișat numele utilizatorului care a efectuat modificarea, precum și data și ora modificării.

Următoarele acțiuni sunt posibile:

  • Vizualizați o versiune anterioară în format doar pentru citire făcând clic pe versiunea relevantă.

  • Restaurați o versiune anterioară făcând clic pe (elipsă verticală) apoi Restore this version.

  • Copiați o versiune anterioară făcând clic pe (elipsă verticală) apoi Make a copy. O copie a versiunii se deschide ca o nouă foaie de calcul.

  • Creați versiuni cu nume făcând clic pe data și ora versiunii relevante și introducând numele dorit. Data și ora versiunii sunt apoi afișate sub noul nume.

Sfat

Când vizualizați o versiune anterioară, doar pentru citire, a unei foi de calcul, următoarele acțiuni sunt totuși posibile:

  • Căutați în foaia de calcul făcând clic pe Edit ‣ Find and replace sau folosind comanda rapidă Ctrl + H.

  • Copiați o celulă individuală sau o zonă selectată făcând clic pe Edit ‣ Copy sau folosind comanda rapidă Ctrl + C.

Setări regionale

Pentru a asigura că datele sunt afișate consecvent pentru toți utilizatorii, setările regionale (sau locale) ale unei foi de calcul sunt gestionate la nivelul foii de calcul. Acest locale afectează următoarele setări și formate:

  • separatori pentru mii și zecimale

  • formate de dată și oră

  • prima zi a săptămânii

Implicit, o foaie de calcul nouă moștenește setările regionale ale utilizatorului care a creat-o. De exemplu, orice foi de calcul create de un utilizator a cărui limbă este setată la French (BE) / Français (BE) vor urma convențiile belgiene franceze.

Setările regionale ale unei foi de calcul pot fi vizualizate și modificate oricând de un utilizator cu drepturi de Editor. Pentru a vizualiza setările regionale ale unei foi de calcul, faceți clic pe File ‣ Settings din bara de meniu. Panoul Spreadsheet settings se deschide în dreapta foii de calcul. Pentru a schimba setările regionale, selectați setările regionale corespunzătoare din lista derulantă.

Sfat

Când deschideți o foaie de calcul care are setări regionale diferite de cele ale profilului dvs. de utilizator, apare o pictogramă albastră (glob) în partea dreaptă sus a foii de calcul. Trecând cu mouse-ul peste pictogramă apare un mesaj de avertizare care indică setările regionale ale foii de calcul și evidențiază formatele care diferă.

Avertisment despre diferența dintre setările regionale ale utilizatorului și ale foii de calcul

Dacă nu este afișată nicio pictogramă (glob), înseamnă că setările regionale ale foii de calcul sunt aceleași cu cele ale profilului dvs. de utilizator.

Conversia unei foi de calcul într-un tablou de bord

Un utilizator cu drepturi de acces corespunzătoare poate converti o foaie de calcul Odoo într-un tablou de bord care devine accesibil prin Tablouri de bord Odoo. Pentru a face acest lucru:

  1. Faceți clic pe Fișier ‣ Adăugați la tabloul de bord din bara de meniu.

  2. Introduceți Numele tabloului de bord.

  3. Selectați Secțiunea tabloului de bord relevantă din meniul derulant sau, pentru a crea o nouă secțiune de tablou de bord, introduceți numele noii secțiuni, apoi faceți clic pe Creează.

  4. Dacă este necesar, modificați Grupurile de acces pentru a determina care grupuri de utilizatori pot accesa tabloul de bord.

  5. Faceți clic pe Creați.

Sfat

  • În mod implicit, prima filă a foii de calcul servește drept interfață a tabloului de bord.

  • De asemenea, este posibil să convertiți o foaie de calcul într-un tablou de bord din setările de configurare ale tabloului de bord, adăugând direct foaia de calcul la o secțiune de tablou de bord existentă sau nouă.

  • După ce o foaie de calcul a fost convertită într-un tablou de bord, aceasta este ștearsă din Odoo Documents. Orice modificări ulterioare trebuie efectuate prin Tablouri de bord Odoo.

Specificații și limite ale foii de calcul

Important

Numărul de coloane și rânduri per foaie poate afecta performanța foii de calcul. Totuși, factorul principal este adesea natura formulelor folosite și intervalele pe care acestea trebuie să le scaneze. În special, formulele care creează un comportament pătratic, în care formule copiate pe multe rânduri scanează fiecare un interval mare, pot afecta grav performanța în seturi mari de date.

O foaie nouă dintr-o foaie de calcul Odoo conține implicit 26 de coloane (adică coloanele A-Z) și 100 de rânduri. Se pot adăuga coloane și rânduri suplimentare în funcție de nevoile dumneavoastră, ținând cont de următoarele aspecte:

  • Coloane: Deși nu există o limită tehnică privind numărul de coloane care pot fi afișate într-o foaie, formulele din Odoo Spreadsheet acceptă doar referințe de coloană cu 3 litere, ceea ce înseamnă că o formulă care face referire, de exemplu, la coloana AAAA, va genera o eroare.

    Prin urmare, limita practică pentru numărul de coloane per foaie este de 18.278 de coloane (adică până la coloana ZZZ).

  • Rânduri: Nu există o limită fixă privind numărul de rânduri pe care o foaie le poate conține.

    Sfat

    Pentru a adăuga rapid un maxim de 10.000 de rânduri în partea de jos a foii dintr-o singură dată, derulează până în partea de jos a foii, introdu numărul dorit de rânduri, apoi apasă Adaugă.

  • Celule și caractere per celulă: Nu există o limită fixă privind numărul de celule pe care le poate conține o foaie, nici privind numărul de caractere dintr-o celulă.