Tabele przestawne¶
Tabele przestawne umożliwiają organizowanie, podsumowywanie i analizowanie dużych ilości danych bez potrzeby stosowania skomplikowanych formuł. Grupując i segmentując dane w wymiary (tj. pola dodane jako kolumny i wiersze) oraz definiując, co jest mierzone (np. całkowita kwota lub zamówiona ilość), odpowiednie wartości każdego przecinającego się punktu danych są obliczane automatycznie.
Można wykonać różne manipulacje, aby zobaczyć ten sam zestaw danych z różnych perspektyw, takie jak zmiana kolejności lub sortowanie wymiarów, lub zmiana sposobu agregacji lub obliczania miar.
Example
W przykładzie tabela przestawna pokazuje Całkowitą kwotę zamówień sprzedaży na sprzedawcę na kwartał. Pole Sprzedawca jest reprezentowane w wierszach, Data zamówienia (pogrupowana według kwartału i roku) w kolumnach, podczas gdy wartości reprezentują całkowitą kwotę dla danego sprzedawcy i kwartału.
Za pomocą Arkusza kalkulacyjnego Odoo można:
wstawić tabelę przestawną z widoku tabeli przestawnej Odoo do arkusza kalkulacyjnego Odoo, konsoli Odoo lub arkusza kalkulacyjnego kalkulatora ofert.
wstawić tabelę przestawną odwołującą się do danych Odoo bezpośrednio z arkusza kalkulacyjnego Odoo. Ta opcja pozwala na pobieranie i pracę z danymi z dowolnego modelu, w tym modeli, dla których nie jest dostępny widok tabeli przestawnej Odoo, np. model Pozycja zamówienia sprzedaży.
wstawić tabelę przestawną z zakresu danych. Dane mogą być danymi statycznymi lub dynamicznymi danymi Odoo, które zostały wstawione do arkusza kalkulacyjnego, np. z widoku listy.
Gdy tabela przestawna jest wstawiana do arkusza kalkulacyjnego Odoo, tworzone jest źródło danych, które łączy tabelę przestawną z bazowymi danymi bazy danych lub zakresem arkusza kalkulacyjnego.
Zobacz także
Vložení kontingenční tabulky z rozsahu dat¶
Wskazówka
Před vložením kontingenční tabulky z rozsahu dat:
Uspořádejte data do sloupců, nikoli do řádků, tj. každý sloupec by měl obsahovat jednu kategorii informací, zatímco každý řádek by měl obsahovat jeden záznam.
Zajistěte, aby všechny sloupce měly jedinečnou hlavičku; vyhněte se dvojitým řádkům hlaviček nebo sloučeným buňkám.
Naformátujte data jako tabulku tak, že vyberete libovolnou buňku v rozsahu, kliknete na Vložit tabulku z panelu nástrojů a poté vyberete styl. Tím zajistíte, že se všechny aktualizace tabulky projeví v kontingenční tabulce.
Pro vytvoření kontingenční tabulky z rozsahu dat:
Otevřete příslušnou tabulku Odoo.
Vyberte libovolnou buňku v rozsahu dat, které mají být analyzovány, a poté klikněte na v řádku nabídky.
Otevře se nový list s prázdnou kontingenční tabulkou v levém horním rohu listu; název listu je ID kontingenční tabulky, např. Pivot #2. Ve výchozím nastavení je kontingenční tabulka dynamická kontingenční tabulka, kde buňka v levém horním rohu obsahuje funkci pole specifickou pro Odoo, která získává data z rozsahu dat, jakmile jsou přidány sloupce, řádky a míry.
Panel po prawej stronie arkusza kalkulacyjnego pokazuje właściwości tabeli przestawnej.
Zobacz także
Właściwości tabeli przestawnej¶
Při vložení kontingenční tabulky do tabulky Odoo se napravo od tabulky otevře panel vlastností.
Here, it is possible to modify various aspects of the pivot table’s configuration and presentation via the Configuration and Design tabs respectively.
Wskazówka
Panel vlastností kontingenční tabulky lze kdykoli otevřít prostřednictvím nabídky Data kliknutím na příslušnou kontingenční tabulku, před níž je ikona (kontingenční), nebo kliknutím pravým tlačítkem myši kdekoli na příslušnou kontingenční tabulku a kliknutím na Zobrazit vlastnosti kontingenční tabulky.
Configuration tab¶
V závislosti na způsobu vložení kontingenční tabulky se zobrazují následující vlastnosti, z nichž některé lze upravit:
Pivot #: ID kontingenční tabulky.
Informacja
Kontingenční tabulka si ponechává své ID po celou dobu existence tabulky. Kromě toho, že je uvedeno v horní části panelu vlastností, toto ID také identifikuje kontingenční tabulku v nabídce Data. ID kontingenčních tabulek jsou přiřazována postupně při vkládání dalších kontingenčních tabulek do tabulky.
Název: název kontingenční tabulky. V případě potřeby upravte název. Upozorňujeme, že úprava názvu ve vlastnostech kontingenční tabulky neupravuje název listu a naopak.
Rozsah: u kontingenční tabulky vytvořené z rozsahu dat použitý rozsah. V případě potřeby upravte rozsah.
Model: u kontingenční tabulky odkazující na data Odoo, která byla vložena ze zobrazení kontingenční tabulky Odoo nebo přímo z tabulky, model, ze kterého jsou data získávána.
Columns and Rows: the dimensions used to group or segment data.
Measures: what is being measured, or analyzed, based on the selected dimensions.
Doména: u kontingenční tabulky odkazující na data Odoo, která byla vložena ze zobrazení kontingenční tabulky Odoo nebo přímo z tabulky, pravidla použitá k určení, které záznamy Odoo se zobrazí. Klikněte na Upravit doménu pro přidání nebo úpravu pravidel.
Informacja
Při odkazování na dynamická data Odoo v kontingenční tabulce a používání globálních filtrů je tato doména kombinována s vybranými hodnotami globálního filtru před načtením dat do tabulky.
Aby zapobiec aktualizacjom w czasie rzeczywistym podczas tworzenia lub manipulowania tabelą przestawną, włącz Odrocz aktualizacje.
Aby zduplikować lub usunąć źródło danych tabeli przestawnej, kliknij ikonę (koło zębate) u góry panelu właściwości, a następnie Duplikuj lub Usuń według potrzeb.
Zobacz także
Design tab¶
The Design tab of the properties panel allows you to control the display and style of the pivot table:
Display options: define the maximum number of rows or columns to show, or indicate if the totals, column titles, and/or measure titles are shown. It is also possible to flatten hierarchical data by enabling Use tabular form.
Wskazówka
Many display options of a dynamic pivot table can also be controlled via the pivot table function.
Pivot table style: use banded rows and/or banded columns, add a filter, or change the appearance of the pivot table by selecting an alternative style.
Tworzenie lub manipulowanie tabelą przestawną¶
Po wstawieniu tabeli przestawnej do arkusza kalkulacyjnego Odoo możliwe jest:
edycja domeny tabeli przestawnej połączonej z modelem Odoo
Ważne
Tabela przestawna wstawiona z widoku przestawnego Odoo musi najpierw zostać przekonwertowana na dynamiczną tabelę przestawną, aby można było manipulować wymiarami i miarami.
Wskazówka
Domyślnie większość manipulacji tabelą przestawną jest odzwierciedlana w danych tabeli przestawnej w czasie rzeczywistym. Aby zapobiec aktualizacjom podczas wprowadzania zmian, na przykład gdy zbiór danych jest bardzo duży, włącz Odrocz aktualizacje u dołu panelu właściwości. Gdy zakończysz wprowadzanie zmian, kliknij Aktualizuj (Zastosuj wszystkie zmiany) lub (Odrzuć wszystkie zmiany).
Wyłączenie Odrocz aktualizacje zastosuje wszystkie zmiany wprowadzone od momentu włączenia tej opcji i przywróci aktualizacje w czasie rzeczywistym.
Wymiary¶
Wymiary tabeli przestawnej, czyli pola dodane jako kolumny i wiersze, reprezentują kategorie używane do grupowania lub segmentowania danych. Kolumny są zazwyczaj używane dla pól, które mogą zapewnić widok porównawczy, np. Data zamówienia pogrupowana według kwartałów, podczas gdy wiersze są zazwyczaj używane dla pól, które zwrócą wiele wartości, np. Klient lub Produkt.
Możliwe jest:
Dodawanie lub usuwanie wymiarów¶
Dodawanie lub usuwanie wymiarów pozwala dostosować tabelę przestawną do swoich potrzeb i kontrolować poziom szczegółowości danych.
Aby dodać wymiar do tabeli przestawnej:
W sekcji Kolumny lub Wiersze, zależnie od potrzeb, kliknij Dodaj.
Wybierz odpowiednie pole.
Zmień sortowanie, jeśli to konieczne.
Wskazówka
Dla wymiarów opartych na dacie lub czasie wybierz żądaną Szczegółowość z opcji w menu rozwijanym.
W tabeli przestawnej odwołującej się do danych Odoo, która została wstawiona z widoku przestawnego Odoo lub wstawiona bezpośrednio z arkusza kalkulacyjnego, kliknij (strzałka w prawo) obok nazwy pola, aby uzyskać dostęp do listy powiązanych pól podczas dodawania kolumn lub wierszy.
Aby usunąć wymiar z tabeli przestawnej, kliknij ikonę (usuń) na karcie wymiaru.
Zagnieżdżone wymiary¶
Dodanie wielu wymiarów wierszy lub kolumn tworzy zagnieżdżoną hierarchię. Aby zmienić hierarchię wymiarów, przeciągnij kartę wymiaru do żądanej pozycji w jej sekcji.
Example
W przykładzie pole Produkt zostało dodane jako wymiar wiersza oprócz Sprzedawca, aby pokazać produkty dla każdego sprzedawcy. Zmiana kolejności wymiarów pokazuje następnie sprzedawcę dla każdego produktu.
Aby zwinąć lub rozwinąć zagnieżdżoną hierarchię w tabeli przestawnej, kliknij ikonę (rozwiń) lub (zwiń), zależnie od potrzeb.
Wskazówka
To flatten a pivot table, i.e., convert hierarchical data into a simple table where each row dimension field has its own column and every line has complete information with repeated labels, enable Use tabular form in the Design tab of the pivot table’s properties panel.
Example
In the example, with tabular form enabled, the row dimensions Salesperson and Product are no longer nested in a single column, but are presented in separate columns.
Zmiana układu wymiarów¶
Zmiana układu wymiarów tabeli przestawnej, tj. przeniesienie pola z kolumny do wiersza lub odwrotnie, pozwala na przeglądanie tego samego zestawu danych z różnych perspektyw i potencjalnie zdobycie nowych spostrzeżeń.
Aby zmienić oś, na której wyświetlany jest pojedynczy wymiar:
Przeciągnij kartę wymiaru z sekcji Kolumny do sekcji Wiersze lub odwrotnie.
Aby przenieść wszystkie wymiary reprezentowane w kolumnach do wierszy i odwrotnie, jednocześnie:
Kliknij ikonę (koło zębate).
Kliknij Zamień osie.
Informacja
W zależności od ilości danych odwrócenie osi tabeli przestawnej może skutkować błędem #SPILL. Dzieje się tak, gdy formuła próbuje wyświetlić zakres wartości, ale coś uniemożliwia wypełnienie komórek, na przykład inne dane, scalone komórki lub granice bieżącego arkusza.
Najechanie kursorem na komórkę zawierającą #SPILL udostępnia szczegóły błędu.
Sortowanie wymiarów¶
Sortowanie wymiarów umożliwia organizowanie danych tabeli przestawnej i łatwiejsze odkrywanie potrzebnych informacji. Każdy wymiar można sortować według wartości wymiaru, natomiast wymiary wierszy można również sortować według miary.
Według wartości wymiaru¶
Wartości wymiarów są domyślnie zazwyczaj sortowane w rosnącej kolejności alfabetycznej, chronologicznej lub numerycznej.
Aby zmienić sposób sortowania wymiaru według wartości wymiaru:
Otwórz właściwości tabeli przestawnej.
Na karcie odpowiedniego wymiaru w polu Sortuj według wybierz Rosnąco, Malejąco lub Bez sortowania.
Według miary¶
Wymiary wierszy można sortować według miary, np. aby zobaczyć całkowitą kwotę zamówień sprzedaży na sprzedawcę na kwartał w kolejności rosnącej na podstawie całkowitej kwoty.
Aby sortować wymiary wierszy według miary:
Kliknij prawym przyciskiem myszy dowolną wartość w odpowiedniej kolumnie, a następnie kliknij Sortuj przestawną i wybierz Rosnąco lub Malejąco.
Aby powrócić do domyślnej kolejności, wykonaj te same kroki, a następnie wybierz Bez sortowania z menu rozwijanego.
Grupowanie wartości wymiarów¶
Grupowanie wartości wymiarów umożliwia uporządkowanie tabeli przestawnej poprzez łączenie wielu wartości wymiarów w jedną, zwijającą się grupę. Może to być przydatne na przykład do utworzenia kategorii Inne, aby zgrupować mniej znaczące wartości i umożliwić skupienie się na ważniejszych danych.
Aby zgrupować wartości wymiarów i utworzyć kategorię Inne:
Przytrzymaj
Ctrl, a następnie wybierz komórki wartości wymiarów wierszy lub kolumn, które powinny zostać zgrupowane.Kliknij prawym przyciskiem myszy jedną z wybranych komórek, a następnie kliknij Grupuj wymiary przestawne. Nowy wymiar zostanie dodany do sekcji Kolumny lub Wiersze, w zależności od sytuacji. Zmień sortowanie na Rosnąco lub Malejąco.
Na karcie nowego wymiaru:
Zmień pole Sortuj według z Nieposortowane na Rosnąco lub Malejąco, w zależności od potrzeb.
Kliknij Grupy, aby rozwinąć podsekcję.
Opcjonalnie zmień nazwę Grupa, klikając ją i wprowadzając nową nazwę.
Kliknij + „Inne”, aby niewybrane wartości wymiarów zostały dodane do pojedynczej grupy, która zostanie następnie umieszczona po wybranych wartościach.
Aby zwinąć lub rozwinąć grupę wymiarów w tabeli przestawnej, kliknij ikonę (rozwiń) lub (zwiń) w zależności od potrzeb.
Example
In the example, data per salesperson for the secondary markets of Ireland, Italy, and the United States has been grouped into an Others category, which can then be collapsed and its data seen beside that of the main markets of Belgium and Spain.
![]()
Miary¶
Miary w tabeli przestawnej reprezentują to, co jest mierzone lub analizowane, i są zazwyczaj polami takimi jak Suma, Zamówiona ilość itp.
Wskazówka
Jeśli żądana miara nie istniała w oryginalnym źródle danych, utwórz miarę obliczeniową, np. w celu pokazania średniego przychodu na zamówienie.
Możliwe jest:
Dodawanie lub usuwanie miar¶
Aby dodać miarę do tabeli przestawnej:
W sekcji Miary kliknij Dodaj.
Wybierz odpowiednią miarę lub kliknij Dodaj miarę obliczeniową, aby utworzyć i dodać niestandardową miarę obliczeniową.
Opcjonalnie edytuj nazwę miary, klikając ją, a następnie edytując nazwę miary.
Opcjonalnie zmień sposób agregacji miary, wybierając wartość z menu rozwijanego.
Aby usunąć miarę z tabeli przestawnej, kliknij ikonę (usuń) na karcie wymiaru. Aby tymczasowo ukryć miarę zamiast ją usuwać, kliknij ikonę (Ukryj); aby uprzednio ukrytą miarę uczynić widoczną, kliknij ikonę (Pokaż).
Wskazówka
Aby po prostu wyświetlić liczbę wymiarów, a nie miarę ilościową, wybierz Liczba jako miarę.
W tabeli przestawnej etykieta miary jest domyślnie wyświetlana w drugim wierszu nagłówka; w razie potrzeby ukryj ten wiersz.
Tę samą miarę można dodać wiele razy z różnymi agregacjami.
Jeśli dodano wiele miar, są one wyświetlane w kolumnach w kolejności, w jakiej zostały dodane; w razie potrzeby zmień kolejność.
Tworzenie miar obliczeniowych¶
Możliwe jest dodanie jednej lub więcej miar obliczeniowych, jeśli pożądane miary nie istniały w oryginalnym źródle danych. Na przykład można dodać miarę obliczeniową, aby pokazać średni przychód na zamówienie lub marżę zysku na produkt.
Informacja
Pola potrzebne do obliczenia nowej miary muszą już być dodane do tabeli przestawnej jako wymiary lub miary.
Aby dodać miarę obliczeniową:
W sekcji Miary kliknij Dodaj.
Poniżej przewijanej listy kliknij Dodaj miarę obliczeniową.
Zmień nazwę miary obliczeniowej, klikając na nazwę i wpisując.
Kliknij linię zaczynającą się od
=, a następnie wprowadź odpowiednią formułę.Wskazówka
W formule miary obliczeniowej można używać funkcji.
Wybierz sposób agregacji miary, wybierając wartość z listy rozwijanej.
Example
W przykładzie średni przychód na zamówienie jest obliczany poprzez podzielenie sumy sprzedaży przez liczbę zamówień.
Zmiana kolejności miar¶
W tabeli przestawnej miary są wyświetlane w kolumnach w kolejności, w jakiej zostały dodane.
Aby zmienić kolejność wyświetlania miar:
Przeciągnij kartę miary do żądanej pozycji.
„Pokaż miarę jako”¶
Domyślnie miary są wyświetlane jako rzeczywista zwrócona wartość, bez wykonywania dodatkowych obliczeń. Możliwe jest jednak również wyświetlanie miar w relacji do innych danych, np. jako % sumy całkowitej lub uszeregowanych od najmniejszej do największej.
Aby zmienić sposób wyświetlania miary:
Na karcie miary kliknij ikonę (Pokaż wartości jako).
Wybierz żądaną opcję z menu rozwijanego.
Kliknij Zapisz.
Informacja
Podczas zmiany sposobu wyświetlania miar dane tabeli przestawnej aktualizują się w czasie rzeczywistym, nawet jeśli opcja Odrocz aktualizacje jest włączona.
Usuwanie tytułów miar¶
Domyślnie tytuły miar są wyświetlane w drugim wierszu nagłówka w tabeli przestawnej.
To remove this header row in a dynamic pivot table:
Kliknij dwukrotnie lewą górną komórkę tabeli przestawnej, aby móc edytować formułę.
Umieść kursor po identyfikatorze tabeli przestawnej, a następnie wpisz
,, aby przejść do [include_measure_titles], a następnie wpisz0.
The row showing measure titles is removed.
Wskazówka
The visibility of measure titles, as well as other display options, can also be controlled via the pivot table properties, in the Design tab.
In a static pivot table, delete the second header row manually, if desired.
Duplikowanie lub usuwanie tabeli przestawnej¶
Informacja
Podczas duplikowania lub usuwania tabeli przestawnej ważne jest, aby pamiętać, że każda wstawiona tabela przestawna ma również źródło danych.
Duplikowanie tabeli przestawnej¶
Duplikowanie tabeli przestawnej za pomocą właściwości tabeli przestawnej tworzy dodatkowe źródło danych. Pozwala to na wykonywanie różnych operacji na tych samych danych w obrębie jednego arkusza kalkulacyjnego. Na przykład możesz zobaczyć te same dane zagregowane według różnych wymiarów lub użyć filtrów globalnych, aby przesunąć datę i utworzyć tabele przestawne porównujące dane z bieżącego okresu z danymi z poprzedniego okresu.
Aby zduplikować tabelę przestawną:
Po otwarciu właściwości tabeli przestawnej kliknij ikonę (koło zębate), a następnie Duplikuj.
Zduplikowana tabela przestawna zostaje automatycznie wstawiona do nowego arkusza w arkuszu kalkulacyjnym, z właściwościami tabeli przestawnej otwartymi w prawym panelu.
W razie potrzeby edytuj Nazwę w panelu właściwości i na karcie arkusza.
Nowe źródło danych otrzymuje następny dostępny identyfikator tabeli przestawnej. Na przykład, jeśli w międzyczasie nie wstawiono żadnych innych tabel przestawnych, duplikowanie Pivot #1 skutkuje utworzeniem Pivot #2.
Informacja
Duplikowanie tabeli przestawnej przez skopiowanie i wklejenie jej lub przez duplikowanie arkusza nie tworzy nowego źródła danych. Wszelkie zmiany wprowadzone we właściwościach tabeli przestawnej wpłynęłyby zatem na wszystkie kopie tabeli przestawnej.
Gdy tabela przestawna jest duplikowana, nowa tabela przestawna jest domyślnie dynamiczną tabelą przestawną, której wymiary i miary można manipulować.
Usuń tabelę przestawną¶
Aby całkowicie usunąć tabelę przestawną i jej źródło danych z arkusza kalkulacyjnego, wykonaj następujące kroki w dowolnej kolejności:
Usuń tabelę przestawną za pomocą preferowanej metody, np. za pomocą poleceń klawiatury, menu arkusza kalkulacyjnego lub przez usunięcie arkusza.
Z panelu właściwości odpowiedniej tabeli przestawnej kliknij ikonę (koło zębate), a następnie Usuń. To usuwa źródło danych tabeli przestawnej.
Informacja
Usunięcie najpierw tabeli przestawnej skutkuje komunikatem ostrzegawczym obok odpowiadającego źródła danych w menu Dane, podczas gdy usunięcie najpierw źródła danych skutkuje tabelą przestawną wypełnioną błędami #ERROR.