Ansichten

Ansichten sind die Schnittstelle, über die die in einem Modell enthaltenen Daten angezeigt werden können. Ein Modell kann mehrere Ansichten haben, die einfach nur verschiedene Möglichkeiten sind, dieselben Daten anzuzeigen. In Studio sind die Ansichten in vier Kategorien unterteilt: Allgemein, Mehrere Datensätze, Zeitleiste und Berichtswesen.

Tipp

  • To change the default view of a model, access Studio, go to Views, click the (ellipsis) icon next to the desired view, and click Set As Default.

  • Views can also be modified using Studio’s built-in XML editor. To do so, activate developer mode, navigate to the relevant view, select the View tab, then click </> XML.

    Wichtig

    When editing a view using the XML editor, avoid making changes directly to standard and inherited views, as these would be reset and lost during updates or module upgrades. Always make sure to select the correct Studio inherited views: when a view is modified in Studio by dragging and dropping a new field, for example, a specific Studio inherited view and its corresponding XPath, which defines the modified part of the view, are automatically generated.

Allgemeine Ansichten

Bemerkung

Die hierunter beschriebenen Einstellungen finden Sie im Reiter Ansicht, sofern nicht anders angegeben.

Formular

Die Ansicht Formular wird zum Erstellen und Bearbeiten von Datensätzen verwendet, z. B. von Kontakten, Verkaufsaufträgen, Produkten usw.

  • To structure a form, drag and drop the Tabs and/or Columns elements from the + Add tab.

  • To add a field, drag and drop a New Field or Existing Field from the + Add tab.

  • To prevent users from creating, editing, deleting, or duplicating records, untick Can Create, Can Edit, Can Delete, or Can Duplicate.

  • To add a button, click Add button directly above the form. In the Properties tab, enter a Label, and select the button’s action from the What should the button do field:

    • Run a Server Action: Select the server action to be executed from the dropdown list.

    • Call a method: Specify an existing Python method already defined in Odoo.

  • To change a button’s label or style, in the Properties tab, click the button and edit its Label or Class (either btn-primary for a primary button or btn-secondary for a secondary button).

    Tipp

    Primäre Schaltflächen stellen die Hauptaktion(en) dar, die der Benutzer in einer bestimmten Ansicht ausführen kann, z. B. Senden einer Angebotsanfrage, und sind visuell auffälliger. Sekundäre Schaltflächen bieten alternative oder weniger häufige Aktionen, z. B. Drucken oder Vorschau einer Angebotsanfrage, und sind visuell weniger auffällig. Standardmäßig wird eine neue Schaltfläche als sekundäre Schaltfläche gestaltet.

  • To add a smart button, click Add button to the right of the standard smart buttons, if any, at the top of the form view. Select a Related field, enter a Label, choose an Icon, then click Add.

  • To reorder buttons, smart buttons, or tabs, click the button or tab, then drag it to the desired position within its section; a blue rectangle indicates the area within which the button or tab can be moved.

    Reordering a button within a defined area
  • To add a (second) status bar above the form in a form view, in a model that allows such customization, drag and drop a Many2One or Selection field into the placeholder status bar above the form to the right.

    Creating a new status bar using a Selection field

    Select the related model and click Confirm or enter the selection values and click Add.

    Example

    A form view with a second status bar created with two selection values

Aktivität

Die Ansicht Aktivität wird verwendet, um Aktivitäten (E-Mails, Anrufe usw.), die mit Datensätzen verknüpft sind, zu planen und im Überblick zu behalten.

Bemerkung

Diese Ansicht kann nur in Studio durch Bearbeitung des XML-Codes geändert werden.

Example

Aktivitätsansicht des Lead/Verkaufschancenmodell

Ansicht mit mehreren Datensätzen

Bemerkung

Die hierunter beschriebenen Einstellungen finden Sie im Reiter Ansicht, sofern nicht anders angegeben.

Kanban

Die Ansichr Kanban wird häufig verwendet, um Geschäftsabläufe zu unterstützen, indem Datensätze über Phasen hinweg verschoben werden oder als alternative Möglichkeit, Datensätze innerhalb von Karten anzuzeigen.

Bemerkung

Wenn die Kanban-Ansicht existiert, wird sie standardmäßig für die Anzeige von Daten auf mobilen Geräten anstelle der Listenansicht verwendet.

  • Um zu verhindern, dass Benutzer neue Datensätze erstellen, deaktivieren Sie das Kontrollkästchen Darf erstellen.

  • Um Datensätze direkt in der Ansicht in einer minimalistischen Form zu erstellen, aktivieren Sie Schnelles Anlegen.

  • Um eine Standardgruppierung für Datensätze festzulegen, wählen Sie ein Feld unter Standardmäßig gruppieren nach aus.

Example

Kanban-Ansicht des Projektsmodells

Liste

Die Ansicht Liste wird verwendet, um viele Datensätze auf einmal zu überblicken, nach Datensätzen zu suchen und einfache Datensätze zu bearbeiten.

  • To add a field, drag and drop a New Field or Existing Field from the + Add tab.

  • To prevent users from creating, editing, deleting, or duplicating records, untick Can Create, Can Edit, Can Delete, or Can Duplicate.

  • To create and edit records directly within the view, select either Add record at the bottom, Add record on top, or Open form view under When Creating Record.

    Bemerkung

    Dies verhindert, dass Benutzer Datensätze in der Formularansicht aus der Listenansicht öffnen können.

  • To allow several records to be edited at once, tick Enable Mass Editing.

  • Um zu ändern, wie Datensätze standardmäßig sortiert werden, wählen Sie ein Feld unter Sortieren nach.

  • Um eine Standardgruppierung für Datensätze festzulegen, wählen Sie ein Feld unter Standardmäßig gruppieren nach aus.

  • To add a button, click Add a button at the top left of the list view, enter a Label, and select the button’s action from the field What should the button do field in the Properties tab:

    • Eine Serveraktion ausführen: Wählen Sie die Serveraktion, die ausgeführt werden soll, aus der Drop-down-Liste aus.

    • Eine Methode aufrufen: Geben Sie eine bestehende Python-Methode, die bereits in Odoo definiert wurde, ein.

  • The widths of columns in a List view are computed automatically to provide the optimal user experience. However, it is also possible to set a fixed or minimum column width per field in pixels, or to define a range. To do so, click on the relevant column to open the field’s Properties tab, then complete the Column Width (px) field as relevant:

    • for a fixed width, enter the number of pixels, e.g., 250

    • for a minimum width, enter the number of pixels within square brackets ([]), e.g., [200]

    • for a range, enter the minimum and maximum number of pixels within square brackets, e.g., [200,250]

Tipp

Um ein Symbol (Ziehpunkt) hinzuzufügen, mit dem Sie Datensätze manuell neu anordnen können, fügen Sie ein Ganzzahl-Feld mit dem Ziehpunkt-Widget hinzu.

Ziehpunkt-Symbol, um Datensätze in der Listenansicht manuell zu sortieren.

Example

Listenansicht des Verkaufsauftragsmodell

Karte

The Map view is used to display records on a map. For example, it is used in the Project app to plan an itinerary between different tasks.

Bemerkung

Ein Many2One-Feld, das mit dem Kontakt-Modell verknüpft ist, ist erforderlich, um die Ansicht zu aktivieren, da die Kontaktadresse zur Positionierung der Datensätze auf der Karte verwendet wird.

  • Um auszuwählen, welche Art von Kontakt auf der Karte verwendet werden soll, wählen Sie ihn unter Kontaktfeld.

  • Um den Namen oder die Adresse des Datensatzes auszublenden, markieren Sie Name ausblenden oder Adresse ausblenden.

  • Um Informationen aus anderen Feldern hinzuzufügen, wählen Sie diese unter Zusätzliche Felder aus.

  • To have a route suggested between the different records, select a Routing mode (Optimized or Ordered). The view requires a valid Mapbox token and at least two located records, or one located record and the user’s current position.

    • Optimized: Computes the route for minimal travel time between records.

    • Ordered: Routes strictly follow the default order (Sort by) set on the view. This selection field is dynamically hidden unless the routing mode is set to Ordered.

    Bemerkung

    A Mapbox token must be configured to use the routing.

Example

Kartenansicht des Aufgabenmodells

Zeitleistenansichten

Bemerkung

  • Wenn Sie eine der Zeitleistenansichten zum ersten Mal aktivieren, müssen Sie auswählen, welches Feld Datum oder Datum & Zeit Ihres Modells verwendet werden sollen, um zu definieren, wann die Datensätze beginnen und enden, um sie in der Ansicht anzuzeigen. Sie können die Felder Startdatumsfeld und Enddatumsfeld nach dem Aktivieren der Ansicht ändern.

  • Die hierunter beschriebenen Einstellungen finden Sie im Reiter Ansicht, sofern nicht anders angegeben.

Kalender

Die Ansicht Kalender dient der Übersicht und Verwaltung von Datensätzen in einem Kalender.

  • Um Datensätze direkt in der Ansicht zu erstellen, anstatt die Formularansicht zu öffnen, aktivieren Sie Schnelles Anlegen.

    Bemerkung

    Dies funktioniert nur bei bestimmten Modellen, die nur mit einem Namen schnell erstellt werden können. Die meisten Modelle unterstützen jedoch keine schnelle Erstellung und öffnen die Formularansicht, um die erforderlichen Felder auszufüllen.

  • Um Datensätze im Kalender einzufärben, wählen Sie ein Feld unter Farbe. Alle Datensätze, die den gleichen Wert für dieses Feld haben, werden in der gleichen Farbe angezeigt.

    Bemerkung

    Da die Anzahl der Farben begrenzt ist, kann es vorkommen, dass dieselbe Farbe verschiedenen Werten zugeordnet wird.

  • Um Veranstaltungen, die den ganzen Tag dauern, oben im Kalender anzuzeigen, wählen Sie ein Kontrollkästchenfeld, das angibt, ob der Termin den ganzen Tag dauert.

  • Um die Standardzeitskala für die Anzeige von Veranstaltungen auszuwählen, wählen Sie Stichwort, Woche, Monat oder Jahr unter Standardanzeigemodus.

Bemerkung

Sie können auch ein Verzögerungsfeld verwenden, um die Dauer des Termins in Stunden anzuzeigen, indem Sie ein Feld Dezimalstellen oder Ganzzahl auf dem Modell auswählen, das die Dauer des Termins angibt. Wenn Sie jedoch ein Enddatumsfeld setzen, wird das Verzögerungsfeld nicht berücksichtigt.

Example

Kalenderansicht des Kalenderereignismodells

Kohorte

Die Ansicht Kohorte wird verwendet, um den Lebenszyklus von Datensätzen über einen bestimmten Zeitraum zu untersuchen. Sie wird zum Beispiel in der Abonnements-App verwendet, um die Kundenbindungsrate von Abonnements zu sehen.

  • Um eine Kennzahl (d. h. den aggregierten Wert eines bestimmten Feldes) standardmäßig in der Ansicht anzuzeigen, wählen Sie ein Wertfeld.

  • Um auszuwählen, welches Zeitintervall standardmäßig zur Gruppierung der Ergebnisse verwendet wird, wählen Sie Stichwort, Woche, Monat oder Jahr unter Intervall.

  • Um den Kohorten-Modus zu ändern, wählen Sie entweder Kundenbindung der Prozentsatz der Datensätze, die über einen bestimmten Zeitraum bleiben – er beginnt bei 100 % und nimmt mit der Zeit ab oder Abwanderung der Prozentsatz der Datensätze, die über einen bestimmten Zeitraum ausscheiden – er beginnt bei 0 % und nimmt mit der Zeit zu.

  • Um den Verlauf der Zeitleiste (d. h. der Spalten) zu ändern, wählen Sie entweder Vorwärts (von 0 bis +15) oder Rückwärts (von -15 bis 0). Für die meisten Zwecke wird die Zeitleiste Vorwärts verwendet.

Example

Kohortenansicht des Abonnements-Modells

Gantt

Die Ansicht Gantt dient zur Vorhersage und Untersuchung des Gesamtfortschritts von Datensätzen. Datensätze werden durch einen Balken unter einer Zeitskala dargestellt.

  • Um zu verhindern, dass Benutzer Datensätze erstellen oder bearbeiten, deaktivieren Sie Darf erstellen oder Darf bearbeiten.

  • Um graue Zellen auszufüllen, wenn dort kein Datensatz erstellt werden soll (z. B. an Wochenenden für Mitarbeiter), markieren Sie Nichtverfügbarkeit anzeigen.

    Bemerkung

    Das zugrundeliegende Modell muss diese Funktion unterstützen, und die Unterstützung kann nicht über Studio hinzugefügt werden. Sie wird für die Apps Projekt, Abwesenheiten, Planung und Fertigung unterstützt.

  • Um eine Summenzeile am unteren Rand anzuzeigen, markieren Sie Summenzeile anzeigen.

  • To allow users to schedule or unschedule records by dragging and dropping them between the Gantt view and the side panel, enable Scheduling.

  • Um festzulegen, wie die Datensätze in den Zeilen standardmäßig gruppiert werden sollen (z .B. pro Mitarbeiter oder Projekt), wählen Sie ein Feld unter Standardmäßig gruppieren nach.

  • Um eine Standardzeitskala für die Anzeige von Datensätzen zu definieren, wählen Sie Stichwort, Woche, Monat oder Jahr unter Standardskala.

  • Um Datensätze in der Ansicht einzufärben, wählen Sie ein Feld unter Farbe. Alle Datensätze, die den gleichen Wert für dieses Feld haben, werden in der gleichen Farbe angezeigt.

    Bemerkung

    Da die Anzahl der Farben begrenzt ist, kann es vorkommen, dass dieselbe Farbe verschiedenen Werten zugeordnet wird.

  • Um festzulegen, mit welcher Genauigkeit jede Zeitskala geteilt werden soll, wählen Sie Viertelstunde, Halbe Stunde oder Stunde unter Tagesgenauigkeit, Halber Tag oder Tag unter Wochengenauigkeit und Monatsgenauigkeit.

Example

Gantt-Ansicht des Planungsschichtmodells

Ansichten des Berichtswesens

Bemerkung

Die hierunter beschriebenen Einstellungen finden Sie im Reiter Ansicht, sofern nicht anders angegeben.

Pivot

Die Ansicht Pivot wird verwendet, um die in den Datensätzen enthaltenen Daten auf interaktive Weise zu untersuchen und zu analysieren. Sie ist besonders nützlich, um numerische Daten zu aggregieren, Kategorien zu erstellen und die Daten aufzuschlüsseln, indem Sie verschiedene Datenebenen aus- und einklappen.

  • Um auf alle Datensätze zuzugreifen, deren Daten unter einer Zelle zusammengefasst sind, markieren Sie Zugriff auf Datensätze aus Zelle.

  • Um die Daten in verschiedene Kategorien zu unterteilen, wählen Sie ein oder mehrere Felder unter Spaltengruppierung, Zeilengruppierung - Erste Ebene oder Zeilengruppierung - Zweite Ebene.

  • Um verschiedene Arten von Daten hinzuzufügen, die mit der Ansicht gemessen werden sollen, wählen Sie ein Feld unter Werte.

  • Um die Anzahl der Datensätze anzuzeigen, aus denen sich die aggregierten Daten in einer Zelle zusammensetzen, markieren Sie Anzahl anzeigen.

Example

Pivot-Ansicht des Einkaufsberichtsmodells

Diagramm

Die Ansicht Diagramm wird verwendet, um Daten aus Datensätzen in einem Balken-, Linien- oder Kreisdiagramm darzustellen.

  • Um das Standarddiagramm zu ändern, wählen Sie Balken, Linie oder Kreis unter der Option Typ.

  • Um eine Standarddatendimension (Kategorie) auszuwählen, wählen Sie ein Feld unter Erste Dimension und, falls erforderlich, ein weiteres unter Zweite Dimension.

  • Um einen Standarddatentyp auszuwählen, der in der Ansicht gemessen werden soll, wählen Sie ein Feld unter Wert.

  • Nur für Balken- und Liniendiagramme: Um die verschiedenen Datenkategorien nach ihrem Wert zu sortieren, wählen Sie Aufsteigend (vom niedrigsten zum höchsten Wert) oder Absteigend (vom höchsten zum niedrigsten) unter Sortierung.

  • Nur für Balken- und Kreisdiagramme: Um auf alle Datensätze zuzugreifen, deren Daten unter einer Datenkategorie im Diagramm zusammengefasst sind, markieren Sie Zugriff auf Datensätze aus Diagramm.

  • Nur für Balkendiagramme: Wenn Sie zwei Datendimensionen (Kategorien) verwenden, zeigen Sie die beiden Spalten standardmäßig übereinander an, indem Sie Gestapeltes Diagramm markieren.

Example

Das Balkendiagramm des Verkaufsanalyseberichtsmodells in der Diagrammansicht