Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Messages not visible in Inbox and app wide mail.message permission issues

By
Damian Bere
on 10/22/15, 6:23 PM 614 views

Context:

Currently looking at Odoo 9 Community Edition to move from current Odoo 8 installation. Installed a bunch of apps and extras as per our old installation. Created a New User and using this user to operate some of the features (Manage Sales, Accounting etc)

Problems:

Please Note: These do not occur with the Admin User - only newly created users..

  • Cannot Create a Message/Mail (from top nav bar envelope icon) - it fails with following Odoo Warning (Access Error):

The requested operation cannot be completed due to security restrictions. Please contact your system administrator.

(Document type: mail.message, Operation: read)

  • When Creating various objects around the application (e.g. Sales Orders, Customers, etc) it fails giving the same Error. I assume that the workflow triggers a message send or inbox read activity or similar, and thus fails.

  • In the Inbox under Discussions, it shows an unread message count e.g. (3). When selecting the Inbox it states that there are no messages to be read. If I go to the technical settings and review the Messages Archive, I can see the messages are indeed there, assigned to the right user.

It would seem that these are all related to the core problem of not being able to read the messages for the user.

Tried so far:

  • Set all permissions to Manager (or equivalent top level permission for each group) - DID NOT WORK

  • Checked Permissions for the Groups assigned allowed read for that object - HAS FULL PERMISSIONS

  • Checked the Record restrictions for the object - SEEMS OK (but my understanding of this is currently limited, so maybe I'm missing something, but it doesn't seem to be an issue)

  • Created a new, fresh User and tried again - SAME ISSUE

  • Filtered the Groups to show where Admin was a member, but New User wasn't and vice versa - NONE (they're in identical groups)

  • Duplicated the Admin User to a New User to avoid any inconsistencies and tried again - STILL NO JOY - SAME PROBLEM :-(

At this point, I'd like some input/advice from the community as we're not particularly Odoo experts (quite new users), and may just have missed something really obvious :-)

Suggestions of fixes or even just things to investigate would be much appreciated :-)

Thanks

0
Damian Bere
On 10/26/15, 3:58 PM

The only way I've managed to resolve this is to re-install and start again. Not a solution people will likely want, but it did work. This still leaves me with the company set-up settings page without permissions for normal users (only Admin can change), but this is a one off use screen, so not an issue.

Vague speculation might lead me to think that one of the Addon/App Installations only partially succeeded. But that is quite speculative.

As I've not pinpointed the actual cause, your mileage may vary...

0
Thomas H.
On 9/6/16, 1:48 PM

Solved that with inactivating the user via settings / users / individual user - there deactivate the little box behind "active".

After that follow the description here to reactivate the user: https://www.odoo.com/forum/help-1/question/inactive-user-reactivation-32211

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 10/22/15, 6:23 PM
Seen: 614 times
Last updated: 9/6/16, 1:48 PM