Per iniziare

Creare un nuovo foglio di calcolo

Per creare un nuovo foglio di calcolo:

  1. Apri Odoo Documenti e vai alla sezione o cartella in cui deve essere creato il foglio di calcolo.

  2. Fai clic su Nuovo e seleziona Foglio di calcolo.

    Suggerimento

    In alternativa, dalla cartella Tutto, fai clic su Nuovo e seleziona Foglio di calcolo, quindi seleziona in quale Cartella deve essere creato il foglio di calcolo.

  3. Fare clic su Foglio di calcolo vuoto oppure, per creare un nuovo foglio di calcolo utilizzando un modello esistente, selezionare il modello pertinente.

  4. Fai clic su Crea.

  5. Fai clic su Foglio di calcolo senza titolo nella parte superiore dello schermo per modificare il nome del foglio di calcolo.

Suggerimento

È anche possibile creare un nuovo foglio di calcolo:

In questi casi, il nuovo foglio di calcolo viene salvato in Odoo Documenti nella cartella personale Il mio drive.

Modelli

I modelli di fogli di calcolo consentono di creare rapidamente fogli di calcolo senza partire da zero. Ad esempio, è possibile creare un modello per un report di budget mensile o un report trimestrale delle commissioni di vendita.

Creare un modello

Qualsiasi foglio di calcolo può essere salvato come modello.

Per creare un modello:

  1. Aprire il foglio di calcolo pertinente o crearne uno nuovo.

  2. Dalla barra dei menu, fare clic su File ‣ Salva come modello. Modificare il Nome modello predefinito se necessario e fare clic su Conferma.

Suggerimento

Importante

Una volta salvato un foglio di calcolo come modello, eventuali ulteriori modifiche apportate al foglio di calcolo aperto vengono salvate solo in quel foglio di calcolo. Per apportare modifiche al modello, modificare il modello.

Utilizzare i modelli

Per creare un nuovo foglio di calcolo utilizzando un modello, aprire l’app Documenti e fare clic su Nuovo ‣ Foglio di calcolo. Selezionare il modello pertinente e fare clic su Crea.

In alternativa, andare su Documenti ‣ Configurazione ‣ Modelli di fogli di calcolo, quindi, sulla riga del modello pertinente, fare clic su Nuovo foglio di calcolo.

Nota

Per impostazione predefinita, il nuovo foglio di calcolo eredita il nome del modello, visualizzato nella parte superiore dello schermo. Per rinominare il foglio di calcolo, fare clic sul nome e modificarlo.

Gestire e modificare i modelli

Gestisci i modelli andando in Documenti ‣ Configurazione ‣ Modelli di fogli di calcolo. Rimuovi il filtro I miei modelli per visualizzare tutti i modelli nel database.

Sono possibili varie azioni:

  • Controllare l’accesso a un modello facendo clic sul campo Gruppi di accesso, quindi eliminando i gruppi utenti o selezionando i gruppi utenti dal menu a discesa, a seconda dei casi.

  • Copia un modello esistente facendo clic su Crea una copia a destra dello schermo. Il nuovo modello appare in fondo all’elenco. Fai clic sul Nome per modificarlo.

  • Modifica un modello esistente (incluso uno appena copiato) facendo clic su Modifica, quindi apporta le modifiche necessarie. Le modifiche vengono salvate automaticamente.

  • Elimina un modello selezionando la casella accanto a esso, facendo clic su Azioni, quindi su Elimina.

Carica file

I file in formato .xlsx o .csv possono essere caricati in Odoo Documenti e aperti con Odoo Spreadsheet. Per farlo:

  1. Apri Odoo Documenti e vai alla sezione o cartella in cui deve essere salvato il foglio di calcolo.

  2. Fare clic su Nuovo e selezionare Carica.

  3. Selezionare il file .xlsx o .csv pertinente e fare clic su Apri.

  4. Fare clic sul file caricato.

  5. Per impostazione predefinita, il file originale viene eliminato quando viene aperto con Foglio di calcolo Odoo. Per conservare il file originale nella stessa cartella in Documenti Odoo, disabilitare Invia il file di origine nel cestino.

  6. Fare clic su Apri con Foglio di calcolo Odoo.

Il file ora può essere completamente modificato in Foglio di calcolo Odoo.

Azioni di base per i fogli

Gli utenti con diritti di Editor su un foglio di calcolo dispongono di varie opzioni per gestire i fogli dalla barra in basso:

  • (più): aggiunge un nuovo foglio a destra del foglio attivo.

  • Fare clic su (freccia giù) nella scheda di un foglio o fare clic con il pulsante destro del mouse sulla scheda per aprire un menu con le seguenti opzioni:

    • Elimina: elimina il foglio dopo aver richiesto la conferma.

    • Nascondi foglio: nasconde il foglio dalla barra inferiore e lo rende inaccessibile agli utenti con soli diritti di Visualizzatore.

    • Duplica: crea una copia del foglio accanto al foglio originale.

    • Rinomina: rende il nome del foglio modificabile direttamente nella relativa scheda.

      Suggerimento

      In alternativa, fare doppio clic sulla scheda del foglio per modificarne direttamente il nome.

    • Cambia colore scheda: seleziona un colore esistente o personalizzato per aggiungere una barra colorata nella parte inferiore della scheda del foglio. I colori delle schede vengono visualizzati come punti accanto al nome del foglio quando si utilizza l’icona (menu) per visualizzare l’elenco di tutti i fogli presenti nel foglio di calcolo.

    • Cambia colore griglia: seleziona un colore esistente o personalizzato per modificare il colore della griglia del singolo foglio.

    • Sposta foglio a destra o Sposta foglio a sinistra: sposta il foglio di una posizione verso destra o verso sinistra.

      Suggerimento

      In alternativa, fare clic e trascinare la scheda di un foglio nella posizione desiderata.

Blocco fogli

Gli utenti con diritti di Editor possono bloccare i fogli per evitare modifiche accidentali ai dati del foglio.

A tale scopo, fare clic sulla (freccia verso il basso) nella scheda di un foglio o fare clic con il pulsante destro del mouse sulla scheda, quindi fare clic su Blocca foglio.

Qualsiasi utente con diritti di Editor può sbloccare il foglio facendo clic su Sblocca foglio dal menu della barra in basso.

Nascondere i fogli

Gli utenti con diritti di Editor possono nascondere i fogli che non devono essere visibili, ad esempio se i dati non sono pronti per essere condivisi o se vengono utilizzati solo per i calcoli da altri fogli.

Per farlo, fare clic su (cursore verso il basso) nella scheda di un foglio o fare clic con il pulsante destro del mouse sulla scheda, quindi fare clic su Nascondi foglio.

Il foglio viene quindi rimosso dalla barra inferiore, ma rimane incluso, con il nome in grigio, nell’elenco di tutti i fogli accessibili tramite l’icona (menu). Gli utenti con:

  • Visualizzatore non possono aprire un foglio nascosto.

  • Editor possono aprire un foglio nascosto tramite l’icona (menu); in questo modo viene ripristinata la scheda del foglio sulla barra inferiore.

Gestire i fogli di calcolo

Gli utenti con diritti di Editor per un foglio di calcolo hanno a disposizione diverse opzioni per gestirlo tramite il menu File:

  • Crea copia: crea un duplicato del foglio di calcolo corrente con le stesse impostazioni regionali.

  • Condividi: consente di configurare i diritti di accesso al foglio di calcolo e Condividerlo con utenti specifici o copiare un collegamento condivisibile. Per un foglio di calcolo contenente dati Odoo dinamici che deve essere condiviso con un utente che non dispone dei diritti di accesso appropriati ai dati, è possibile Bloccare e condividere il foglio di calcolo.

  • Scarica: scarica il foglio di calcolo in formato .xlsx.

    Importante

    Quando si scarica un foglio di calcolo in formato .xlsx, tutte le formule del foglio di calcolo che recuperano dati Odoo dal database, ad esempio tramite un elenco inserito o tramite altre funzioni specifiche di Odoo, vengono convertite nei valori che avrebbero restituito al momento del download del foglio di calcolo.

    Suggerimento

    Gli utenti con diritti di Visualizzatore possono anche scaricare un foglio di calcolo in formato .xlsx.

  • Stampa: stampa una copia del foglio di calcolo su una stampante collegata.

  • Salva come modello: consente di utilizzare il foglio di calcolo corrente come modello per fogli di calcolo futuri.

  • Sposta nel cestino: sposta il foglio di calcolo nella cartella cestino dell’app Documenti

    Suggerimento

    Gli elementi nella cartella cestino vengono eliminati definitivamente dopo 30 giorni.

  • Aggiungi a dashboard: converte il foglio di calcolo corrente in una dashboard Odoo.

  • Visualizza cronologia versioni: fornisce accesso in sola lettura alle versioni precedenti del foglio di calcolo corrente, che possono essere denominate e ripristinate se necessario.

  • Impostazioni: consente di visualizzare e modificare le impostazioni locali del foglio di calcolo corrente.

Cronologia versioni

Foglio di calcolo Odoo salva automaticamente le versioni dei fogli di calcolo man mano che vengono apportate modifiche, consentendo agli utenti con diritti di Modifica di sfogliare e ripristinare le versioni precedenti.

Per accedere alla cronologia delle versioni di un foglio di calcolo, fare clic su File ‣ Visualizza cronologia versioni dalla barra dei menu. Le versioni salvate appaiono in un pannello a destra del foglio di calcolo. Viene visualizzato il nome dell’utente che ha apportato la modifica, nonché la data e l’ora della modifica.

Le seguenti azioni sono possibili:

  • Visualizzare una versione precedente in formato di sola lettura facendo clic sulla versione pertinente.

  • Ripristinare una versione precedente facendo clic su (puntini di sospensione verticali) quindi Ripristina questa versione.

  • Copiare una versione precedente facendo clic su (puntini di sospensione verticali) quindi Crea una copia. Una copia della versione si apre come nuovo foglio di calcolo.

  • Creare versioni con nome facendo clic sulla data e l’ora della versione pertinente e inserendo il nome desiderato. La data e l’ora della versione vengono quindi visualizzate sotto il nuovo nome.

Suggerimento

Quando si visualizza una versione precedente di sola lettura di un foglio di calcolo, le seguenti azioni sono ancora possibili:

  • Cercare nel foglio di calcolo facendo clic su Modifica ‣ Trova e sostituisci o utilizzando la scorciatoia Ctrl + H.

  • Copiare una singola cella o un’area selezionata facendo clic su Modifica ‣ Copia o utilizzando la scorciatoia Ctrl + C.

Impostazioni regionali

Per garantire che i dati vengano visualizzati in modo coerente per tutti gli utenti, le impostazioni regionali (o locale) di un foglio di calcolo sono gestite a livello di foglio di calcolo. Queste impostazioni regionali influenzano le seguenti impostazioni e formati:

  • separatori delle migliaia e decimali

  • formati di data e ora

  • primo giorno della settimana

Per impostazione predefinita, un nuovo foglio di calcolo eredita le impostazioni regionali dell’utente che lo ha creato. Ad esempio, qualsiasi foglio di calcolo creato da un utente la cui lingua è impostata su French (BE) / Français (BE) seguirà le convenzioni del francese belga.

Le impostazioni regionali di un foglio di calcolo possono essere visualizzate e modificate in qualsiasi momento da un utente con diritti di Editor. Per visualizzare le impostazioni regionali di un foglio di calcolo, fare clic su File ‣ Impostazioni dalla barra dei menu. Il pannello Impostazioni foglio di calcolo si apre a destra del foglio di calcolo. Per modificare le impostazioni regionali, selezionare le impostazioni appropriate dal menu a discesa.

Suggerimento

Quando si apre un foglio di calcolo che ha impostazioni regionali diverse da quelle del proprio profilo utente, un’icona (globo) blu appare in alto a destra del foglio di calcolo. Passando il mouse sull’icona viene visualizzato un messaggio di avviso che indica le impostazioni regionali del foglio di calcolo e mette in evidenza i formati che differiscono.

Avviso sulla differenza tra impostazioni regionali utente e foglio di calcolo

Se non viene visualizzata alcuna icona (globo), significa che le impostazioni regionali del foglio di calcolo sono le stesse di quelle del proprio profilo utente.

Convertire un foglio di calcolo in una dashboard

Un utente con i diritti di accesso appropriati può convertire un foglio di calcolo Odoo in una dashboard che diventa quindi accessibile tramite Dashboard di Odoo. Per farlo:

  1. Fare clic su File ‣ Aggiungi alla dashboard dalla barra dei menu.

  2. Inserire il Nome della dashboard.

  3. Selezionare la Sezione dashboard pertinente dal menu a tendina oppure, per creare una nuova sezione dashboard, digitare il nome della nuova sezione, quindi fare clic su Crea.

  4. Se necessario, modificare i Gruppi di accesso per determinare quali gruppi di utenti possono accedere alla dashboard.

  5. Fai clic su Crea.

Suggerimento

  • Per impostazione predefinita, la prima scheda del foglio di calcolo funge da front-end della dashboard.

  • È anche possibile convertire un foglio di calcolo in una dashboard dalle impostazioni di configurazione della dashboard, aggiungendo direttamente il foglio di calcolo a una sezione dashboard esistente o nuova.

  • Dopo che un foglio di calcolo è stato convertito in una dashboard, viene eliminato da Documenti di Odoo. Qualsiasi modifica successiva deve essere effettuata tramite Dashboard di Odoo.

Specifiche e limiti dei fogli

Importante

Il numero di colonne e righe per foglio può influire sulle prestazioni del foglio di calcolo. Tuttavia, il fattore principale è spesso la natura delle formule utilizzate e gli intervalli che devono scansionare. In particolare, le formule che generano un comportamento quadratico, in cui le formule copiate su molte righe scansionano ciascuna un ampio intervallo, possono influire gravemente sulle prestazioni in set di dati di grandi dimensioni.

Un nuovo foglio in un foglio di calcolo Odoo contiene per impostazione predefinita 26 colonne (ovvero le colonne da A a Z) e 100 righe. È possibile aggiungere ulteriori colonne e righe in base alle proprie esigenze, tenendo presenti i seguenti punti:

  • colonne: sebbene non vi sia alcun limite tecnico al numero di colonne che possono essere visualizzate in un foglio, le formule nel foglio di calcolo di Odoo supportano solo riferimenti alle colonne di 3 lettere, il che significa che una formula che fa riferimento, ad esempio, alla colonna AAAA, genererà un errore;

    Il limite pratico al numero di colonne per foglio è quindi di 18.278 colonne (ovvero fino alla colonna ZZZ).

  • righe: non esiste un limite fisso al numero di righe che un foglio può contenere;

    Suggerimento

    Per aggiungere rapidamente un massimo di 10.000 righe in fondo al foglio in un’unica operazione, scorri fino alla fine del foglio, inserisci il numero desiderato di righe e poi fai clic su Aggiungi.

  • celle e caratteri per cella: non esiste un limite fisso al numero di celle che un foglio può contenere, né al numero di caratteri all’interno di una cella.