Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

6

How to set up e-mail/messaging with Odoo?

By
Maxime Deuse
on 9/3/14, 3:27 AM 43,666 views

Hello,

I tried installing Odoo, it's going great, I managed to install the CRM without any issues and insert my sugarCRM data inside it. Nonetheless, I have huge issues setting up the messaging/emailing part.

This is how I proceeded:

I have a user whose e-mail is maxime@deuse.me.

I went to general settings (I don't know what to put in Alias Domain so I wrote my Odoo domain down "odoo.domain.com")

In configure outgoing e-mail servers I set up my server: 

SMTP Server : smtp-mail.outlook.com    
SMTP Port: 587
TLS (STARTTLS)
username: maxime@deuse.me
Password: **************

(connexion works properly)

In configure ingoing email gateway i wrote:

Server Name pop-mail.outlook.com
Port 995
SSL/TLS
Username: maxime@deuse.me
Password: ******

(connexion works properly)

I left "Actions to Perform on Incoming Mails" blank

When I try to send a message with user Maxime Deuse it gets send properly BUT I just don't get any incoming e-mails. Does anyone know what I am doing wrong and if not does someone have a nice step by step tutorial with whom I couldn't screw up?

Thank you very much! You are a life saver ;)

EDIT SOLVED:

I managed to solve this issue. It was due to my bad understanding of e-mailing in OpenERP. Note that I had to switch from OpenERP 8 to OpenERP 7 due to some stability issues but I believe the process should be the same. See below for answer.

 

Hello Maxime, Try to change in "Alias Domain" to deuse.me. You can also check in Settings > Automation > Scheduled Actions if the "Email Queue Manager" is defined with hours (Number of calls), minutes, days,..... Good luck!

Daniel Santos
on 9/3/14, 7:51 AM

Thanks Daniel, you got me on the right track to solve this issue.

Maxime Deuse
on 9/5/14, 4:56 AM
13
Maxime Deuse
On 9/5/14, 5:34 AM

I managed to solve this issue. It was due to my bad understanding of e-mailing in OpenERP. Note that, I had to switch from OpenERP 8 to OpenERP 7 due to some stability issues but I believe the process should be the same for both versions.

At first I tried to configure e-mail like any other e-mail client, which did not work. I configured my incoming email gateway and my outgoing e-mail server like explained above. The problem I faced was that I inserted one new config per user (with IMAP, SMTP) but I could not link it to a user. E-mails from maxime@deuse.me or from juliend@deuse.me didn't end in Maxime or Julien's inboxes. I kept getting the following error in my terminal: "create an appopriate mail.alias or force the destination model"

In the end I never managed to force the destination model properly (the "Actions to Perform on Incoming Mails" tab) so I went with the appropriate mail.alias (Thanks Daniel for the suggestion).

This is how I proceeded:

To get the incoming e-mails

  1. I went to my google account which manages the deuse.me domain. There I created a new user which I converted in a catchall e-mail adress.https://support.google.com/a/answer/33962?hl=en. This means that all e-mails send to any deuse.me address end up in this catchall@deuse.me inbox. Another solution if a catchall option isn't available would be to forward all your e-mail addresses towards the catchall@deuse.me address.
  2. In the generals settings of OpenERP I set the Alias Domain to deuse.me
  3. I set the ingoing e-mail server as the catchall@deuse.me address. I configured the IMAP config with this e-mail adress. "Server Action" and "Create New Records" should be left blank.
  4. Once this is done users with the allias Maxime will get the e-mails from maxime@deuse.me and so on ...It works

To send e-mail

I did not configure the catchall adress as the outgoing e-mail server, otherwise all e-mails are send with the catchall@deuse.me address and only the name changes. When I did send an e-mail I wanted "Maxime Deuse <maxime@deuse.me>" to be the sender not "Maxime Deuse <catchall@deuse.me>". To achieve that Iinstalled Postfix mail server on my server and I kept the OpenERP outgoing mail server as localhost(configurations may be needed depending on your Postfix config). For this solution don't forget to set up spf records and DKIM's to avoid being marked as spam. (https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-dkim-with-postfix-on-debian-wheezy)

I hope my explanation could help some of you who had the same issues I had.

Thanks for your post. This helped me also http://mhawthorne.net/posts/postfix-configuring-gmail-as-relay.html

Bista Solutions US, Ray Carnes
on 9/18/14, 2:17 PM

For the ones who don't want to install Postfix on their server, you can use services like mandrill.com. If you choose this option to send e-mails you have to configure the outgoing mail server as being mandrill. It has several advantages: 'you don't have to install a mail server on your server" + "DKIM and SPF are easy to set up with mandrill". I didn't try this method out but it should work just fine.

Maxime Deuse
on 10/14/14, 7:34 AM

Maxime: mandrill was great until they effectively raised prices 4x. Now, USD$40/mo is the lowest option. This article reviews some alternatives. I have no relation whatsoever to the article or any provider. http://www.codeinwp.com/blog/mandrill-alternatives/

Practichem, Nicholas DeMarco
on 4/7/16, 11:18 AM
3
Carlos Vasquez
On 10/13/14, 5:44 PM

To expand on your answer, to send email keeping the correct sender name and address you also can use some other mail service besides Google Mail. They are very strict with their anti-spam policies and only allow mail relay (sending though their servers) for explicit sender addresses. So if you wanted to send email from maxime@deuse.me using the catchall@deuse.me you have to login into the catchall Google account and add a sender address for maxime. This way you would be able to do it (not a good option if you have more than a couple of users).

But as you did, other mail servers don't have this restrictions. But you can use your hosting provider, or any mail provider that allows mail relay to do this. And as you pointed out, you have to set the DKIM key and the SPF records to add this server to the allowed mail servers for your domain.

 

One more thing. How are you receiving all email that does not have a valid alias in Odoo? If you have a catchall account going into the system, how do you handle typos and bad addresses. E.g., someone writes to maxine@deuse.me, this would normally get bounced with a "no valid user on this domain" kind of error, but with a catchall address this will go into the system and there is no valid alias, and as you said, no forced object associated.

Regards

Hi Carlos, Actually in my case I decided not to redirect all my e-mails to the catchall@deuse.me address like I explained in my answer. I decided to only forward maxime@deuse.me, julien@deuse.me and info@deuse.me towards catchall@deuse.me. Technically itsn't a real catchall address since it does not catch all my e-mail adresses. That means that if someone sends an e-mail to maxine@deuse.me gmail will send them a "no valid user on this domain".

Maxime Deuse
on 10/14/14, 7:29 AM
1
Luis Alberto Panozzo
On 7/17/15, 11:16 AM

Very interesting exchange. I still have some questions about redirection of incoming emails but need to investigate further.

Again thank yo ufor the clarity so far


Thank you in advance

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

10 follower(s)

Stats

Asked: 9/3/14, 3:27 AM
Seen: 43666 times
Last updated: 11/11/16, 1:22 AM