Help

0

Odoo 14 high idle CPU load and log rotation problem?

Avatar
Samo Arko

I've installed Odoo 14 CE from source on Ubuntu 20.04 server. It's installed in proxy mode so it's behind nginx. I've created a service for odoo. Same as all my Odoo 12 CE installs.

I used instructions from https://linuxize.com/post/how-to-install-odoo-14-on-ubuntu-20-04 to help me with the install.

My problem is not that even in idle, no one is accessing odoo, the CPUs are at high load. When looking into the log it looks like odoo is restarting every 2  seconds.

LOG:

2021-01-18 06:52:06,595 3470092 DEBUG ? odoo.netsvc: logger level set: "odoo.http.rpc.request:INFO" 
2021-01-18 06:52:06,595 3470092 DEBUG ? odoo.netsvc: logger level set: "odoo.http.rpc.response:INFO" 
2021-01-18 06:52:06,595 3470092 DEBUG ? odoo.netsvc: logger level set: ":INFO" 
2021-01-18 06:52:06,596 3470092 DEBUG ? odoo.netsvc: logger level set: "odoo:DEBUG" 
2021-01-18 06:52:06,596 3470092 DEBUG ? odoo.netsvc: logger level set: "odoo.sql_db:INFO" 
2021-01-18 06:52:06,596 3470092 DEBUG ? odoo.netsvc: logger level set: ":INFO" 
2021-01-18 06:52:06,597 3470092 INFO ? odoo: Odoo version 14.0 
2021-01-18 06:52:06,597 3470092 INFO ? odoo: Using configuration file at /etc/odoo.conf 
2021-01-18 06:52:06,597 3470092 INFO ? odoo: addons paths: ['/opt/odoo/odoo14/odoo/addons', '/opt/odoo/.local/share/Odoo/addons/14.0', '/opt/odoo/odoo14/addons', '/opt/odoo/customaddons', '/opt/odoo/thirdpartyaddons'] 
2021-01-18 06:52:06,598 3470092 INFO ? odoo: database: odoo@default:default 
2021-01-18 06:52:06,850 3470092 INFO ? odoo.addons.base.models.ir_actions_report: Will use the Wkhtmltopdf binary at /usr/local/bin/wkhtmltopdf

The above messages are repeated every 2 seconds. Is this normal for odoo 14 because it didn't in odoo 12.

The second problem is that my logs don't rotate. I've set the logrotate parameter to true but it's juts writing into the same file. Used same settings and permissions as for odoo 12 on Ubuntu 18, but it's not working.

How to fix this issues?

Thanks!


EDIT:

Running the odoo-bin gets error:

<frozen importlib._bootstrap>:219: RuntimeWarning: greenlet.greenlet size changed, may indicate binary incompatibility. Expected 144 from C header, got 152 from PyObject





Avatar
Discard
3Answers
0
Avatar
Samo Arko
Best Answer

The high CPU usage was because Ubuntu 20 has python 3.8 and it doesn't work with the libs in requirements.txt.

Had to add a new line and comment out the original line and create a new venv.

gevent>= 20.9; python_version >= '3.8'
#gevent==1.5.0 ; python_version >= '3.7'

Need to see with odoo usage if there are any problems, but there in no more error when launching odoo from odoo-bin.

Hope this will help with the logrotation.

Avatar
Discard
0
Avatar
Neha Sharma
Best Answer

Hello Samo Arko


In odoo. conf file

#-----------------------------------------------------------------------------

# True/False. If True, create a daily log file and keep 30 files.

#-----------------------------------------------------------------------------

logrotate = True


It seems logrotate parameter works how I needed it. At first, I didn't notice it, maybe not the whole 24h were not passed yet or (sometimes needed to archive log). But now I see it archives logs daily.


Restarting Problem is maybe the server is overloaded or in your service creating you made mistake please make sure you have not run any CRON job is running on Ubuntu or OS level.

Thanks

For more information Contact us: -     https://kanakinfosystems.com/odoo-development-services

1Comment
Avatar
Discard
Avatar
Samo Arko
-

I've set the parameter in odoo.conf. I said in the question "I've set the logrotate parameter to true". Still doesn't work. I had it set a few days already and it doesn't work! No cronjobs are running. The problem for the CPU load is that odoo requirements.txt has unsupportet python libs. Libs gevent and greenlet don't work with the specified versions. So I don't know who marked you answer, but your answer didn't solve anything!

0
Avatar
Amar
Best Answer

Hi,

Add this in your odoo.conf file,

logrotate = True

also, check this link

1Comment
Avatar
Discard
Avatar
Samo Arko
-

I've set the logrotate parameter in odoo.conf as said in the question, but I'll check out the link, maybe it'll contain something useful. But I need to fix the python lib versions, maybe that is the reason logrotate doesn't work.