Help

1

How to setup an instance accessible via No-ip address?

Avatar
Fred

I would like to set up an instance whereby the client can access OpenERP using a no-ip address. How can I set this up?

Avatar
Discard
10Answers
5
Avatar
Ahmet Altinisik
Best Answer

Required settings are not openerp related. You should first find your servers local ip address with command.

ifconfig

Local IP address of your server will be something like 192.168.1.* or 10...* note that address down and enter to the administration page of your zyxel model/router. (this will be the gateway address in the ifconfig output.

Go to the NAT settings and make a new entry with the local IP of your openerp server and port 8069. For the external port you should also define a port 8069 for example.

Now you can access with your new http://yourname.no-ip.org:8069 address

If you need help about setting up NAT settings in your modem take a look at this video http://www.youtube.com/watch?v=9OVYC37BQZg

6Comments
Avatar
Discard
Avatar
Fred
-

All done. Thanks for the effort. I downloaded and installed the NO-IP updater, set the OpenERP domain alias to my NO-IP IP and set my router with my machines IP to port 8069

Avatar
Ahmet Altinisik
-

if my answer is ok you should accept it by clicking check button and make it green

Avatar
Camptocamp SA
-

Answer accepted

Avatar
Fred
-

"if my answer is ok you should accept it by clicking check button and make it green" Can't find any check button :(

Avatar
Camptocamp SA
-

It is the ✓ just below the answer vote counter. As I clicked on it, it is now green.

Avatar
Fred
-

Thanks, NOw I know :)

0
Avatar
Olakunle Akinwande
Best Answer

Hello Alan, 

I have been on this all day trying to figure out how to host my Odoo server on the internet, I have open port 8069 with port forwarding and I have even signed in my no-ip account on my rounter's DNS settings and nothing is working,

I have tried switching off my firewall too with no success. Please I really need help on this.

Thanks.

Avatar
Discard
0
Avatar
Fred
Best Answer

Hello Allen, I have used this before but it has been a while so please bear with me.

First a bit about my setup. OS: Linux Kubuntu 12.10 OpenERP: Version 7 .deb latest Interent: wired DSL connection with a zyxel modem/router.

I can access my OpenERP localy with:127.0.0.1:8069

I set up a host with NO_IP :afbbodenbelag.no-ip.org, respectively :87.237.174.79. I went to configuration->general settings and added: 87.237.174.79 to Alias Domain Using either NO-IP host times out or throws me a login screen. Open ERP login does not work. Neither does the login to my linux machine.

I remember something about setting/editing some stuff in one or various /etc file(s) maybe also something somewhere else, but not sure anymore what and where. It has been a long time since I tried getting OpenERP to run.

Any ideas?

Avatar
Discard
0
Avatar
Alan Bell
Best Answer

OpenERP doesn't really care what domain name it is on, a dynamic DNS entry will work just like a real DNS entry. You just need to open the appropriate port (8069 by default) and it should work fine. Are you experiencing a problem with it?

Avatar
Discard