Help

3

[V9] Menu disappears and logout after activating developer mode

Avatar
Lucas Huber

After I try to activate the  developer mode I see the page reloading but after that it seems that I'm not longer logged in. But this happens only when I run the odoo server (an Ubuntu 14.4) in the subdomain mode with this  parameter (dbfilter=^%d).

if I click on the Logo, what is the only thing that remains, I will get back to the login menue.

Seems to me as it is a bug?

5 Comments
Avatar
Discard
Avatar
Ermin Trevisan
-

What do you see when try the database selector: subdomain.domain.tld/web/database/manager ?

Avatar
Ermin Trevisan
-

Also my regexp looks like ^%d$ , I don't know if the $ sign makes a difference.

Avatar
Lucas Huber
-

@Erwin I see all the database in the databse selector that have an identical beginning of the db-name. Eg. If my domain is demo.domain.tld and I have also a db called demo_xx I cann see this one too. I can't imagine that the $ sign at the end of your dbfilter regexp makes a different? But I should try: on the difference dee: https://www.odoo.com/de_DE/forum/hilfe-1/question/domain-based-db-filter-6583

Avatar
Ermin Trevisan
-

The $ seems not the issue in this case. The reason why I'm asking is that I experience also strange behaviour with logouts when I'm using Odoo without dbfilter, means while having access to a list of several databases. A new login by selecting the appropriate database from the list solves the problem. I definitely do not have any problems as long as dbfilter identifies exactly 1 database which should be the case in production mode anyway if you want to avoid different kind of problems.

Avatar
Ermin Trevisan
-

I don't remember if it makes a difference if you properly log out before selecting another database and then activating the developer mode. But I have to confess that this issue doesn't bother me too much, I have many more serious problems to solve :-)

17 Answers
2
Avatar
Prowler
Best Answer

+1

I can confirm.

I'm experiencing this behavior after setting dbfilter=^%d$ in my config file.

Here are my logs, if anybody will be able to look into this problem: http://pastebin.com/eXHTxzf7

3 Comments
Avatar
Discard
Avatar
Prowler
-

Can somebody upvote me... I only need 1 more karma.. :)

Avatar
Ermin Trevisan
-

I did not see this earlier, sorry. If it is not yet solved, by looking at your log, i can see that the requests on port 8069 seem all to look like https://example.com. In this case you do not have a subdomain and Odoo is looking for the database "example", this is the same as if your request is https://www.example.com.

Avatar
Lucas Huber
-

@Ermin Indeed according the log of @Prowler the source of the problem might be different in his case. In my case everythink works fine until I activate the deveopler mode. NGINX is configured well and same configration works with Odoo 8 flawless.

1
Avatar
Lucas Huber
Best Answer

Here is my log file with the two relevant entries:

(At my first trial I didn't found the relevant entries!)

2016-03-30 12:01:37,176 1151 INFO ? werkzeug: 127.0.0.1 - - [30/Mar/2016 12:01:37] "GET /web_editor/static/src/js/snippets.options.js HTTP/1.0" 200 -
2016-03-30 12:01:37,207 1151 WARNING ? openerp.http: Logged into database 'test', but dbfilter rejects it; logging session out.

2016-03-30 12:01:59,159 1151 INFO ? werkzeug: 127.0.0.1 - - [30/Mar/2016 12:01:59] "GET /web_editor/static/src/xml/snippets.xml?debug=1459339218287 HTTP/1.0" 200 -
2016-03-30 12:01:59,383 1151 INFO ? werkzeug: 127.0.0.1 - - [30/Mar/2016 12:01:59] "GET /web_editor/static/src/xml/translator.xml?debug=1459339218461 HTTP/1.0" 200 -
2016-03-30 12:01:59,423 1151 INFO test werkzeug: 127.0.0.1 - - [30/Mar/2016 12:01:59] "POST /web/webclient/bootstrap_translations HTTP/1.0" 200 -
2016-03-30 12:01:59,445 1151 INFO test werkzeug: 127.0.0.1 - - [30/Mar/2016 12:01:59] "POST /web/proxy/load HTTP/1.0" 200-
2016-03-30 12:01:59,508 1151 INFO test werkzeug: 127.0.0.1 - - [30/Mar/2016 12:01:59] "POST /web/webclient/translations HTTP/1.0" 200 -
2016-03-30 12:02:05,617 1151 INFO test werkzeug: 127.0.0.1 - - [30/Mar/2016 12:02:05] "GET /web?debug HTTP/1.0" 303 -
2016-03-30 12:02:05,796 1151 INFO test werkzeug: 127.0.0.1 - - [30/Mar/2016 12:02:05] "GET /web/login HTTP/1.0" 200 -
2016-03-30 12:02:21,176 1151 WARNING test openerp.addons.base.ir.ir_cron: Method `bus.presence.check_users_disconnection`does not exist.



1 Comment
Avatar
Discard
Avatar
Prowler
-

I'm afraid this question won't get any more attention as it is buried under the new ones. The "support" ends here. Damn!

0
Avatar
fussions
Best Answer

Hello Lucas,

I've faced the same issue. I've resolved it by properly configuring my reverse proxy nginx server. It wasn't passing right headers to static resources requests (/web/static). I had to set proxy_set_header directive with host variable. Also it should be set on longpolling requests if you are using the im feature.

Avatar
Discard
0
Avatar
Ivan Elizaryev
Best Answer

Workaround for one who needs debug mode only for Technical Features:

https://github.com/OCA/server-tools/tree/9.0/base_technical_features

Avatar
Discard
0
Best Answer

Hello,

As I am experiencing the same problem, please find below the log:

2016-06-13 22:59:37,842 3002 INFO ? werkzeug: 127.0.0.1 - - [13/Jun/2016 22:59:37] "GET /base/static/src/css/modules.css HTTP/1.0" 200 -
2016-06-13 22:59:37,843 3002 WARNING ? openerp.http: Logged into database 'database_name', but dbfilter rejects it; logging session out.
2016-06-13 22:59:37,849 3002 WARNING ? openerp.http: Logged into database 'database_name', but dbfilter rejects it; logging session out.
2016-06-13 22:59:37,856 3002 INFO ? werkzeug: 127.0.0.1 - - [13/Jun/2016 22:59:37] "GET /web/static/src/less/web.assets_backend/variables.less.css HTTP/1.0" 404 -
2016-06-13 22:59:37,861 3002 INFO ? werkzeug: 127.0.0.1 - - [13/Jun/2016 22:59:37] "GET /web/static/src/less/web.assets_backend/enterprise_compatibility.less.css HTTP/1.0" 404 -
2016-06-13 22:59:37,873 3002 INFO ? werkzeug: 127.0.0.1 - - [13/Jun/2016 22:59:37] "GET /web/static/src/less/web.assets_backend/utils.less.css HTTP/1.0" 404 -
2016-06-13 22:59:37,879 3002 INFO ? werkzeug: 127.0.0.1 - - [13/Jun/2016 22:59:37] "GET /web/static/src/less/web.assets_backend/modal.less.css HTTP/1.0" 404 -
2016-06-13 22:59:37,885 3002 INFO ? werkzeug: 127.0.0.1 - - [13/Jun/2016 22:59:37] "GET /web/static/src/less/web.assets_backend/notification.less.css HTTP/1.0" 404 -


Many thanks for your help with this.


Michel

Avatar
Discard
-1
Avatar
TKF
Best Answer

Hello Lucas,


Can you post an extract of your log when you get that error ?



Regards,

FTK


Avatar
Discard