Help

0

The style compilation failed

Avatar
hello@lagence49.fr

The style compilation failed, see the error below. Your recent actions may be the cause, please try reverting the changes you made.

Could not get content for /muk_web_branding/static/src/scss/primary_colors.custom.muk_web_branding._assets_primary_variables.scss defined in bundle 'web.assets_common'.

Avatar
Discard
4 Answers
1
Avatar
hello@lagence49.fr
Best Answer

thank you for help, impossible. I restart the server

Avatar
Discard
0
Best Answer

Try this command

sudo apt-get install npm

sudo npm install -g less@3.10.3

Restart your odoo 

Avatar
Discard
0
Avatar
Hilar Andikkadavath
Best Answer

You may be removed the muk_web_branding addon from addons path without un-install.  Try to put back the addon on the same path.

Avatar
Discard
0
Best Answer

I was also getting similar problem in Odoo 11:


2021-06-28 16:37:04,158 4908 WARNING SAS_cellntell odoo.addons.base.ir.ir_qweb.assetsbundle: (b'', b'The "--no-js" argument is deprecated, as inline JavaScript is disabled by default. Use "--js" to enable inline JavaScript (not recommended).\nArgumentError: Error evaluating function `floor`: argument must be a number in - on line 3251, column 17:\n3250 height: @planner-height;\n3251 margin: floor((@odoo-navbar-height - @planner-height)/2) 10px 0;\n3252 cursor: pointer;\n\n')This error occured while compiling the bundle 'web.assets_common' containing:
- /web/static/lib/bootstrap/less/variables.less
- /web/static/lib/bootstrap/less/mixins/vendor-prefixes.less
- /web/static/lib/bootstrap/less/mixins/buttons.less
- /web/static/lib/bootstrap/less/mixins/clearfix.less
- /web/static/lib/bootstrap/less/mixins/size.less
- /web/static/src/less/variables.less
- /web_enterprise/static/src/less/variables.less
- /web/static/src/less/utils.less
- /web_editor/static/src/less/web_editor.variables.less
- /web/static/lib/bootstrap-datetimepicker/src/less/_bootstrap-datetimepicker.less
- /web/static/src/less/fonts.less
- /web/static/src/less/navbar.less
- /web/static/src/less/mimetypes.less
- /web/static/src/less/modal.less
- /web/static/src/less/animation.less
- /web/static/src/less/rainbow.less
- /web/static/src/less/datepicker.less
- /web_enterprise/static/src/less/fonts.less
- /web_planner/static/src/less/web_planner_common.less
- /web_tour/static/src/less/tip.less
- /web_tour/static/src/less/keyframes.less
- /stock/static/src/less/stock_traceability_report.less

I have checked the less version in Ubuntu 20.04:

lessc --version
lessc 4.1.1 (Less Compiler) [JavaScript]

I have installaed less@3.10.3

sudo npm install -g less@3.10.3

This has solved my issue.

Avatar
Discard