Help

1

Remove port from url odoo/nginx

Avatar
JK

Hi, i have a website running odoo, now to reach the website its required to have :8069 at the end of the url. how can i remove it? i have tried googling and searching online but nothing seems to work for me. im using nginx to redirect the :8069 to normal port 80 or 443 so i can type the url without the port and still reach the website but i just can not get it to work.

im trying this code from the odoo guide but it doesnt help me much...

server {
   listen 80;
   server_name odoo.mycompany.com;
   rewrite ^(.*) https://$host$1 permanent;
}

it just returns me to the normal nginx welcome screen.


i have also tried 

server {
   listen 80;
   server_name odoo.mycompany.com;
   return 301 http://$host$server_name;
}

this just returns and endless loop of url? 

example: odoo.mycompany.com/odoo.mycompany.com/odoo.mycompany.com/

exactly like that but never ending... and it doesnt work ofcourse..
can someone help me? 


1 Comment
Avatar
Discard
Avatar
Ermin Trevisan
-

Please read the documentation and study the nginx configuration example there.

3 Answers
1
Avatar
Krys.Raj
Best Answer

It's not so complicated... 
look at this example (this one covers the SSL, which is a standard today),

https://linuxize.com/post/configure-odoo-with-nginx-as-a-reverse-proxy/

but for the localhost you do not have to use SSL.
BUT, what is the most important thing here that you are missing?
Setting up "upstream" in the header. 


upstream odoo { server 127.0.0.1:8069; }

Then you use the upstream name as the name to point you proxy server.

listen 80;
server_name odoo.example.com;

location / {
proxy_redirect off;
proxy_pass http://odoo; # here you pass the request to the upstream name }

But notice, I am giving to you only the essentials above, for full configuration please use the example I have provided to you or maybe even better, this one from the official deployment guide:

https://www.odoo.com/documentation/15.0/administration/install/deploy.html#id7


And remember to turn on proxy mode for Odoo, in the odoo configuration file or using the right proxy_mode=True parameter when you fire the odoo-bin from command line without configuration file.

in /etc/odoo.conf set:

proxy_mode = True

Hope this helps,
If it does, vote +1 👍
and select as best answer ✅



1 Comment
Avatar
Discard
Avatar
Ermin Trevisan
-

I want an upvote too :-)
and my answer is better :-)

0
Avatar
Ermin Trevisan
Best Answer

If nginx is too complicated for you (as it is for me) you can check Caddy server as alternative as I have described in this post here: https://www.odoo.com/forum/help-1/automatic-ssl-easy-way-to-secure-your-odoo-website-domains-using-caddy-server-2-and-let-s-encrypt-certificates-176598

Avatar
Discard