Odoo Help

2

Qweb reports missing css on pdf export

By
Ricardo Martins
on 10/1/14, 4:01 PM 6,610 views

Hi, 

All my Q-Web reports (invoice, sale order, purchase, etc) are missing the css in pdf export and are all good in html export... Can anyone please help? I am running ubuntu 14.04 and wkhtmltopdf 12.01... Next is a preview of the problem on the left, and the html export with the css tables on the right... 

Thanks

Hi, I want to reproduce the problem. When export and dialog save file opened. Don't immediately save the file, but check the server in /tmp. There should be some report*.html files. Can you share the files?

Ben Bernard
on 10/7/14, 11:35 PM

Ups, I was wrong, sorry.

Ben Bernard
on 10/7/14, 11:51 PM
3
Ricardo Martins
On 10/13/14, 5:26 PM

Ok, its solved. I had 2 diferent problems:

 

1 - the css must be added directly to the report

2 - The url parameter must have a :8069 at the end

 

Hope this helps for others.

 

 

The second options works for me

Osval Reyes
on 4/28/16, 9:34 AM
1
David McNeill
On 4/15/17, 5:19 AM

The global parameter Theo describes can be found in

Settings > Technical > Parameters > System Parameters

This can only be accessed when in 'debug' mode, add url parameter ?debug after web in your browser address bar.

You have to create a new record with

key:    report.url

value:    http://localhost:8069

Further discussion here.. https://github.com/odoo/odoo/issues/2934

0
info@pdg.solutions
On 3/16/18, 6:30 AM

I want to give my 2 cents on this!

If you are loading your instance in port 80, you should've probably added the iptable record in your system. Then you've tried to print an invoice and everything is screwed. Ok!

Because you've changed the URL we need to say Odoo where are the assets now and because the project doesn't know anything about the iptable record you need to specify where the assets (css) are, so adding the following record to your system global parameters will solve the issue. 

Go to debug mode, either by adding the `?debug` parameter at the end of the URL or clicking in the profile at the top right and then on About. You'll see a popup with a button that says `Activate debug mode`. If you don't see it, you're not logged in as Administrator!

Go to Settings > Parameters > System Parameters

Add the following key/value:

Key: `report.url`

Value: `http://localhost:8069`

Those exact values! localhost is not a placeholder, use that exact same URL!

Try to print an invoice ;)

You're welcome!

0
Open Alpha LLC
On 9/21/16, 8:13 AM

Actually if you are sitting behind some kind of proxy (containerized odoo/ngix/squid etc) you need to set a global parameter 'report.url' = 'http://localhost:8069' and it will work like a charm all the time.


Regards

Theo


you are amazing man! the localhost solved the problem i have been looking to fix for the last 2 weeks!!!

NETLINKS, Farshid G.
on 2/12/18, 12:25 PM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

3 follower(s)

Stats

Asked: 10/1/14, 4:01 PM
Seen: 6610 times
Last updated: 4/10/18, 9:58 AM