Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

ProgrammingError: column res_users.partner_id does not exist

By
Bharathi
on 2/7/13, 7:27 AM 1,352 views

I am trying to restore the database of 6.1 in openupgrade-server 7.0 Following error occurred

ProgrammingError: column res_users.partner_id does not exist.

Thanks for giving reply.Can you tell me the procedure how to migrate the database of 6.1 manually.

Bharathi
on 2/7/13, 7:37 AM

Actually i have upgraded my 6.1 server to 7.0 from launchpad. In that upgraded server, i am trying to restore my database.

Bharathi
on 2/7/13, 7:43 AM
3

Alexandre Fayolle - Camptocamp

--Alexandre Fayolle - Camptocamp--
1109
| 5 6 8
Le Bourget-du-Lac, France
--Alexandre Fayolle - Camptocamp--

Alexandre has been working on Odoo at Camptocamp since 2012 as a project manager and technical lead. He is an active actor in the Odoo Community (github projects, mailing lists, IRC...), and wants to build a better ecosystem for Odoo developers. He is a member of the Odoo Community Association board and an active contributor to the OCA projects.

Alexandre Fayolle - Camptocamp
On 2/8/13, 4:32 AM

You cannot upgrade from 6.1 to 7.0 like this. OpenERP SA sales an upgrade procedure and does not give it out for free. You will have to get in touch with them to see how things can be sorted out.

On the other hand there are efforts for a community built opensource migration solution, but as far as I know the migration from 6.1 to 7.0 is not supported yet. Your contribution would be welcome, though.

Keep in mind that selling the migration solution is a means of generating revenue for OpenERP SA, used for financing the development of OpenERP. If you can afford it, I strongly recommend going that way.

2

Sudhir Arya (SA)

--Sudhir Arya (SA)--
10150
| 6 8 8
Ahmedabad, India
--Sudhir Arya (SA)--

Working as an OpenERP/Odoo developer and a Team Leader 

Top 5 Odoo contributor On Stackoverflow

LinkedIn

Blog

Stackoverflow

Sudhir Arya (SA)
On 2/7/13, 7:30 AM

Database of OpenERP-6.1 will not work in OpenERP-7.0.

If you want to use data of old version, you have to manually migrate the database.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/7/13, 7:27 AM
Seen: 1352 times
Last updated: 3/16/15, 8:10 AM