Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Problem with char "&" in password with thunderbird module.

Bonnet Denis
on 3/12/13, 6:52 AM 715 views

I've installed the thunderbird module and it's working fine But I've one user with a password that contain the '&' char and the module don't work with him.

I think it's an encoding problem. What can I do for that or where can I post the bug?

EDIT: After research I found the problem: there is no encoding for special char of password or login. So I have an url like this:


My server don't understand "123abc&456" like a password but "123abc" like password and 456 like keyword. It's the same with the login and database.

I will change the function that create this url but I want to notice this to the people develops this module, How can I contact they?

I have 2 solutions:

  1. find a REGEXP to change the char & in "& amp;" in ALL calling methods.
  2. find a way to change the answer from xml-rpc call.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 3/12/13, 6:52 AM
Seen: 715 times
Last updated: 3/16/15, 8:10 AM