Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Mass mailing campaigns do not track opened and replied e-mails?

By
Yenthe
on 10/7/14, 3:54 AM 5,986 views

Hi guys

Today I've download and installed the mass mailings module for Odoo V8.
I've setup a testaccount with an incoming and outgoing mailserver and then added the email test account to Odoo.
Everything seems to fine up until the emails are sent. They are sent to the emailadresses I provide but it doesn't seem to track who has read the emails and who replied?
Can anybody tell me what I'm doing wrong or if I am missing something?

Here are my settings.
My campaign: 

My inbox:


My reply on this e-mail:

 

My e-mail configuration settings:

Yet my Odoo still says 0% is opened and 0% has reponded. I do not have anything in my inbox on Odoo either. My e-mail reply is in my Gmail account though!
Any solutions / help?

With kind regards
Yenthe

I see that the images in your email are also not loading. So I think your problem might be because you have installed Odoo on your localhost, which does not have a valid domain. Therefore, when people open your mass mail-outs, your Odoo install does not receive the response.

Bodybuildpro.com, Jaron Soininen
on 10/25/14, 4:29 AM

@Jaron, this is not the problem. Sadly there are a few major bugs with parameters regarding to the IP internal and external of the server and multi-database use. I'm looking into this with the developers and we're trying out patches right now. I'll post back an answer with a detailed explenation/fix when everything is verified! :)

Yenthe
on 10/26/14, 6:29 AM

Hi, Have you found fixes ? emailing doesn't work for now ...

6 IT, Jean-Marc Dupont
on 10/30/14, 1:40 PM

@Jean-Marc, yes I have find a solution but its rather lengthy. I will write out the answer for you tommorow morning! :)

Yenthe
on 10/30/14, 2:55 PM

I found that this is due to not setting session.db. In my case - when I first opened any odoo site - then tracking image was opened correctly. I've modified openerp/http.py: --- http_orig.py 2014-10-31 07:25:02.941976640 +0100 +++ http.py 2014-10-31 07:08:12.907227392 +0100 @@ -324,7 +324,14 @@ The database linked to this request. Can be ``None`` if the current request uses the ``none`` authentication. """ - return self.session.db if not self.disable_db else None + if not self.disable_db: + if self.session.db is None and 'db' in self.httprequest.args: + self.session.db = self.httprequest.args['db'] + return self.session.db + else: + return None + + #return self.session.db if not self.disable_db else None @lazy_property def httpsession(self):

Sławomir Lis
on 10/31/14, 2:30 AM

sorry I forgot to add the image content in last comment.

Yogesh
on 12/29/14, 11:22 AM
3

Yenthe

--Yenthe--
6676
| 7 7 8
Turnhout, Belgium
--Yenthe--

My Odoo blog: http://www.odoo.yenthevg.com/

My Twitter: https://twitter.com/Yenthe666

Yenthe
On 10/31/14, 9:00 AM

To get everything working you will need to update some code in the mass_mailing module.
Patch for the new report.url parameter: https://github.com/odoo/odoo/pull/3260.patch
Patch for the mail_mail.py file under mass_mailing/models
and main.py under mass_mailing/controllers:https://github.com/odoo/odoo/pull/3289.patch

You will need to apply those patches. Or alternatively copy the content from these files and import them in your files.
main.py file: http://pastebin.com/zAw64WpH
mail_mail.py file: http://pastebin.com/6g2ddfdZ

After you've applied those patches you can add a new parameter report.url under settings > Parameters > System Parameters with the IP of your Ubuntu VM.
Now you can set a web.base.url, a web.base.url.freeze (to be sure the URL isn't changed by Odoo itself) and a report.url.
Why is this? With this you can define the web.base.url to make the URL for your images and e-mails and use the report.url to make the URL for printing files out in PDF.
Your final settings should look like this:
Now save all your files, edits, ... and restart your Odoo. From now on you can use mass mailing, all images and tracking of opened e-mails will work.

NOTE: At the time of this answer mass_mailing is not supported for multiple databases! This will only work if you have one database or use the --db-filter parameter.
For more information see: https://github.com/odoo/odoo/pull/3289 
Odoo is working on a multi-database fix for tracking but images will not be supported in multi-databases most likely.

 

Are all these patches available in last published version of Odoo ? Is development team aware of this ?

6 IT, Jean-Marc Dupont
on 10/31/14, 9:23 AM

They seem to be added to the Github Odoo branche (as you can see here https://github.com/odoo/odoo/blob/8.0/addons/mass_mailing/controllers/main.py). But I don't think they are already into the download link from the Odoo website itself..I'd manually check both files to be sure. I've tested these patches and setup the fixes for this, so yes a developer is aware of this!

Yenthe
on 10/31/14, 9:28 AM

This doesn't seem to work for me. I see a broken image in inbox in chrome but nothing in firefox. method track_mail_open(self, mail_id, **post) never gets. How should image blank.gif appear in my inbox. is it okay to appear broken image ?

Yogesh
on 12/29/14, 10:30 AM

@Yogesh if you get a broken image preview it means there is still something wrong / you did something wrong. Are you running your Odoo on ONE database and did you follow all my instructions?

Yenthe
on 12/29/14, 10:59 AM

Yes I read carefully multiple times. Running database with --db-filter option. I can see this is being append with body of mail but can't find where blank.gif exists.

Yogesh
on 12/29/14, 11:09 AM

sorry it seems kind of spamming but its odoo removes html content and makes blank comment.

Yogesh
on 12/29/14, 11:13 AM

Hi @Yenthe, I have an issue on this today, in my installation I could see correctly the percent of opened emails but I cannot see the email address of who open the email because the email field in the statistic is gone after the email is send. Any workaround on this?

Axel Mendoza
on 12/3/15, 1:10 AM

Hi @Axel I guess you could counterpart this by writing the e-mailadres away on the model on the moment it is being sent? By default there doesn't seem to be anything to keep track of the e-mail anyway.

Yenthe
on 12/3/15, 1:58 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

5 follower(s)

Stats

Asked: 10/7/14, 3:54 AM
Seen: 5986 times
Last updated: 3/16/15, 8:10 AM