Help

6

how to configure email gateway

Avatar
jheszica

Hi, Good Day, Can anyone please help me to configure my Email Gateways in OpenERP version 7, so that I can send notifications to a specific employee about his/her task. Thanks in advance.,

Your opinion will be highly appreciated. :D

1 Comment
Avatar
Discard
Avatar
Martin
-

You should indicate which of the ones below is the best answer to your question. While you leave that ambiguous people will keep trying to supply an answer that might satisfy you.

7 Answers
8
Avatar
Shelton
Best Answer

The Email outgoing server can be configured in Settings>>Technical>>Email>>Outgoing mail serversrver

Incoming Server Configuration:

Server Type : POP Server
Server Name:  pop.gmail.com
Port: 995
SSL/TLS: True
Username: user@gmail.com
Password: userpwd
Avatar
Discard
8

You will find Email outgoing server in

Settings>>Technical>>Email>>Outgoing mail servers

Fill mandatory fields:

SMTP Server: smtp.gmail.com

Connection Security: Select Any One

Username: Your E-Mail user name

Password: Your E-Mail password

2 Comments
Avatar
Discard
Avatar
Vikram
-

Hi Arya, I have doubt. I am working on email configuration in openerp 7 with my client domain. I couldnt configure his domain with OpenERP. Entered his server name in Server Name field. If i Choose IMAP server as Server type should i add imap.mydomain.net? or use pop for pop.mydomain.net. Please mention ur comment whether i m right direction? Or Else any other procedure for do this one..

Avatar
Shahid Ali
-

The answer above furnished is exactly true.But how can i configure email servers for different user with the different email id and passwords.

2
Avatar
Abner Galeno Jr.
Best Answer

For a [gmail] incoming port server, you can either choose IMAP (port 993) or POP (port 995) protocol - summarized here.

From gmail help article, it seems IMAP is a more modern protocol, so I chose it.

For Incoming Mail Server, assuming you chose the IMAP protocol instead of POP:

Navigate to Settings/Configuration/General Settings/Configure the incoming email gateway

Name          : *anything you want*
Server Type   : IMAP server
Server Name   : imap.gmail.com
Port          : 993
SSL/TLS       : [✔] *make sure to check this or else you will get an error*
Supply your email address and password. 
I did not supply any other information to the Server Action Field or to the Advanced tab.

Only OpenERP users that supply their email address and password to the Configuration can fetch the unread messages in their inbox and will appear in the Messaging Module. As I have read, OpenERP will fetch every 5 minutes but you can press Fetch Now to force the fetch.

BTW, i'm using google apps email server but I'm using a custom domain, so my email looks like: myname@customdomain.com but is still served by gmail

actual screenshot of my settings


For an outgoing email setup, even if I configure all the emails of many users, the email is always sent from the first configured [outgoing] email, also asked here

All emails that arrive on my inbox is from openerp@mycustomdomain.com. I also don't know how to change the "from" address. Maybe Fabien's suggestion of configuring a local server will make it work.

5 Comments
Avatar
Discard
Avatar
jheszica
-

Thanks to you answer Sir, however, I am just a bit confused about the Port setting, is 993 the default setting? :) thanks again,

Avatar
Fabien Pinckaers (fp)
-

The best approach is to use Local Server instead of POP or IMAP in the selection box. It gives you the script to use on your own email server. That way, all email aliases will work automatically.

Avatar
Abner Galeno Jr.
-

@jheszica: only use port 993 if you chose the IMAP protocol for the "Server Type" , and I have updated my answer :)

Avatar
Abner Galeno Jr.
-

@fabien wow thanks for the tip I'll try a local mail server. It seems "a local mail server" is the only answer to this question: http://help.openerp.com/question/413/how-i-can-change-the-from-field-value-when-sending-a-message-because-it-always-has-the-same-email-address/ . Is my assumption correct?

Avatar
jheszica
-

Thanks to all your answers Sir. it is really a big help for me. :D

0
Avatar
Nikhil kushwaha
Best Answer


Server name : smtp.gmail.com

Port: 465   

User name: something@gmail.com

Password:****

Priority  : 10


Avatar
Discard
0
Avatar
kathan
Best Answer

You can configure your mail gateway of any service provider, for example if you are using gmail then the configuration will like this, •Gmail SMTP server address: smtp.gmail.com •Gmail SMTP user name: Your full Gmail address (e.g. example@gmail.com) •Gmail SMTP password: Your Gmail password •Gmail SMTP port: 465 •Gmail SMTP TLS/SSL required: yes other mail options are also available.

Avatar
Discard
0
Avatar
jheszica
Best Answer

Thanks to all your feedback, I can now send Emails using ERP. I am still exploring ERP so it is very helpful for me. :)

But can you also help me with configuration of Incoming Mail Servers. I really don't have idea on how to configure it. thanks again in advance

1 Comment
Avatar
Discard
Avatar
Shelton
-

I've edited my answer for incoming mail server configuration

0
Avatar
Oliver Prenn
Best Answer

So finally I succeded in getting emails for a single email to a discussion group.

  • Create an imap account for that email test@test.com
  • Change the alias on the discussion group to test@test.com -In Actions to Perform on Incoming emails => Create new Record "Discussion group"

This worked for me. But I still do not understand why some messages are sent and others not.

Question: I want the users to get additionally emails on all the notifications from their message inbox. I changed the preferences to "Incoming Emails and Discussions" but user do not get new messages?

Avatar
Discard