Odoo Help


Google Oauth using Https:// protocol

on 10/5/15, 8:14 AM 1,102 views

Following the instruction for Odoo's oauth provider and developer google project  authentication settings (using https://mydomain/auth_oauth/signin" )  I keep getting the problem when using https:// as default protocol.

The "request.httprequest.url_root" from controllers/main.py (line 58 and 75) sending out http:// as default protocol.   So, when Iogin with Google account. I always got  "Error: redirect_uri_mismatch" error.

So, what should be done? I try to modified the main.py to use "web.base.url" but keep getting the following error:

File "/opt/odoo/addons/bus/bus.py", line 188, in poll

raise Exception("bus.Bus unavailable")"

And the system was lock at 500 error.

So, anyone can share the possible solution will be appreciated.



Akhil P Sivan

--Akhil P Sivan--

| 5 4 7
Kochi, India
--Akhil P Sivan--

Interested in exploring Odoo both technically & functionality wise.

email-id : akhilpsivan01@gmail.com

Akhil P Sivan
On 10/5/15, 8:20 AM


Please check the following post, that might be useful for you to ensure the configuration steps:


Thank you for the post and link. I did try the setting but it does not working. Our firewall does not allow access 8069 directly from outside domain which include Google. I setup using nginx reverse proxy to port 43 for SSL encryption. That's why it have to good through https://. But thank you anyway!

on 10/5/15, 8:27 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 10/5/15, 8:14 AM
Seen: 1102 times
Last updated: 10/5/15, 8:20 AM