Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

6

OpenERP and Google OAuth

By
Santiago
on 3/15/13, 3:26 PM 15,725 views

Greetings,

In our company we use Google Apps for our business, and we would like to set up with OpenERP, so based in documentation and other forum posts i did the following:

I have no idea what else to do, I have tried all the possible combinations with the email and username in OpenERP, but it seems I am missing something. Where do I configure or associate the user from OpenERP with the user of Google Apps?

Thanks!

Santiago

Also in the system parameters i changed the "mail.catchall.domain" from - http://subdomain.mydomain.com - to only - http://mydomain.com - this change is to have the same domain as my google apps account.

Santiago
on 3/15/13, 3:51 PM
9
Santiago
On 3/16/13, 4:01 AM

Found the solution!...

If you follow the steps above you will be able to successfully configure Google Apps (Gmail) with OpenERP via the OAuth module. The only thing i was missing is an extra step I found in a youtube video; you have to:

  • Go to Settings - Users
  • To the users you want to give OAuth access, send them a password reset by using the "Send reset password instructions by email" option.
  • Ask your users (or yourself) to use the link they receive in their email, but, when they open it, they will only see the log in screen with the "Log in with Google" option. (no typical change password option available)
  • Use the proper Google account and voila! - Now it connects smoothly.

This worked for me, might be useful for someone else. Maybe a more technical user could explain us why it happens this?.

The Youtube video that show how to log in with Google in OpenERP: http://www.youtube.com/watch?v=A-iwzxEeJmc

Cheers!

Can't seem to find the "Send reset password instructions by email" option in the Settings - Users area. Am I missing a module? I only see option to change password without email.

grayson
on 3/25/13, 5:59 PM

Grayson, you have to enable the "Technical Options" for your administration user, under Configuration - Users - "Your User" - Access Rights ;-)

Santiago
on 4/1/13, 12:59 PM
6

Martin

--Martin--
1978
| 5 6 8
Cornwall, Canada
--Martin--

Analysing, designing, coding and mentoring since 1975. Kilobytes to terabytes. Punch cards to punchy sites. My OpenERP video series: http://www.youtube.com/playlist?list=PLq7op4J183lX44ZlXPiHxUpRvmmRDtxye My Google Speadsheets --> OpenERP Data Pump project: http://martinhbramwell.github.io/GData_OpenERP_Data_Pump My email (with spaces removed) : mhb . warehouseman @ gmail . com

Martin
On 5/1/13, 10:37 AM

For future readers.

I have created a (7 minute long) video series that incorporates the steps in the excellent correct answer provided here by Santiago S. into a complete demonstration beginning with an empty database.

Google OAuth Demo

I hope you find it helpful.

Note to AYODEJI OGUNYEMI : I deleted your answer by mistake. Sorry. Please watch the above movie and ask a NEW question. Don't use the answers area as a place to ask new questions.

1
seeram trinath babu
On 9/19/14, 10:13 AM

Hi! Its worked fine for me!, but thing is that it was allowing of unknow user with his gmail credentials to login into that..even though he can`t access the modules as he doesn`t see any of then because of template user as default,, but can any one help me how to restrict any other user rather than company`s alias mail extention should get error message to get rid of access into OpenERP.

Thank`x in advance

1
David Dean
On 9/18/14, 11:38 AM

I had problems getting Odoo 8 to authenticate against my Google Apps domain with OAuth2. The process for Google Apps is different to standalone GMail and there are some extra steps to complete. Eventually I managed to get it working and I've put together detailed instructions here:

http://odootricks.wordpress.com/2014/09/18/setting-up-google-apps-authentication-for-odoo/

Hopefully this will help others.

 

0
ayodeji ogunyemi
On 8/21/13, 10:38 AM

hello everyone sorry to wake up this thread, i am on the step of getting the google api, when i enter the redirect path http://198.x.x.x:xxxx/auth_oauth/signin

i get the invalid redirect ...

i also get this invalid url any one who can help us

Atul Kumar jain
on 7/23/14, 5:47 AM

We are also having this problem.

ITpedia Solutions, LLC, Nicholas Riegel
on 10/23/14, 8:37 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 3/15/13, 3:26 PM
Seen: 15725 times
Last updated: 3/16/15, 8:10 AM