Odoo Help

0

0
5 Answers
1
Papirkriger.no Norway
9/27/17, 9:07 AM

EDIT: Changed answer after reading question better.


Regarding the "Exception: bus.Bus unavailable":

Probably a slight misconfiguration of the system.
Are you running in multiprocess-mode? (With non-zero amount of workers. )
If so, are you running a reverse-proxy? Apache or Nginx?
Have you designated a port for the longpolling-calls?
Have you turned on "proxy_mode = True" in your odoo-config file?

More info here:
https://www.odoo.com/documentation/10.0/setup/deploy.html


Regarding uninstallation of im-module:

  • Stop odoo-service.

  • Take backup of db, either by pgdump to file, or clone the db.

  • Change the state of the im-module and the modules listed as missing dependencies back to "installed" in the table 'ir_module_module'.

  • Start odoo-service.

If it doesn't work;

  • stop the service

  • try running odoo with the update flag, (something similar to this):
    ./odoo-bin -c /etc/odoo_server.conf -d your_database_name -u all

Note!

  • You might have some flags in your conf-file that are uncompatible with the "-d your_database_name"-flag.

  • The names and location of the odoo-conf file may vary depending on installation.

  • Wait until the modules are installed, before trying to access your odoo-installation.

  • You might have to terminate the process and start odoo in the "normal way" (What ever that may be for you)


Missing dependencies:

  • account

  • analytic

  • auth_signup

  • base_action_rule

  • bus

  • calendar

  • crm

  • fetchmail

  • gamification

  • hr

  • hr_timesheet

  • mail

  • mrp

  • note

  • payment

  • portal

  • portal_sale

  • procurement

  • product

  • project

  • rating

  • sale

  • sale_crm

  • sale_stock

  • sales_team

  • stock

  • stock_account

  • survey

  • website_form

  • website_mail

  • website_payment

  • website_portal_sale

  • website_project

  • website_sale



0
Avatar

Mahmoud Egypt

--Mahmoud--
Mahmoud Dot Com
http://www.mah007.com
895
| 1 2 5
Cairo, Egypt
--Mahmoud--

the odoo man

Mahmoud Egypt
12/21/17, 3:32 AM

seem that no one can help in this problem 
and by the way this problem become worst in odoo 11 
we need an odoo expert or some one from official odoo to answer us  how to self this problem 

0
SAWSAN SAMRITA Morocco
4/20/18, 11:41 AM

UP

-1

I had two backups, one for 25th and one for the 27th day. The first one was corrupt, at least it did not solve the issue, and the latter worked - it was the situation with the problem. I have no clue why the first one did not work.

I could not find the modules you listed,  they were not in the ir_modules_modules from the 27th day that gave at least a working website but those were found from the backup database of 25th. I copied the ir_modules_modules data to 27th and run the update from the command line. By following the log (watch 'cat /var/log/odoo.log') it was possible to see how it updated everything.

Now it works.

1 Comment
Fatih Piristine Finland
9/27/17, 10:20 AM

you have changed the state of the module, but you didn't delete related models from ir_model. where all models being loaded

Ask a Question
Keep Informed
2 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now