Odoo Help

2

Email set correctly but email is not being delivered?

By
John Peterson
on 7/11/13, 8:13 AM 10,534 views

Hello,

Both my outgoing and incoming servers have been tested and pasted the connection test.

But when i send an email from the messaging in the crm, i do not get an error and the message is never received on the other end. I tried to look for a log but couldn't find one.

Anyone have any ideas on next steps I could try to troubleshoot this?

make sure that all email settings are correct and match the administrator and domain alias.

Endosoft B.V., Bart van der Meer
on 8/13/13, 12:34 PM

I have similar problem. The email is not delivered from openerp to the customer. But It does when we send it through outlook. What could be the problem.? is the mail sent from openerp considered as spam? Note: The problem is not for all customers though. But for some customers, The email is not delivered. I think that we need to check their email server configuration, gateway and proxy configurations to troubleshoot. If it is for all customer, We can easily fix it. It is either the email server configuration in openerp is not correct or the email id of the customer is not correct or not active

Vivekrajan
on 8/23/13, 2:13 AM

I have the same problem too. My mail is well configured, and I use for testing the same mail address, but the mail is send or not depending on the partner. If it is a company, the mail is never received, and if it is a contact, the mail is received.

Wided Kéfi
on 2/3/16, 6:10 AM

I found what have caused the mail to not been sent, it's not that the partner is a company or contact, but it's the option "receive messages by email" on the partner page.

Wided Kéfi
on 2/3/16, 8:43 AM
3
Andreas Marpmann
On 8/23/13, 11:31 AM
  1. Check your alias domain at:

Settings -> Configuration-General -> Settings: Alias Domain = your-domain.tld

It should be the same as the outgoing server uses as smtp.your-domain.tld

  1. Check the scheduler settings. The Scheduled Action "Email Queue Manager" will send it. It runs every hour, by default.

At: Settings -> Technical -> Scheduler -> Scheduled Actions -> Email Queue Manager

you can edit that.

1
Vivekrajan
On 8/23/13, 3:11 AM

Hi,

There are different things, you need to check.

1) Email Server Configuration: You need to check this first. But you have done it already as per your post.

2) Email status in Setting/mails menu you need to check whether the email status is shown as delivered or failed. That is the log for you.

Based on the email status, Check the following

1) If it is not delivered for anybody:

   a) Check the email id of the customer

   b) Check the email server configuration and restrictions in proxy or gateway.

2) If not delivered for some people:

   a) Check the email id and try to send it from other email clients(outlook)

   b) b) Check the email server configuration and restrictions in proxy or gateway.

Hope it helps.

thanks

0
Sven Seipke
On 1/5/17, 7:02 AM

We have almost the same problem: the emails are delivered only to a part of our customers, all the rest is never delivered. And this behavior never changes, because someone who gets an email once, will always get emails and those who do not get an email, will never get one
We tried also to send emails to our own email addresses and the same problem appeared: some of us get the emails, other never get them! Also we exchanged our email addresses, in order to find out what causes the problems. The email address of the "faulty partner" has been switched to a "proper working" partner. After this exchange the "proper working" partner does not get the emails anymore. So it is definitively the email address that is causing this problem. It is obvious that all settings in Odoo have been checked several times, over and over again, but no wrong setting there. So, what can we do more?
Many thanks for your help!
Sven

0
prasoon gupta
On 5/23/16, 7:11 AM

If you are using gmail and configure as incoming mail  first go to gmail


gmail  setting/security/lesssecureapp 


make it turn on first


and configure incoming mail as smtp.gmail,com    

0
MetAandacht
On 5/15/14, 6:24 PM

Hello people,

We recognized this problem in our situation was the problem that we had two different SMTP servers with the same priority. We've change these and it works!

I hope it work for you to!

 

 

 

 

0
Sudheendra Walvekar
On 2/27/14, 4:32 AM

Please change the connection security as TLS(STARTTLS) instead of SSL/TLS and check. Even though SMTP port for this is 25 by default, you may have to verify from your service provider and use the correct port number.

0

Gopakumar N G

--Gopakumar N G--
1198
| 5 3 7
Cochin, India
--Gopakumar N G--

Senior Software Engineer at BroadTech IT Solutions Pvt. Ltd.

Gopakumar N G
On 9/3/13, 5:28 AM

Check the email template defined in the Settings->Technical->Email->Templates and make sure the configuration is correct. You can edit this section and the edit will not be reverted when server restarts as email templates are defined in the data tag with an attribute noupdate="1". Your problem will be in retrieving values for the fields in email template. If possible provide your email templates's xml code.

0
Luke Thurston
On 4/15/15, 7:31 AM

 

0
Wattlet
On 10/26/13, 7:39 AM

I have similar problem but the emails are always recognized as spam by my Outlook if sent to my email. the attachment are hidden. It can be really annoying for some customers.

What could I do ?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

5 follower(s)

Stats

Asked: 7/11/13, 8:13 AM
Seen: 10534 times
Last updated: 1/5/17, 7:02 AM