Help

0

German Translation of Swiss Chart of Accounts not working

Avatar
Peter Baumann

Hi all,

Maybe someone can help me.

I installed Odoo 9 rc1 on a Virtual Machine with Ubuntu 14.04 successful. I used the nightly build of the *.deb package.

I could go through the initial setup wizard and everything is working well except the translation of the chart accounts for switzerland. It stays always in french, even when I loaded again german translation and overwrite all again.

I have seen that the german translation are there (/usr/lib/python2.7/dist-packages/openerp/addons/l10n_ch/i18n_extra/de.po) and is loaded:

openerp.addons.base.ir.ir_translation: module l10n_ch: loading extra translation file (de) for language de_DE
openerp.tools.translate: loading /usr/lib/python2.7/dist-packages/openerp/addons/l10n_ch/i18n_extra/de.po

So why is the translation not active?

I still have all the accounts in french text which is very complicated for us german speaking swiss to use.


Thanks for any help.

Peter

6 Comments
Avatar
Discard
Avatar
Ermin Trevisan
-

Is the language preference of your user set to german? As long as it is set to english, the french COA will be displayed because there is no english translation.

Avatar
Peter Baumann
-

0 Peter Baumann On 9/22/15, 1:17 PM Hi Ermin, I forgot to mention that. Yes sure I changed to "German / Deutsch". Everything is in German but not the COA. I also loaded the Translation again with the overwrite option, doesn't help.

Avatar
Ermin Trevisan
-

If I remember it correctly, the language preference set at the time of the installation of the accounting module is key (I used to install it with the admin user, which was of course set to english at installation time). In version 8.0 you can change that afterwards using this module: https://www.odoo.com/apps/modules/8.0/account_chart_update/ . Unfortunately I do not have an 9.0 instance ready at the moment to test it.

Avatar
Peter Baumann
-

I also tried to create fresh database, installed NO module, changed user to german language, THEN installed Accounting Module but this also doesn't help...

Avatar
Peter Baumann
-

So the important question is then howto reinstall COA after the initial installation of odoo. In version 8.0 this was possible to reselect a chart of accounts. I checked the manual but couldn't find any information how todo this in v9.0.

Avatar
Ermin Trevisan
-

Accounting has undergone a major refactoring for v9. I will try it myself as soon as possible, but meanwhile you may have more luck with the mailing list: https://www.odoo.com/groups

17 Answers
0
Avatar
Peter Baumann
Best Answer

Hi all,

The only workaround still at the newest release 10 is to use german and not swissgerman language settings. Then the swiss chart of accounts is in german.

When set to Swiss german language everything is in french then.

Avatar
Discard
0
Best Answer

I can not reproduce this problem.  At my installation, the german translations work perfectly. Did you synchronize the terms properly?

Avatar
Discard
0
Best Answer

As I had the same problem with account descriptions not beeing updated I've recognized that the table account_account was used for the chart.


Unfortunately the translation de.po files did not update the account translations in the charts.

/etc/init.d/odoo stop
 sudo  -u odoo /usr/bin/odoo.py --stop-after-init --load-language=de_DE -c /etc/odoo/openerp-server.conf -d odoo
/etc/init.d/odoo start


This didn't help either

DELETE FROM ir_translation WHERE lang='de_DE';
/etc/init.d/odoo stop
sudo -u odoo /usr/bin/odoo.py -d odoo -l de_DE --i18n-import=/usr/lib/python2.7/dist-packages/openerp/addons/account/i18n/de.po --i18n-overwrite
/etc/init.d/odoo start



THE "WORKAROUND"

What finally worked was a dirty workaround updating the account_account table with the values of the translations like the following with postgresql. Now the account texts are in German :)

UPDATE  odoo.public.account_account t1SET  name = t2.valueFROM  odoo.public.ir_translation t2  INNER JOIN odoo.public.ir_translation t3 USING (src)WHERE  t1.name = t2.src;



However this workaround might lead to problems sooner or later.
It would be interesting, if someone knews the right solution for this problem.

6 Comments
Avatar
Discard

What do you mean with "Did you synchronize the terms properly"? (I'm using the community edition)

Avatar
Ermin Trevisan
-

"Settings/Languages/Synchronize Terms"

Avatar
Ermin Trevisan
-

I'm also using the community edition.

Ok, thank you for your help.

Today I did a fresh install Version 9.0c-20160705 (Community Edition) on Debian 8 like mentioned her

https://www.odoo.com/documentation/9.0/setup/install.html

As language I have "German (CH) / Deutsch (CH)"

Switzerland - Accounting l10n_ch is installed

I have synchronised the translations

When I click on Abrechnung / Kontenplan I can see the account name in French and the type in German

Same thing if I click to add a new journal entry (Buchungssatz) and select an account

Then i did change the language to "German / Deutsch" and now I can see the account name it in German

This behavior is not very logical as German CH is explicitly noted

Changing the language again to English leads to the same behavior like

"German (CH) / Deutsch (CH)" with account names in French and type in English

Avatar
Ermin Trevisan
-

The problem is that there is no english translation of the chart of accounts. So if you are logged in with a user set to english language, you will see the french terms of the chart of accounts.

Avatar
Ermin Trevisan
-

This is because the Swiss chart of accounts is provided by CamptoCamp and their primary language (source terms) is french.

0
Avatar
Daniel Meili
Best Answer

Any updates on that?

Avatar
Discard
0
Avatar
Mauro Giudici
Best Answer

Hi any news on this? I have the same issue

Also all the Test for the Taxes are only in frech and I would like to have it in English (Mehrwertsteuer...)

1 Comment
Avatar
Discard
Avatar
Lucas Huber
-

I did just exeperience the same. It is a painfull bug. I try to import a corrected German de.po i18n_extra file, but that didn't work either. I can't figure out how the po file in i18n_extra are handeld by Odoo. Maybe placing a de_CH.po in i18n_extra and then update the module would help.