This question has been flagged
4 Replies

This is the same question (
But since it was closed, I'm making this1

The error appears when i try to install a custom module which originally was made for odoo v10


Odoo Server Error

Traceback (most recent call last):
  File "C:\odoo-11.0\odoo\", line 646, in _handle_exception
    return super(JsonRequest, self)._handle_exception(exception)
  File "C:\odoo-11.0\odoo\", line 307, in _handle_exception
    raise pycompat.reraise(type(exception), exception, sys.exc_info()[2])
  File "C:\odoo-11.0\odoo\tools\", line 87, in reraise
    raise value
  File "C:\odoo-11.0\odoo\", line 683, in dispatch
    result = self._call_function(**self.params)
  File "C:\odoo-11.0\odoo\", line 339, in _call_function
    return checked_call(self.db, *args, **kwargs)
  File "C:\odoo-11.0\odoo\service\", line 97, in wrapper
    return f(dbname, *args, **kwargs)
  File "C:\odoo-11.0\odoo\", line 332, in checked_call
    result = self.endpoint(*a, **kw)
  File "C:\odoo-11.0\odoo\", line 927, in __call__
    return self.method(*args, **kw)
  File "C:\odoo-11.0\odoo\", line 512, in response_wrap
    response = f(*args, **kw)
  File "C:\odoo-11.0\addons\web\controllers\", line 928, in call_button
    action = self._call_kw(model, method, args, {})
  File "C:\odoo-11.0\addons\web\controllers\", line 916, in _call_kw
    return call_kw(request.env[model], method, args, kwargs)
  File "C:\odoo-11.0\odoo\", line 689, in call_kw
    return call_kw_multi(method, model, args, kwargs)
  File "C:\odoo-11.0\odoo\", line 680, in call_kw_multi
    result = method(recs, *args, **kwargs)
  File "<decorator-gen-39>", line 2, in button_immediate_install
  File "C:\odoo-11.0\odoo\addons\base\module\", line 71, in check_and_log
    return method(self, *args, **kwargs)
  File "C:\odoo-11.0\odoo\addons\base\module\", line 446, in button_immediate_install
    return self._button_immediate_function(type(self).button_install)
  File "C:\odoo-11.0\odoo\addons\base\module\", line 539, in _button_immediate_function, update_module=True)
  File "C:\odoo-11.0\odoo\modules\", line 85, in new
    odoo.modules.load_modules(registry._db, force_demo, status, update_module)
  File "C:\odoo-11.0\odoo\modules\", line 343, in load_modules
    loaded_modules, update_module)
  File "C:\odoo-11.0\odoo\modules\", line 242, in load_marked_modules
    loaded, processed = load_module_graph(cr, graph, progressdict, report=report, skip_modules=loaded_modules, perform_checks=perform_checks)
  File "C:\odoo-11.0\odoo\modules\", line 121, in load_module_graph
  File "C:\odoo-11.0\odoo\modules\", line 368, in load_openerp_module
    __import__('odoo.addons.' + module_name)
  File "C:\odoo-11.0\odoo\modules\", line 82, in load_module
    exec(open(modfile, 'rb').read(), new_mod.__dict__)
  File "<string>", line 1, in <module>
ModuleNotFoundError: No module named 'models'

I think right now it it may be just import model change it to from . import models and also check the folder name is models itself


You pointed me to the right direction.

I've changed to "from . import models" also renamed my folder, changed the model class name and the file inside model folder and it worked.

Thanks a lot.

Best Answer

in the

import models


from . import models

Best Answer

i have the exact same problem when i try to download my custom made module i get the same error