Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

XMLRPC Breaking on data with accent marks

By
Jesse Rye
on 5/8/15, 6:03 PM 823 views

I am trying to create a product.template. The product name contains accent marks from the source database I am importing from. These appear to be causing an issue. Has anyone else ran into this and what is the solution? No matter what I do I can't seem to fix this issue.  I even tried encoding it like row['product_nm'].encode('utf8').

Product Name Example:Super Café (Notice the accent e)

Traceback (most recent call last):

File "import_products.py", line 180, in <module>

template_id=sock.execute(dbname, uid,pwd, 'product.template','create',product_template)

File "/usr/lib/python2.7/xmlrpclib.py", line 1224, in __call__

return self.__send(self.__name, args)

File "/usr/lib/python2.7/xmlrpclib.py", line 1578, in __request

verbose=self.__verbose

File "/usr/lib/python2.7/xmlrpclib.py", line 1264, in request

return self.single_request(host, handler, request_body, verbose)

File "/usr/lib/python2.7/xmlrpclib.py", line 1312, in single_request

response.msg,

xmlrpclib.ProtocolError: <ProtocolError for localhost:8069/xmlrpc/object: 500 INTERNAL SERVER ERROR>

0
Jesse Rye
On 5/8/15, 10:57 PM

I believe I figured out my problem. The character was 8859 and needed to be decode and then encoded in utf8

product_name = product_name.decode('8859').encode('utf8'


Once this change was made it worked.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 5/8/15, 6:03 PM
Seen: 823 times
Last updated: 5/8/15, 10:57 PM