Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Why is there no team members to add in project?

By
Mogens Nielsen
on 8/9/13, 11:41 PM 2,609 views

Just created a test system and created to employees and assigned them to two different departments. I then created a user for each employee and assigned it to the employee. If i log in as one of the employees and create a project I am unable to assign the other as a team member of the project. This despite that they belong to the same company and both employees have been given manager rights to the PM module. The admin can see both users in the dropdown but I have not been able to figure out what rights to assign the other users for them to see each other.

UPDATE

I looked in the manual under both access rights and project management module.

The latter only contains 1 line regarding team members “On the Team tab, add Project Members to the project; this is related to access rights too.” And that obviously isn't very helpful to my question.

The manual also mention groups and access rights (though it forgot to mention that it isn’t by default enabled for administrators) but nothing seems to point to anything specific needed regarding visibility of team members.

I have tried creating a new user “test” in the demo site and create a new project with that user. Even though both the user “Administrator” and the user “Demo” has user right to projects they never show up in the list.

Obviously my mind is using a different thought process than whoever created this so any help is appreciated.

What have you entered in the field privacy_visibility ?

Xsias
on 8/12/13, 6:49 AM

Svend, That is the kicker – I have tried all of them! Employees, Portal Users, All Users it doesn’t matter what I pick for visibility, the only option in the list is my own user (and you could argue that as manager of the project I would be a team member by default)

Mogens Nielsen
on 8/12/13, 3:41 PM

I had similar problem but it was because "Survey/User" on Settings->users->select user->other was checked after I removed that then it was possible to add team members (in this selection "other" there should be nothing selected). Not sure if this is your problem.

Laura Jarvenpaa
on 8/13/13, 7:37 AM

Laura, Thank you for the response and suggestion. I had originally marked the checkbox for Survey/Other so it was worth a shot. Unfortunately it didn't fix the problem. I also tried adding "sharing" from applications and added tasks from the technical settings but to no avail.

Mogens Nielsen
on 8/13/13, 11:46 AM
1
Laura Jarvenpaa
On 8/14/13, 11:37 PM

Because Sven Boudesseul asked me to post my comment as an answer so here it is:

I had similar problem but it was because "Survey/User" on Settings->users->select user->other was checked after I removed that then it was possible to add team members. Also it seemed that in this selection "other" there should be nothing initial options (anonymous, portal, user/survey) selected if you want that user is able to select team members. I call them initial options because they were there before any extra modules were installed.

And as add from Morgens himself: "Laura actually pointed me to the solution. If your profile has "Portal" selected in access rights->other then apparently you are not allowed to have any team members in your project. Once I removed the "Portal" check-mark I could add members to my project."

Laura, I am too new to mark my own answer as correct which is why Sven suggested you made a new post. However as you answer isn't right but lead me to the correct answer I would suggest you edit your answer with the info i posted below. That way it is easy for anyone in the future to get the correct answer to the question.

Mogens Nielsen
on 8/15/13, 4:09 AM

Ok, edited it now to include also your own answer.

Laura Jarvenpaa
on 8/15/13, 4:26 AM
1
Mogens Nielsen
On 8/13/13, 12:32 PM

Laura actually pointed me to the solution. If your profile has "Portal" selected in access rights->other then apparently you are not allowed to have any team members in your project. Once I removed the "Portal" check-mark I could add members to my project.

Now I just need to figure out why I can't remove them again!

Good that my comment helped. :)

Laura Jarvenpaa
on 8/13/13, 11:15 PM

Laura can you create an answer (not just a comment) so that Mogens may check her as correct. This will close the question. Thanks !

Xsias
on 8/14/13, 8:23 AM

Ok, I posted it as an answer...

Laura Jarvenpaa
on 8/14/13, 11:38 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/9/13, 11:41 PM
Seen: 2609 times
Last updated: 3/16/15, 8:10 AM