Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Why do I get an Internal server error when creating database after OpenERP 7 install on Centos ?

By
Michael Wassmer
on 5/23/13, 4:55 AM 6,925 views

I am running a Centos 6.3 server and used the installation script found on the old openerp forum to install OpenERP 7.

After the install, I open OpenERP in the browser and create a new database, after I click the button it opens a popup with the following message :

XmlHttpRequestError INTERNAL SERVER ERROR

500 Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

In the terminal, when I run "service openerp start", here's the output I get :

[root@nsxxxxxx openerp]# service openerp start

Démarrage de OpenERP Server Daemon (openerp-server) : [ OK ]

[root@nsxxxxxx openerp]# Traceback (most recent call last):

File "/usr/lib64/python2.6/logging/__init__.py", line 776, in emit msg = self.format(record)

File "/usr/lib64/python2.6/logging/__init__.py", line 654, in format return fmt.format(record)

File "/usr/lib/python2.6/site-packages/openerp-7.0_20130522_231057-py2.6.egg/openerp/netsvc.py", line 144, in format return logging.Formatter.format(self, record)

File "/usr/lib64/python2.6/logging/__init__.py", line 454, in format s = s + record.exc_text.decode(sys.getfilesystemencoding())

File "/usr/lib64/python2.6/encodings/utf_8.py", line 16, in decode return codecs.utf_8_decode(input, errors, True)

UnicodeDecodeError: 'utf8' codec can't decode byte 0xab in position 1184: invalid start byte

What can I do to try to fix this error ?

EDIT : Here is the what "locale" returns on the server:

LANG=en_US.UTF-8

LC_CTYPE="en_US.UTF-8"

LC_NUMERIC="en_US.UTF-8"

LC_TIME="en_US.UTF-8"

LC_COLLATE="en_US.UTF-8"

LC_MONETARY="en_US.UTF-8"

LC_MESSAGES="en_US.UTF-8"

LC_PAPER="en_US.UTF-8"

LC_NAME="en_US.UTF-8"

LC_ADDRESS="en_US.UTF-8"

LC_TELEPHONE="en_US.UTF-8"

LC_MEASUREMENT="en_US.UTF-8"

LC_IDENTIFICATION="en_US.UTF-8"

LC_ALL=

1

patrick

--patrick--
1958
| 5 4 7
Baarn, Netherlands
--patrick--
patrick
On 5/23/13, 11:22 AM

Your error message: UnicodeDecodeError: 'utf8' codec can't decode byte 0xab in position 1184: invalid start byte is about python trying to decode some character, it is expecting it to be UTF8 (Unicode), but it is not. This can happen is you have edited some files on a system which does not run the same kind of OS (Mac, Linux, Windows) as the server.

Another issue might be the usage of accents. Given Démarrage de OpenERP Server Daemon (openerp-server) : [ OK ] , I expect you to be in a french-speaking country. And there they use quite some accents (é or è for example).

Do you get the error with an empty database?

More information about unicode and your errormessage, have a look at the explanation at stackoverflow

Update

After some searching around, I found out that '0xab: ASCII code for Left double angle quotes'. So it loks like that you have modified a file on Windows, and typed ", which has been converted by Windows to the left double angle quotes (can't do it here). Hopefully you have got enough information to fix your issue

Thanks for your answer. The server is on Centos and I connect to it from a Lubuntu box, so the OS is the same kind. I get the error when I push the "Create database" red button. PS. I juste ran the installation script you posted on the question "install-openerp-7-on-red-hat" and I still get the same error after. I'll keep looking.. definetly something to do with encoding.

Michael Wassmer
on 5/23/13, 5:15 PM

Weird you run into that issue, while we do not have that. Given the 0xab character, I still expect somehow that the encoding is the issue, as you also found. Did you install CentOS in French? Is there a username/password you use which has accent in it?

patrick
on 5/23/13, 9:51 PM

I ended up using another install script found on the web, and everything works now (sorry can't post the link due to lack of karma). Still don't know exactly what happened. Thank you anyway for having looked into that.

Michael Wassmer
on 5/24/13, 4:37 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 5/23/13, 4:55 AM
Seen: 6925 times
Last updated: 3/16/15, 8:10 AM