Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Why Cannot I create form view using the interface?

By
Abdullah Sofan
on 9/26/13, 6:29 PM 3,910 views

I tried creating a new module using the web interface using this video as a guide:

youtube.com/watch?v=RrXrxuAKFRY

Everything was good until I faced the problem of not being able to create a form view as the person did in the video (3min 10sec) . I did the exact steps he did but to no avail.

Also, when I try to create a view from User Interface > Views the view type is fixed to "Tree"

am i missing something? Can someone help me?

1
Devvyn Murphy
On 1/31/14, 5:24 PM

The video you linked to shows a workaround for creating new form views, wherein you can use "Manage Views" from the debug menu to change the view type to "form" after creating a temporary "tree" view.

As of the time of this answer, there is a bug in the bundled form view for creating/editing form views, "ir.ui.views form". The "type" field in the model for views has a "readonly" attribute, so you'll need to override that attribute in the form:

If you go to Settings / User Interface / Views and search for "ir.ui.view", you can correct the bug in the view quite easily. Change <field name="type"/> to <field name="type" readonly="0"/>. It should look something like this when you're done:

<?xml version="1.0"?>
<form string="Views" version="7.0">
    <sheet>
        <group>
            <group>
                <field name="name"/>
                <field name="type" readonly="0"/>
                <field name="model"/>
                <field name="priority"/>
            </group>
            <group>
                <field name="field_parent"/>
                <field name="inherit_id"/>
                <field name="xml_id"/>
            </group>
        </group>
        <notebook>
            <page string="Architecture">
                <field name="arch"/>
            </page>
            <page string="Groups">
                <field name="groups_id"/>
            </page>
        </notebook>
    </sheet>
</form>

(Bug reports relating to this issue have already been filed, such as: bugs.launchpad.net/openobject-server/+bug/1103788 )

0
MikeyUM
On 8/12/14, 2:36 AM

Sorry if this is late, but the way to manage that issue, follow this steps:

Go to Settings / User Interface / Views, and find the the tree view you create at the begining and click it, then just click in More/ Duplicate button, then change the name of the view, the type of view from tree to Form, and in the xml code change the word tree to form.

Now you can go to your module and you will find your form view.

It works for me, hope it helps

0
Abdullah Sofan
On 9/26/13, 8:07 PM

Thanks but I already did and that's how I came across the video i mentioned and as I said,

Can you please help with a straight forward specific answer?

I appreciate it.

0

Borni DHIFI

--Borni DHIFI--
5102
| 6 8 9
Tunis, Tunisia
--Borni DHIFI--

Techno Functional Consultant Odoo(OpenERP) 

http://www.linkedin.com/in/borni

Skype : dhifi.borni

Borni DHIFI
On 9/26/13, 7:37 PM

Thanks but I already did and that's how I came across the video i mentioned and as I said,

Can you please help with a straight forward specific answer?

I appreciate it.

Abdullah Sofan
on 9/27/13, 5:38 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/26/13, 6:29 PM
Seen: 3910 times
Last updated: 3/16/15, 8:10 AM