Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

Why can't all users see all sales reports?

By
Jason
on 2/15/13, 6:05 PM 2,602 views

Newly migrating to OpenERP v7, so trying to figure all the new stuff out. In our previous version, v6.0.3, all users were able to see all the Sales Orders, regardless of state. Now, each user can only see Sales Orders where they are the Salesman, and I can't find the option to "clear" this filter setting.

Previously, in v6.0.3, I did find where the default was set to search by uid, but was able to clear this so the default search showed all users. I attempted the same here, but can't find where anything restricts the search, and there is no obvious "clear" button to remove all search filters.

So there isn't anyone in the ERP community who knows how to clear the default filter on the Sales Order query? Removing the user name in the search bar doesn't reveal all available Sales Orders, as it should.

Any help is appreciated.

Jason
on 2/20/13, 2:36 AM
3
Max
On 2/22/13, 10:39 AM

Hi,

There are a couple of things that could be causing your users to only be seeing Sales Orders assigned to themselves:

  • Make sure there are no filters in the search bar by clicking the small X on each one
  • Go to Settings > User Interface > Menu Items, find the Sales Order menu, then open it's action record. Make sure that there is nothing there that limits which sales orders are shown
  • Check the user permissions in Settings > Security > Record Rules - it may be that users that are not in the Salesperson group do not have read access...

If you need me to expand on any of the above steps, let me know in a comment

Max -

Thanks for the response. It was the third option (I knew about the first two, but not the third). The permission "Personal Order Lines" was active, and only let people see their own records. I disabled that permission and the issue was resolved.

Greatly appreciate your assistance.

Best regards, Jason

Jason
on 2/25/13, 12:07 PM

Glad its fixed! And thanks for helping to format this answer for the benefit of future readers :) All the best

Max
on 2/26/13, 4:49 AM
0
Jason
On 2/22/13, 12:28 PM

Max -

Thanks for the response. It was the third option (I knew about the first two, but not the third). The permission "Personal Order Lines" was active, and only let people see their own records. I disabled that permission and the issue was resolved.

Greatly appreciate your assistance.

Best regards, Jason

No problem, glad it is fixed! - For clarity for future readers, can you put the above text into a comment on my answer and then delete this answer? Thanks!

Max
on 2/25/13, 8:44 AM
0
Tomás Pascual
On 4/7/14, 6:55 PM

Great ¡¡¡¡

But the question is, is this a bug???

Regards,

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 2/15/13, 6:05 PM
Seen: 2602 times
Last updated: 3/16/15, 8:10 AM