Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Why am I getting a ParseError on a base.action.rule record?

Kit Sunde
on 8/24/14, 1:55 PM 792 views

I'm getting a parse error on my base.action.rule record and I don't understand why. It seems like it's well formatted XML. My whole document is this:

<?xml version="1.0" encoding="utf-8"?>
        <record id="rule_set_reminder_lead" model="base.action.rule">
            <field name="name">Trigger email scheduling when Order is set to confirm.</field>
            <field name="model_id" ref="sale.model_sale_order" />
            <field name="server_action_ids" eval="[(6,0,[ref('ir_actions_server_schedule_emails')])]" />

        <record id="ir_actions_server_schedule_emails" model="ir.actions.server">
            <field name="state">code</field>
            <field name="model_id" ref="sale.model_sale_order"/>
            <field name="code">exit()</field>

            <field name="type">ir.actions.server</field>
            <field name="condition">True</field>
            <field name="name">Schedule Emails</field>

Any idea why?

Kit Sunde
On 8/24/14, 2:12 PM

The problem was that the Automated Action Rules module wasn't installed. It's really difficult to tell these things with the current error output.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)


Asked: 8/24/14, 1:55 PM
Seen: 792 times
Last updated: 3/16/15, 8:10 AM