Odoo Help

0

Why am I getting a ParseError on a base.action.rule record?

xml
By
Kit Sunde
on 8/24/14, 1:55 PM 1,047 views

I'm getting a parse error on my base.action.rule record and I don't understand why. It seems like it's well formatted XML. My whole document is this:

<?xml version="1.0" encoding="utf-8"?>
<openerp>
    <data>
        <record id="rule_set_reminder_lead" model="base.action.rule">
            <field name="name">Trigger email scheduling when Order is set to confirm.</field>
            <field name="model_id" ref="sale.model_sale_order" />
            <field name="server_action_ids" eval="[(6,0,[ref('ir_actions_server_schedule_emails')])]" />
        </record>

        <record id="ir_actions_server_schedule_emails" model="ir.actions.server">
            <field name="state">code</field>
            <field name="model_id" ref="sale.model_sale_order"/>
            <field name="code">exit()</field>

            <field name="type">ir.actions.server</field>
            <field name="condition">True</field>
            <field name="name">Schedule Emails</field>
        </record>
    </data>
</openerp>

Any idea why?

0
Kit Sunde
On 8/24/14, 2:12 PM

The problem was that the Automated Action Rules module wasn't installed. It's really difficult to tell these things with the current error output.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)

Stats

Asked: 8/24/14, 1:55 PM
Seen: 1047 times
Last updated: 3/16/15, 8:10 AM