Odoo Help


web.base.url : automatic reset???

on 9/23/13, 4:50 PM 11,353 views


I am building a portal for customers to access some data within OpenERP. I am inviting them via an email sent out after the user creation. I noticed that the address for the server is set to the server internal IP address.

I did try to set web.base.url to the external address. If works for one email and at the next logon, the web.base.url is reset to internal IP.

How can I make sure the address on outgoing email features the FQDN?

Thanks, Phil

I've noticed when I login with 'admin', the web.base.url resets to http instead of https. So I made another user with admin right to avoid the url reset.

Openworx, Mario Gielissen | Openworx
on 9/26/14, 5:13 PM
Matt Taylor
On 9/26/14, 5:07 PM

Adding a system parameter to freeze the url works in master:

Key: web.base.url.freeze

Value: True


Seems to work on v8.0, too.

Tobias Frankl
on 9/27/14, 2:34 AM

For me too work on Odoo 8. Thanks!

Prodax Ltd., Vassil Toumbev (vassybg)
on 10/31/14, 9:02 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 9/23/13, 4:50 PM
Seen: 11353 times
Last updated: 10/28/16, 2:46 AM