Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

V9 Community, server connection error

By
Geoff Kimpton
on 6/18/16, 5:05 AM 380 views
Just installed V9 community & modules.

Am getting the following error:  could not connect to server: Connection refused (0x0000274D/10061)

	Is the server running on host "localhost" (127.0.0.1) and accepting
	TCP/IP connections on port 5432?
 
I am also running V8 online, the intention is to change to V9 community gradually as I get time.
My suspicion is that the error may be caused by a log in conflict. I have used the same email for both versions.
Both versions MAY be using the same password (unable to find original password used for V8).
If the password IS the problem ?? I need to be very cautious about changing it as all my transactions
for the past year are in V8.
I may be wrong, it could be a problem with the installation of V9?
Either way, suggestions please.

It is not possible to say anything without reasonable information. How did you install these different versions? Do you have 2 separate database instances and 2 separate Odoo instances? Did you properly specify the corresponding .conf files?

Ermin Trevisan
on 6/18/16, 7:01 AM
0

Ermin Trevisan

--Ermin Trevisan--
3548
| 6 3 7
Walchwil, Switzerland
--Ermin Trevisan--


Ermin Trevisan
On 6/18/16, 10:27 AM

I have no experience with Windows, so just an idea: did you try to update the base module?

No, Just a clean install.

Geoff Kimpton
on 6/18/16, 10:40 AM

I meant you should try to update the base module :-)

Ermin Trevisan
on 6/18/16, 1:24 PM
0
Geoff Kimpton
On 6/18/16, 8:25 AM

My V8 is online so as far as I am aware there is no database or Odoo application files on my PC for V8.

V8 online has been running for one year.

  So, yes I have two instances & two databases but one is online.  

V9 community was installed on my PC yesterday.  

I followed the link provided by Odoo:  https://www.odoo.com/fr_FR/page/community

Downloaded the windows file ( Odoo_9.c latest.exe ) ran the .exe & specified Engish language/ UK as Country.

This installed the following onto my hard disk:  PostgreSQL, Server, Service, Thirdparty and Uninstall.  But strangely, no program launch icon for Odoo anywhere ! ?

Next, I installed the modules I need.

About 3/4 way through installing the modules I got a "cannot connect" error which I assumed to be as a result of my very poor internet connection but it would still not re-establish the connection even after restarting the router.

So I used the uninstall utility, re-booted the pc & ran the Odoo exe again.  When complete, the modules I had already installed were still there !!.

Installed the remaining modules & all looked good . I opened a few of the apps including accounting & inventory just to have a look.  This morning I get an error if I open any apps including modules (apps).

Here is the full error message for apps:


Odoo Server Error
Traceback (most recent call last):
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\http.py", line 646, in _handle_exception
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\http.py", line 683, in dispatch
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\http.py", line 319, in _call_function
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\service\model.py", line 118, in wrapper
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\http.py", line 312, in checked_call
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\http.py", line 962, in __call__
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\http.py", line 512, in response_wrap
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\openerp\addons\web\controllers\main.py", line 831, in load_needaction
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\http.py", line 1066, in proxy
  File "werkzeug\local.pyc", line 338, in __getattr__
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\tools\func.py", line 22, in __get__
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\http.py", line 213, in env
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\http.py", line 250, in cr
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\modules\registry.py", line 279, in cursor
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\sql_db.py", line 630, in cursor
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\sql_db.py", line 164, in __init__
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\sql_db.py", line 513, in _locked
  File "C:\Program Files (x86)\Odoo 9.0-20160617\server\.\openerp\sql_db.py", line 581, in borrow
  File "psycopg2\__init__.pyc", line 164, in connect
OperationalError: could not connect to server: Connection refused (0x0000274D/10061)
	Is the server running on host "localhost" (::1) and accepting
	TCP/IP connections on port 5432?
could not connect to server: Connection refused (0x0000274D/10061)
	Is the server running on host "localhost" (127.0.0.1) and accepting
	TCP/IP connections on port 5432?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 6/18/16, 5:05 AM
Seen: 380 times
Last updated: 6/18/16, 10:27 AM