Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


[V8] [WORKAROUND] Pos Restaurant: doesn't send order with the selected local printer.

on 3/30/15, 8:55 PM 1,844 views

I've Installed Odoo (branch 8.0) from github, standard installation using setup instructions from the documentation. I'm testing the platform on Ubuntu 15.04 64 bit beta 1 with python 2.7.9 (but I got the same results with Ubuntu 14.10 64bit and python 2.7.8).

Fresh db (no demo)- Technical Features enabled

Server starts with no errors:

$ ./odoo.py --addons-path=addons

2015-03-27 21:26:09,177 31240 INFO ? openerp: OpenERP version 8.0

2015-03-27 21:26:09,178 31240 INFO ? openerp: addons paths: ['/home/effe/.local/share/Odoo/addons/8.0', u'/home/effe/odoo/addons', '/home/effe/odoo/openerp/addons']

2015-03-27 21:26:09,178 31240 INFO ? openerp: database hostname: localhost

2015-03-27 21:26:09,178 31240 INFO ? openerp: database port: 5432

2015-03-27 21:26:09,179 31240 INFO ? openerp: database user: effe

2015-03-27 21:26:09,379 31240 INFO ? openerp.service.server: HTTP service (werkzeug) running on

Modules installed (in this order):



Hardware Proxy

ESC/POS hardware driver

Report to printer

No other modules installed or any kind of customization.

The thermal printer is a generic USB ESC/POS (epson/samsung compatible) installed and working fine in other apps and with the report to printer module after identify it on Odoo.

In the POS settings the Print via Proxy was enable and the address was set to 'locahost'. The result is the message "printer offline" but at least I don't have the tedious Chrome printing window.

Errors on log:

2015-03-27 21:13:59,580 26002 WARNING ? openerp.addons.hw_escpos.controllers.main: ESC/POS Device Disconnected: Printer Not Found

Due to some kind of polling the error is very frequent (obviously).

I have created an Order Printer and is enabled on the POS setting page. I tried with 'localhost' and with the path provided by CUPS (usb://). I fear it need a precise syntax for the address but I didn't see errors on log. But when I press the 'order' or 'bill' button nothing happens.

Message in log:

2015-03-27 21:46:09,716 31240 INFO db1_test openerp.addons.hw_escpos.controllers.main: ESC/POS: PRINT XML RECEIPT

2015-03-27 21:46:09,717 31240 INFO db1_test werkzeug: - - [27/Mar/2015 21:46:09] "POST /hw_proxy/print_xml_receipt HTTP/1.1" 200 -

2015-03-27 21:46:10,794 31240 INFO ? openerp.addons.hw_escpos.controllers.main: disconnected : Printer Not Found

Using the 'reprint' button on a selected order works even if not at the best quality. 

Even adding the printer vendor id on ~/odoo/addons/hw_escpos/escpos/supported_devices.py the result is still the same:

{ 'vendor' : 0x0416, 'product' : 0x5011, 'name' : 'Generic USB' },

Starting the server I can see on log:

2015-03-30 22:13:49,567 1773 INFO ? openerp.addons.hw_escpos.controllers.main: connected : Connected to Generic USB

But then a huge amount of errors is shown and the printer is still not working.

Since we are talking about a working system printer should be possible to have it configured on Odoo. But how?

I've opened an issue on github too: https://github.com/odoo/odoo/issues/6026



On 4/22/15, 3:33 PM

I've found a solution, even with some limitations. Have a look here:


Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 3/30/15, 8:55 PM
Seen: 1844 times
Last updated: 5/20/15, 9:18 AM