Odoo Help

0

[v8]Not able to debug openerp properly because a terminal command keeps coming up in between the pdb debugging session

By
banky
on 10/27/15, 6:20 PM 660 views

I have put a

pdb.set_trace() at a point in my python function during Odoo development and Odoo keeps interrupting me with this message:

2015-10-27 22:13:18,404 7786 INFO db_test werkzeug: 127.0.0.1 - - [27/Oct/2015 22:13:18] "POST /longpolling/poll HTTP/1.1" 200 -



GREAT question title. I knew, because this happened to me, instantly how to help you without even needing to open your question.

Bista Solutions US, Ray Carnes
on 10/27/15, 7:06 PM
1
Andre de Kock
On 1/29/16, 5:42 AM

You could start your Odoo server with the parameter --no-xmlrpc. This will cause long-polling workers to not start and thus not log.

Example: ./odoo.py --no-xmlrpc

Documentation: \https://www.odoo.com/documentation/8.0/reference/cmdline.html

0
Ray Carnes
On 10/27/15, 7:05 PM

Set WERKZEUG logging to a different level than INFO.

log_handler = werkzeug:CRITICAL
0
Julio Serna
On 10/28/15, 3:20 PM

I solve this starting server with --logfile=log.log


e.g.

./odoo.py -c YOUR_CONFIG_FILE --logfile=log.log

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 10/27/15, 6:20 PM
Seen: 660 times
Last updated: 1/29/16, 5:42 AM