Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

V8 - Bug with the Hour(s) unit of measure?

By
Luis Alberto Panozzo
on 8/27/14, 7:23 AM 2,016 views

I am using Odoo V8 with Odoo-provided test data.
Software updated from GitHub early today (27-8-14)

Just to test the Import/Export facility I have exported Product Data (all 40 products).
I generated two files actually. One using the Import-Compatible Export option and another with the Export All Data.
One field that was there was the Unit of Measure.

I then tried to import the data back into the system.
Regardless of whether the unit of measure id (uom_id) is
product.product_uom_hour or 
Hour(s)

I always get the same message.

Unknown error during import: <class 'openerp.exceptions.ValidationError'>: ('ValidateError', u'Field(s) `uom_id` failed against a constraint: Error: The default Unit of Measure and the purchase Unit of Measure must be in the same category.') at row 2

Clearly I went into the problematic products and checked that the units are not only of the same category but they are the EXACT same unit: Hour(s).

Obviously the error comes up with the Services.

If we are talking product.product_uom_unit or Unit(s) there is no such a problem.

2
Patrick van Gool
On 8/30/14, 2:36 PM

I have the exact same experience with importing a data set with a custom unit of measure: bottles from within the volume category. Even when I deleted all products I got the exact same error. 

My guess some comstraint defaults to units. I could not find a 'normal' setting to change the default unit of measure.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/27/14, 7:23 AM
Seen: 2016 times
Last updated: 3/16/15, 8:10 AM