Odoo Help


v7 google api configuration, why do I get XmlHttpRequestError ?

Christian Eichert
on 2/2/14, 10:58 AM 1,310 views
The configuration of the Google API is not documented.
Account : [ 7077467779379@developer.gserviceaccount.com ]
Auto synchronize : [ x ]
Use local browser : [ x ]
Secrets path : [  ] << prefigured,  but where is this file ?
Credential path : [ credentials.dat ]  << prefigured,  but where is this file ?

(My karma is insufficient to post a link or a file.. :)) ) So please visit dl.dropboxusercontent.com/u/82752112/google_api.JPG to see what I mean.

but when I hit : "Authorize" I get     XmlHttpRequestError 

And its not fair ;)
On 7/11/14, 2:49 AM

Hello Christian Eichert,

By default openerp set the field "secrets path" with value as a "client_secrets.json". But there was no file, we need to provide file name with path where JSON file located.

You can create and download json file from "console.developers.google.com". First create a new project and go to the “APIS & AUTH/ APIs” section. Enable “calendar API”.

Now go to the “Credentials” just below the APIs section of your project and click on “Download JSON" and save this file on a location where your Odoo/OpenERP system has access to it. 

In “Secrets path” enter the full path of downloaded json file/ (example: /home/openerp/google_calendar/client_secrets.json).

Enter path for “Credential path” field. When we authorize, google_api will create the credential file and fill data. (example: /home/openerp/google_calendar/credentials.dat). File should have read and write access.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)


Asked: 2/2/14, 10:58 AM
Seen: 1310 times
Last updated: 3/16/15, 8:10 AM