Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

'utf8' codec can't decode byte error when importing a list of products as a CSV file

By
Marco
on 12/30/13, 12:24 PM 17,179 views

'utf8' codec can't decode byte 0xb0 in position 16: invalid start byte

I have about 13k products that I need to get into OpenERP, so I tried exporting an example and then filling the fields with the information regarding all the other products but when I try importing it back it gives me the error on the first line.

Where is pòsition 16 and what exactly is causing this?

UPDATE: As Grover Menacho said, I did have "°" in my info, I erased those and now the error is as follows.

'utf8' codec can't decode byte 0xc7 in position 3: invalid continuation byte

Copy your csv sheet to an Open Office spreadsheet and save as ods file and then save as csv form the ods format if you are using MS Excel. Excel does not format csv properly most times.

kaynis
on 12/31/13, 6:55 AM

That did not work, it keeps giving me the error: .'utf8' codec can't decode byte 0xc7 in position 3: invalid continuation byte

Marco
on 1/2/14, 2:42 PM
3
Eric
On 1/2/14, 2:51 PM

I also had this problem once. When you choose your csv file to import, then select the "latin-1" encoding option from the Encoding drop down menu rather than the "utf-8". The "latin-1" option accepts the different symbols like the " ° " and this way I didnt have to modify the csv file at all.

I do not have this drop down menu, do you know if I have to activate it somewhere and if so, where exactly?

Marco
on 1/2/14, 3:06 PM

No need to activate. After you browse to and select the CSV file, an option appears below that says "File Format Options..." You can expand that to select encoding.

Rich Granata
on 1/2/14, 3:31 PM

I found it, it worked now and imported all 12k products without a hitch, thank you.

Marco
on 1/6/14, 2:30 PM
2

Grover Menacho

--Grover Menacho--
2523
| 5 7 8
La Paz, Bolivia
--Grover Menacho--

Systems Engineer + MBA

Grover Menacho
On 12/30/13, 5:37 PM

You have a degree symbol or crossed d "°" or "ð" Check this and import it again.

Thank you, it did have the "°" symbol.

Marco
on 1/2/14, 1:51 PM
1
Wayne Nelson
On 5/20/14, 12:47 PM

This works on Macs and Windows versions of Excel:

In Excel, Save As..   and select format as Windows Comma Separated (.csv)

When importing into OpenERP change the + File Format Options ecoding from utf-8 to windows-1252.  

 

0
Mariusz Mizgier
On 12/30/13, 1:41 PM

Did you save your csv with utf-8 coding? Remember that editing with Excel does not always work this way (usually the best choice is to use OpenOffice to be sure that coding is right). Otherwise, if you did, could you post a line with a product, which could not be imported?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 12/30/13, 12:24 PM
Seen: 17179 times
Last updated: 3/16/15, 8:10 AM