Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

user without having product field.

By
charlesraj
on 5/6/13, 2:43 AM 881 views

hi. I create a user he has the right to make order for sale and saving it (not to confirm) .But there is no field to add products other fields like decrption,qty, unit price etc.Are found. please help to find out how to add the field..

1

Priyesh Solanki (pso)

--Priyesh Solanki (pso)--
Tiny ERP Pvt Ltd
http://www.odoo.com
1100
| 2 2 4
--Priyesh Solanki (pso)--
Priyesh Solanki (pso)
On 5/6/13, 3:06 AM

You need to assign "Employee" group to your current logged user for that. Go to your User record, Open it, In Access Rights tab, Assign Employee from Human Resources application.

Thanks, Priyesh Solanki

thanks for the reply.. sir first i say sorry to make a mistake . i create a CUSTOMER NOT USER.

charlesraj
on 5/6/13, 3:12 AM

Are you logged in as a Admin or by another user ?

Priyesh Solanki (pso)
on 5/6/13, 3:17 AM

logged in as another user.

charlesraj
on 5/6/13, 3:24 AM

Then follow my first answer. Product field is restricted for Employee group so you need to check that whether your logged user has this group assigned or not. For that, Go to your User record, Open it, In Access Rights tab, Assign Employee from Human Resources application. Save it. Reload it. It should work.

Priyesh Solanki (pso)
on 5/6/13, 3:32 AM

Hi Priyesh Solanki, I also need the same requirement.

Remya
on 5/6/13, 3:33 AM

Reqiurement::: I have create a customer only have to make orders, through customer portal. I dont where is my mistake. I cant correctly configure the portal system. Please help me to configure it.

Remya
on 5/6/13, 3:35 AM

What do you want to do ? Do you not want Portal user to confirm the Sale order or anything else ? Please explain more!

Priyesh Solanki (pso)
on 5/6/13, 4:14 AM

I have some customers. Through portal system, i gave username&password to all customer. Customer only has the privilege to make order, not to confirm sale. But in my configuration they has the privilege to confirm sale. Then i remove customers from 'HR/Employee' group. Then i tried to create a sale order as customer login. I cant see the product list in sale order line. How can i neatly configure the customer portal(only have the access to make order & can see only name of the products)

Remya
on 5/6/13, 4:29 AM

Oh yes, I got it. If you will not assign Employee group, it will not allow user to confirm sale but it also disappears Product from order line. I confirm it, but for that, you need to make some customization by adding a new group that will not allow you to confirm sale and you need to assign that group to your current logged user. Also, you need to add that group in sale_view.xml by replacing existing one.

Priyesh Solanki (pso)
on 5/6/13, 6:42 AM

Ok. First i should create a group? Which group should i duplicate?

Remya
on 5/6/13, 6:47 AM

You need to create a group by code because If you will create from GUI, you won't be able to assign it on button/field from GUI. Are you aware about OpenERP Technical ?

Priyesh Solanki (pso)
on 5/6/13, 6:52 AM

No Priyesh. I'm not at all confidence. Can you please help me?

Remya
on 5/6/13, 6:57 AM

Then what i can suggest you is that, Instead of creating a new one, Use existing ones. Right now, on Confirm Sale button and Product, they both are restricted with one group Employee. You can separate them by assigning different group and accordingly it, You need to add it in Logger user.

Priyesh Solanki (pso)
on 5/6/13, 7:01 AM

How can i separate it? Do you mean the new one & existing one are groups?

Remya
on 5/6/13, 7:04 AM

Go to the Settings --> Technical --> User Interface --> Views. Search for sale.order.form and open the first record. View is too long but if you can search <field name="product_id" .... , here you need to assign another group like this:

replace the existing groups="base.group_user" with "groups="sale.group_discount_per_so_line" It means that Product is restricted for "Discount on Lines" group. Save this view. Now, for Confirm Sale --> Employee group and for Product --> Discount on Lines group is required. Tick it accordingly and Add to your Logged user. Hope this will help you.

Priyesh Solanki (pso)
on 5/6/13, 7:09 AM

1st part is clear. Next, Confirm sale, where can i find this?

Remya
on 5/6/13, 7:16 AM

Did you replace the old group "group_user" with new one "sale.group_discount_per_so_line" from the sale.order.form view ?

Priyesh Solanki (pso)
on 5/6/13, 7:18 AM

I just replace groups="base.group_user" with "groups="sale.group_discount_per_so_line" in sale.order.line. Then,what is the next step?

Remya
on 5/6/13, 7:19 AM

Thats it. What we did is To not allow user to Confirm Sale, We will not tick Employee group but To see the product, We have to tick Discount on lines group in Logged user form.

Priyesh Solanki (pso)
on 5/6/13, 7:25 AM

I'm really sorry Priyesh, i did get you. Where should i tick?

Remya
on 5/6/13, 7:30 AM

Go to the Settings --> Users --> Users. Open your logged user. Go to the Access Rights tab and first tick 'Technical Features'. Save it. Reload it. Again Open the same record from Users form. Again, Go to Access Rights tab and you will see all the groups over there. You will find Employee group in Human Resource application and Discount on Lines group in Technical Settings separator. Do not select Employee from Human Resources application and Tick that boolean 'Discount on Lines'. Save it and Reload it. Try again your scenario. You will not find Confirm sale button but you will find Product.

Priyesh Solanki (pso)
on 5/6/13, 7:37 AM

Did you mean---Settings-->user-->customer name-->tick the Discount on lines? i tick that one. But no product is not displaying

Remya
on 5/6/13, 7:38 AM

There is nothing to do with Customer name. In Users, you will find all users record by which you are going to do Login. What is your User Name ? User has to do with Access rights whatever we are assigning to him.

Priyesh Solanki (pso)
on 5/6/13, 7:40 AM

Ok. After that , i cant see any buttons in sale order of customer login

Remya
on 5/6/13, 8:35 AM

Can you see Product in order line ?

Priyesh Solanki (pso)
on 5/6/13, 9:08 AM

No product & no buttons

Remya
on 5/6/13, 9:12 AM

Now button is present but cant see the list of products.

Remya
on 5/7/13, 1:44 AM

can you post your user name and which groups are assigned to him ? So we can check it out!

Priyesh Solanki (pso)
on 5/7/13, 3:39 AM

I will explain it::: I have create a customer named ram. Select technical feature in access tab. Check the portal checkbox. Follow your answer ie, change the user group in sale.order.line and check discount on line. Now i can see the create button, but cant see the product list in sale.order.line

Remya
on 5/7/13, 3:47 AM

Ok i got it. You need to make one more change. Go to the Settings --> Technical --> User Interface --> Views. Search for sale.order.form and open the first record. View is too long but if you can search <field name="product_id" .... , you will find this product_id two times in this view. here you need to assign another group like this:

replace the existing groups="base.group_user" with "groups="sale.group_discount_per_so_line" at both place. Before this, it was just assigned at once that's why it was missing but now, if you will search for product_id, you will get twice in that view.

Priyesh Solanki (pso)
on 5/7/13, 3:55 AM

So change the groups with new one "sale.group_discount_per_so_line", save it , reload it. Now, again login with the new user and check, You will be able to see products in list of Sale order line.

Priyesh Solanki (pso)
on 5/7/13, 3:56 AM

Now product dropdownlist is showing, but cant select any product because of the access rights

Remya
on 5/7/13, 4:03 AM

Yes its due to lack of access rights. Portal group can only read sale order/sale order line that's why you can't do anything with it. In fact, in OpenERP, Portal group is used to just view your own documents.

Priyesh Solanki (pso)
on 5/7/13, 4:09 AM

But i want to give customer to create their own sale order. What will i do?

Remya
on 5/7/13, 4:11 AM

For that, You need to give create/delete/write access rights to your Portal group for sale.order/sale.order.line and many more related objects from Settings --> Technical --> Security --> Access control list menu.

Priyesh Solanki (pso)
on 5/7/13, 4:19 AM

I gave access sale order access to portal group, but still it shows access error.

Remya
on 5/7/13, 4:32 AM

Possible because Portal group has very limited rights and If you will tick another groups then you will again see that Confirm sale button that you do not want. You have to make many changes regarding access rights for this.

Priyesh Solanki (pso)
on 5/7/13, 4:35 AM

ok. But i tried to integrate many access rights to portal group.

Remya
on 5/7/13, 4:43 AM

Hmm! Which access error, you are getting ?

Priyesh Solanki (pso)
on 5/7/13, 4:44 AM

Access denied. The requested operation cannot be completed due to security restrictions. Please contact your system administrator. (Document type:Product, Operation:read)

Remya
on 5/7/13, 4:50 AM

I get an another idea! First revert all the changes regarding group assigning and view editing. It means we came back to your original issue. You can interchange rights between Confirm Sale and Product means for now, Discount on Lines for Product and Employee for Confirm Sale. But As you are facing such many issues regarding access rights, I will suggest you to interchange rights means To see the Product, you need go with Sales -> See own leads group and to hide confirm sale, you need to assign "Discount on lines" group.

Priyesh Solanki (pso)
on 5/7/13, 5:11 AM

After reverting all the changes, first go to Settings --> Users --> Groups and Open Employee group. In Inherited Tab, Remove Discount On Lines group and save it. Again go to Views form of sale.order.form and keep the product_id groups same as before, change the groups of buttons from header section, at top of view and assign groups="sale.group_discount_per_so_line" on the buttons, that you do not want to show to the users like confirm sale, send by email, print, etc.

Priyesh Solanki (pso)
on 5/7/13, 5:16 AM

After assigning groups to the view, save it. Go to the Users form and Open logged user record, Tick the See own leads from Sales application , Portal, Technical Features group and save it. Reload it and again login with the user and check your scenario. It should work.

Priyesh Solanki (pso)
on 5/7/13, 5:19 AM

That works. But when i tick See own leads, customer become employee. Is this a right configuration?Will it work correctly?

Remya
on 5/7/13, 7:23 AM

Customer become employee ? How ?

Priyesh Solanki (pso)
on 5/7/13, 7:26 AM

When i tick See own leads, customer become employee.

Remya
on 5/7/13, 7:28 AM

No, it should not. There is nothing to do with Employee for See own Leads group!

Priyesh Solanki (pso)
on 5/7/13, 7:30 AM

Shall i follow this step?

Remya
on 5/7/13, 7:37 AM

By assigning See Own Leads group, Some more menus and rights will be assigned but it should not create any issue. If its working fine at your end with these steps, you can follow it.

Priyesh Solanki (pso)
on 5/7/13, 7:40 AM

Ok Thanks for your speedy reply. Please help if any error

Remya
on 5/7/13, 7:44 AM

Good luck! Enjoy!

Priyesh Solanki (pso)
on 5/7/13, 7:45 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 5/6/13, 2:43 AM
Seen: 881 times
Last updated: 3/16/15, 8:10 AM