Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

User edits being saved, but not being shown. Database shows correct value. Only deleting and importing fixes this! ??

By
Ray Carnes
on 10/27/14, 12:44 PM 603 views

I've now seen this on two different databases in the past month.

A user edits a record in a form view and changes the value of a simple char field.  

On saving, the field reverts to the 'old' value.  The database stores the 'new' value.  An export of the record produces a CSV with the 'new' value.  Still, the UI shows the 'old' value.  Restarting and refreshing the browser don't change this.

If I delete the record and import the CSV that was just exported, then the UI and the database are back in sync.

Has anyone else seen this and knows what is going on?

I've checked that there is no default value for the field, and no on_change event in the view definition, or any views that inherit.

Bista Solutions US, Ray Carnes
on 10/27/14, 12:44 PM

What build are you running?

Kelly Stuart
on 11/21/14, 4:36 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 10/27/14, 12:44 PM
Seen: 603 times
Last updated: 3/16/15, 8:10 AM