Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

"Update modules list" not finding newly added modules. What else can I try?

By
Michael Scorpio
on 8/12/15, 1:51 PM 2,781 views

I've got a fresh install of Odoo V8 on Ubuntu 14.04. I've followed the instructions for installing the Odoo-Magento Connector (http://odoo-magento-connector.com/guides/installation_guide.html), but I can't get Odoo to see the modules. I've placed the modules in the custom addons folder as specified in the config file. I've made Odoo the owner of the folders and files. I've tried adding the full path to each of the 6 folders containing the modules for the connector.to the addons section of the config file. I've done "Update Modules list". I've tried adding and removing the trailing "/" to the paths in the config file. I've tried specifying the addons paths at startup.  Nothing works.

To confuse things even further, I've tried removing all the addons paths from the config file, restarting the service, doing an "Update Modules List", and somehow it still finds local modules (all except the ones I want to add). How on Earth can it find local modules if you've removed the path from the config?

I'm completely out of things to try. Any ideas?

i really have tried absolutely everything and Odoo just refuses to recognise the modules. I'm on my 6th clean build and still nothing. Are there some rules published somewhere as to what is required of a module before it will be found by Odoo? Is anyone actually using the Odoo-Magento Connector? If so, how? given that the install process doesn't work.

Michael Scorpio
on 8/17/15, 10:20 AM
1
Marvin Taboada
On 8/12/15, 11:23 PM

Michael, menu entries under "Settings > Modules" are somehow misleading IMHO.

There are these two entries "Apps" and "Installed Modules" that allow us to install modules but the first one "Apps" looks for modules at remote repositories only.

If you require to install modules from your local addons directories (those configured either in a configuration file or from the command-line), choose the "Installed Modules" menu entry and then remove the [Installed] filter that is selected by default at the search bar, then you can search again and I expect that all your locally available addons will be displayed in the search results.

Do not add the paths to the addons themselves, add the path to their parent directory.

0
Michael Scorpio
On 8/15/15, 12:55 PM

Thanks for all the responses. I can confirm that I'm only looking for my modules under local modules and I have removed the default filter. I am doing an update modules list. I am doing a restart of the odoo service after each attempt at modifying the config. The addons path where I've done my git clone is the same path in the config. I've given the Odoo user ownership and execute over the files and folders (recursively).

I have been able to get a module to show up by moving it from the subfolder it's in to the addons path. This prompts the question; does Odoo not recursively scan folders when doing an update modules list? I'm trying to install the odoo-magento connector and it consists of 6 repositories with multiple subfolders. I just can't see how anyone has ever been able to get this to work by following the install instructions. There must be something missing here.

0
Dr Obx
On 8/13/15, 9:58 AM

To solve similar problem I just created a link to the addons folder (in my case it was: ls /usr/lib/python2.7/dist-packages/openerp/addons /addons ) so now i have a direct access into the addons folder in / (root folder - working on server not connected to the internet so it doesn't matter).

All my modules placing directly into this folder and never had a problem with.

==============================================================================


"Check access rights to the /opt/odoo/addons

Your module to be visible should be placed in addons:

folder: your_module

(inside this folder you should have) __init__.py, __openerp__.py, your_module.py, your_module_view.xml

at least first three files in order to make your module visible :)

So:

1. Users/Settings technical features 'ticked'

Update Modules List - should appear in left side menu

2. Check if in __openerp__.py

'application': True, - OK

if 'application': False  remove 'Apps' filter in search field (top right corner).

Check your Custom Module path

put module into /usr/lib/python2.7/dist-packages/openerp/addons

if your custom addons path is incorrect Odoo will not see your module in this location....."

0
HappyOdoo
On 8/13/15, 9:08 AM

Hi Michael Scorpio,

as my experience. If you downloaded modulename.tar.gz. then first check how many folders in that .tar.gz.

if two or more directories.

first you extract that .tar.gz . then goto extract folder. then copy all directories from extract folder and goto to back addon directory where modules listed and past that copied directory.

now update module list and search downloaded file word.

it will work.

0
Pete
On 8/13/15, 8:13 AM

Michael,

On your second point, there was a forum question (https://www.odoo.com/forum/help-1/question/what-are-the-steps-to-update-a-custom-module-55419) that I found helpful for learning some of this background about modules.  As I understand it, the modules listed in Local Modules (once the "Apps" filter is off) have actually been (partially) loaded into the database from the addons directory (happens when you Update Modules List). So even once you remove the addons directory (or remove the module from the addons directory) it will still be in the list, until you Delete the module (select the module from the Local Modules list, Detele is in the More dropdown).

As for the first part, nothing in that sounds wrong. I can give do what I've wished other answers did, and tell you the step-by-step I worked out -- I've only learned this recently, so there may be things you and I don't get that everyone else is taking for granted -- and see if that helps you?

In openerp-server.conf I've set "addons_path = /opt/odoo/addons" (and set read and write permissions to that folder and all subfolders for all users -- not great, I know, but it ensures that access rights aren't the problem, and you can set it back to something sensible once you've established that.)

My example modules goes in it's own subdirectory there (e.g. the module's base file is in: /opt/odoo/addons/Module-Name/__init__.py)

Next I restart the odoo service, then when I'm back in, I click "Update Modules List."  Finally, as Marvin said, I find my custom module in the "Local Modules" list, once the "Apps" filter is turned off.

I can't promise this is the best way to do it, but it works and that's a start.

Good luck!

0
Julian Robbins
On 8/12/15, 7:28 PM

Perhaps would be useful if you can indicate briefly how you installed Odoo, as you appear to be doing all the right things .. Are you certain you have the correct addons path ?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/12/15, 1:51 PM
Seen: 2781 times
Last updated: 8/17/15, 10:20 AM