Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Unicode decode error after installation of Odoo V8

Peter Tomolik
on 12/19/14, 2:26 AM 2,039 views

Hi all,

I am chewing quite some time now on this prob and couldn't find a solution (despite having found many threads containing unicode decode errors):

On my machine I had an OpenErp V7 installation, but deinstalled this now (I am at the beginning of the implementation of the ERP System) in favor to V8.

Unfortunately the installation of the latest build will not run. Trying to start up the server I get this error:

C:\Program Files (x86)\Odoo 8.0-20141218\server>openerp-server.exe
Traceback (most recent call last):
  File "openerp-server", line 2, in <module>
  File "C:\Program Files (x86)\Odoo 8.0-20141218\server\.\openerp\__init__.py",
line 78, in <module>
    import service
  File "C:\Program Files (x86)\Odoo 8.0-20141218\server\.\openerp\service\__init
__.py", line 27, in <module>
    import wsgi_server
  File "C:\Program Files (x86)\Odoo 8.0-20141218\server\.\openerp\service\wsgi_s
erver.py", line 46, in <module>
    import websrv_lib
  File "C:\Program Files (x86)\Odoo 8.0-20141218\server\.\openerp\service\websrv
_lib.py", line 37, in <module>
    from SimpleHTTPServer import SimpleHTTPRequestHandler
  File "SimpleHTTPServer.pyc", line 27, in <module>

  File "SimpleHTTPServer.pyc", line 208, in SimpleHTTPRequestHandler

  File "mimetypes.pyc", line 358, in init

  File "mimetypes.pyc", line 258, in read_windows_registry
    --extension / -e  -- guess extension instead of type
  File "mimetypes.pyc", line 249, in enum_types

UnicodeDecodeError: 'ascii' codec can't decode byte 0xae in position 7: ordinal
not in range(128)


Trying to run odoo on win server 2008 (x64) with the latest build from 18.12. with postgresql 9.3

I already tried reinstalling odoo, postgresql and adding unidecode 0.04.17 from python.org to the server directory. still, I can not get this solved (though I had this problem before during my tests and adding a new, empty postgre-db solved it, but this does not work this time).

Any ideas on this? I am quite lost at the moment.

Gautier Decaen
On 2/9/15, 3:10 PM


could you give some more details:

  • Where can I find the file mymetypes.pyc to be remplace?
  • I don't have Python installed, where I can find the old file as you told in your comment?

Thx in advance,


Samo Potokar
On 2/6/15, 6:02 AM

Solved the problem here deleting the mymetypes.pyc provided with the installation (probably from an old version of python) and copying the file from the previously installed python libraries (I have 2.7.9 on my machine, win7 64bit). If needed ask for more detailed explanations.

On 1/20/15, 7:38 AM

Same problem here too, but different system: WinXP SP3 (On Win7: Everything works).
Decode byte error 0xd6 (code table character: Ö - source: http://lwp.interglacial.com/appf_01.htm).

I would like to solve this problem, but I am really noob for this.

Which file needs correction (mimeypes.pyc? but is this not an output file from an py?) Or.. I need to edit/remove a windows registry key (I've seen in other site)?

Thanks for any help you can provide.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)


Asked: 12/19/14, 2:26 AM
Seen: 2039 times
Last updated: 3/16/15, 8:10 AM