Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Uncaught TypeError: Cannot read property 'prototype' of null

By
don teal
on 3/6/14, 4:35 PM 2,374 views

something has happened to the OpenERP installation I have.

When i log in to OpenERP I get the following message

Uncaught TypeError: Cannot read property 'prototype' of null

After I clear the message the side menu and top menu show up but nothing in the main section of the window appears.

I can click on the different menu options but nothing changes.

I am running OpenERP 7.0 on a windows 2008 server.

Thanks

0

Martin

--Martin--
1978
| 5 6 8
Cornwall, Canada
--Martin--

Analysing, designing, coding and mentoring since 1975. Kilobytes to terabytes. Punch cards to punchy sites. My OpenERP video series: http://www.youtube.com/playlist?list=PLq7op4J183lX44ZlXPiHxUpRvmmRDtxye My Google Speadsheets --> OpenERP Data Pump project: http://martinhbramwell.github.io/GData_OpenERP_Data_Pump My email (with spaces removed) : mhb . warehouseman @ gmail . com

Martin
On 3/6/14, 7:30 PM

I hope I am right in assuming that it is not a production server.

If you are learning, I recommend you install Windows 2008 in a virtual machine -- under Virtual Box, VmWare or whatever your preference.

It is pointless to try to debug install errors.

When you work with virtual machines you can make a backup, try some changes, make another backup, try some more changes, etc.

You can experiment, worry free, with various installation options until you find what works for you -- then back it up. You are bound to screw up. Knowing you have a library of fully working server copies available is very comforting.

Also, I found the fear of having to reload all my test data by hand to be a real inhibitor to experimentation, so I created a data pump to automate that.

It setup as an evaluation server to run in parallel to our actual inventory system. So we can evaluate if OpenERP is a good fit for our needs. But this issue didn't occur as part of an installation but has been running since Dec '13. When the issue occurred I tried to restore a dump I did and it still occurs. I can go back 2 months and restore a dump and that works but then the data from then till now is missing. I even tried a clean install of OpenERP and restore the dump and it still didnt work.

don teal
on 3/7/14, 12:33 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 3/6/14, 4:35 PM
Seen: 2374 times
Last updated: 3/16/15, 8:10 AM