Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Unable to install module

By
Djordje Marjanovic
on 4/18/15, 3:50 AM 616 views

I am trying to install OCA/Comptocamp's Analytic Timesheet In Task (timesheet_task) module, but I keep getting this error:

File "/opt/odoo/odoo-server/addons/timesheet_task/__init__.py", line 21, in <module>
from . import project_task
ImportError: cannot import name project_task

File project_task.py is present and file permissions seem to be OK. I've also tried to replace '.' with 'openerp' in __init__.py, but it has no effect. I have no problems installing other modules.

Any ideas?

1
Dr Obx
On 4/18/15, 6:59 AM

Have you tried place this module in /usr/lib/python2.7/dist-packages/openerp/addons/ ?

Maybe you have some issues with addon path .... :)

and check spelling :)

A hahaha

right, your bad :)

from . import  should be in module file not in __init__.py :)

in __init__.py only import module_name


0
Djordje Marjanovic
On 4/18/15, 7:26 AM

Edited __init__.py, instead of 'from . import project_task' changed it to 'import project_task' and module finally installed.

Issue resolved.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 4/18/15, 3:50 AM
Seen: 616 times
Last updated: 4/18/15, 1:18 PM