Odoo Help

2

Time zone issue

By
Bharathi
on 2/7/13, 6:43 AM 2,417 views

In Windows environment, in employee attendance list view sign in and sign out timings are +5:30 hrs ahead than our local timing. How to set it to our local timings.

6

Olivier Dony (odo)

--Olivier Dony (odo)--
2142
| 7 6 7
--Olivier Dony (odo)--

 

Olivier Dony (odo)
On 2/7/13, 7:58 AM

There's a known issue with timezones on Windows machines. After making sure that all users have set the appropriate timezone value in their user preferences (and that it matches the OS/browser timezone), you should try the solution proposed on bug 1038017. Mainly it involves:

  1. Applying this registry patch
  2. Rebooting
2

Hilar

--Hilar--
1742
| 5 3 8
Rome, India
--Hilar--
  Blog:-
        https://hilarlive.wordpress.com/
  StackOverflow:
        http://stackoverflow.com/users/7561347/burmese-pythis

For Online Chat and Doubts :-
      http://chat.stackoverflow.com/rooms/139324/odoo

Hilar
On 10/31/16, 8:06 AM

In PsQl db the time will saved as UTC, you have to convert the data whenever you are fetching for any purpose using time objects like strptime or strftime.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 2/7/13, 6:43 AM
Seen: 2417 times
Last updated: 10/31/16, 8:06 AM