Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

The default S/O template is mentioning VTA instead of VAT.

By
Martin T
on 1/16/14, 11:34 AM 1,033 views

The default S/O template is mentioning VTA instead of VAT.

When I open this S/O template report in the report designer I noticed that the 'VTA' is just text. So I changed this to 'VAT'.

VTA : [[ (o.partner_id.vat) or removeParentNode('para') ]] changed to

VAT:[[ (o.partner_id.vat) or removeParentNode('para') ]]

For English customers this is perfect, but for my dutch customers it isn't, because now the translation doesn't work. The VAT term should be translated to 'BTW' but it doesn't, the translation only works when I use the term 'VTA' in the template.

Where can I find the translation settings for this in Openerp?

Any hints or help would highly appreciated,

0
Martin T
On 1/16/14, 12:39 PM

After a lot of troubleshooting I did the following,

I deleted the whole VTA line from the Sales Order template and replaced it with:

[[ (o.partner_id.lang=='nl_NL')and 'BTW: ' or 'VAT: ' ]] [[ (o.partner_id.vat) ]]

At least this is working as i'm expecting it to work. Make sure you have all the spaces in place.

If anybody knows how to make it better/robust, then please let me know.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 1/16/14, 11:34 AM
Seen: 1033 times
Last updated: 3/16/15, 8:10 AM