Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

TCP Port 8069 is already in use

By
Anthony Tripley
on 11/11/16, 11:01 AM 163 views

I'm trying to load odoo V9.0 (from github using homebrew) onto my MacBook Pro running Sierra 10.12.1 using guidance from a Youtube video https://youtu.be/RRmmpWt5Nvg

When I install the program it seems to install then I get the message:

File "/usr/local/Cellar/python/2.7.12_2/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 228, in meth return getattr(self._sock,name)(*args)

error: [Errno 48] Address already in use

When I open Safari and type in 127.0.0.1:8069 I get a message saying:

"Safari can't open page 127.0.0.1:8069 because the server unexpectedly dropped the connection."

Does anyone have a fix?

I followed yours and the github instructions to change the openerp-server.conf file but it made no difference.

I should point out this is the third time I've tried to install using the procedure outlined in the video.

Should I uninstall / delete everything and start again with a clean slate?

If so, what's the best way to go about that?

Anthony Tripley
on 11/11/16, 11:34 AM

The video seems straightforward to me, so there is a chance, that you already have an Odoo instance running while trying to install a new one. I would restart again with a clean install.

Ermin Trevisan
on 11/12/16, 2:16 AM

Odoo doesn't appear in my Applications folder or in the applications directory in Mackeeper.

What would be the best way to remove all instances of the program so I can do a clean install?

Anthony Tripley
on 11/12/16, 3:00 AM

You should check your virtual environment "odoo-env", if you followed the video. But I'm not firm with Odoo on Macs.

Ermin Trevisan
on 11/12/16, 4:04 AM
1

Ermin Trevisan

--Ermin Trevisan--
3524
| 6 3 7
Walchwil, Switzerland
--Ermin Trevisan--


Ermin Trevisan
On 11/11/16, 11:09 AM

Check what is already using port 8069, if it is legit, change the Odoo port to something else in the openerp-server.conf file (usually located at /etc/odoo directory) by changing the xmlrpc_port parameter. See here for details: https://github.com/odoo/odoo/issues/8322

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 11/11/16, 11:01 AM
Seen: 163 times
Last updated: 11/12/16, 4:00 AM