Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

"switch to calendar view" button missing

By
Tommy
on 6/11/13, 10:50 AM 1,374 views

Hi guys, when I tried to design my modules through the web form operation. (add model,and views) In openErp7,views can be only added by the "copy" function.One can never add any views through the "views management" menu(which I guess is a bug of version 7.0-20130308-002138)

And it turned out that both tree view and form view can be added this way while the calendar view won't work. I can't figure out where the problem lies.

model fields x_startDate(date) x_endDate(date) x_title(char) x_content(char) x_user(many2one)

calendar view xml: <calendar string="Scheduled Actions" date_start="x_startDate" color="x_user"> <field name="x_title"/> <field name="x_content"/> </calendar>

everything seems ok except that the button for switching to the calender view does not show up.

could anybody help me ?

Have you tried entering Developper's mode (Upper right corner: About OpenERP --> Activate Developper's mode) and taking a look at the views through "Manage Views"?

Rebel
on 6/11/13, 11:11 AM
3

Sandeep

--Sandeep--
6083
| 6 5 8
Delhi, India
--Sandeep--
Python OpenERP Developer http://in.linkedin.com/pub/sandeep-rana/3b/a16/786/
Sandeep
On 6/11/13, 11:56 AM

Hello

you can edit view_mode field directly from settings-- >action -- >window action add calender with tree,form like ex :tree,form,calender in your module action

and if module is new then just add calender with tree,form in view_mode field in action view of your model then your action should be like this:

                <record id="your_action_id" model="ir.actions.act_window">
                <field name="name">your model</field>
                <field name="res_model">your.model</field>
                <field name="view_type">form</field>
                <field name="view_mode">tree,form,calendar</field>
                </record>

Thanks
Sandeep

3

Sudhir Arya (SA)

--Sudhir Arya (SA)--
10150
| 6 8 8
Ahmedabad, India
--Sudhir Arya (SA)--

Working as an OpenERP/Odoo developer and a Team Leader 

Top 5 Odoo contributor On Stackoverflow

LinkedIn

Blog

Stackoverflow

Sudhir Arya (SA)
On 6/11/13, 11:32 AM

Did you add calendar in view_mode in action?

Like this:

`view_mode=form,tree,calendar`

Go to Settings / Actions / Window Actions then search for your action and open from view. Add calendar in View Mode field as shown in image.

image description

Agree with Sudhir. This will work for sure.

AB Consultant
on 6/11/13, 11:59 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 6/11/13, 10:50 AM
Seen: 1374 times
Last updated: 3/16/15, 8:10 AM